phpfcgi mit apache

Apache, Lighttpd, nginx, Cherokee
xeron
Posts: 8
Joined: 2006-07-28 15:15

phpfcgi mit apache

Post by xeron »

hallo

ich bin gerade dabei php als fcgi zum laufen zu bekommen, habe dazu das tutorial auf http://archiv.debianhowto.de/de/apache2 ... sarge.html befolgt.

allerdings funktioniert das ganze bei mir nicht so wie es soll, ich bekomme einen internal server error wenn ich ein php file aufrufe, im error_log steht folgendes:
[Wed Jul 19 21:19:54 2006] [warn] FastCGI: server "/var/www/php-fcgi-scripts/test.vhost/php-fcgi-starter" (uid 1001, gid 104) restarted (pid 6121)
[Wed Jul 19 21:19:54 2006] [warn] FastCGI: server "/var/www/php-fcgi-scripts/test.vhost/php-fcgi-starter" (pid 6121) terminated by calling exit with status '0'
[Wed Jul 19 21:19:59 2006] [warn] FastCGI: server "/var/www/php-fcgi-scripts/test.vhost/php-fcgi-starter" (uid 1001, gid 104) restarted (pid 6122)
[Wed Jul 19 21:19:59 2006] [warn] FastCGI: server "/var/www/php-fcgi-scripts/test.vhost/php-fcgi-starter" (pid 6122) terminated by calling exit with status '0'
[Wed Jul 19 21:20:04 2006] [warn] FastCGI: server "/var/www/php-fcgi-scripts/test.vhost/php-fcgi-starter" (uid 1001, gid 104) restarted (pid 6123)
[Wed Jul 19 21:20:04 2006] [warn] FastCGI: server "/var/www/php-fcgi-scripts/test.vhost/php-fcgi-starter" (pid 6123) terminated by calling exit with status '0'
[Wed Jul 19 21:20:09 2006] [warn] FastCGI: server "/var/www/php-fcgi-scripts/test.vhost/php-fcgi-starter" (uid 1001, gid 104) restarted (pid 6124)
[Wed Jul 19 21:20:09 2006] [warn] FastCGI: server "/var/www/php-fcgi-scripts/test.vhost/php-fcgi-starter" (pid 6124) terminated by calling exit with status '0'
[Wed Jul 19 21:20:14 2006] [warn] FastCGI: server "/var/www/php-fcgi-scripts/test.vhost/php-fcgi-starter" (uid 1001, gid 104) restarted (pid 6125)
[Wed Jul 19 21:20:14 2006] [warn] FastCGI: server "/var/www/php-fcgi-scripts/test.vhost/php-fcgi-starter" (pid 6125) terminated by calling exit with status '0'
[Wed Jul 19 21:20:19 2006] [warn] FastCGI: server "/var/www/php-fcgi-scripts/test.vhost/php-fcgi-starter" (uid 1001, gid 104) restarted (pid 6126)
[Wed Jul 19 21:20:19 2006] [warn] FastCGI: server "/var/www/php-fcgi-scripts/test.vhost/php-fcgi-starter" (pid 6126) terminated by calling exit with status '0'
hat vielleicht jemand eine glaskugel zur hand, oder soll ich die configs dazuposten?
xeron
Posts: 8
Joined: 2006-07-28 15:15

Re: phpfcgi mit apache

Post by xeron »

ich habe php mit folgenden parametern kompiliert
./configure
--enable-force-cgi-redirect
--disable-debug
--disable-rpath
--enable-inline-optimization
--with-bz2
--with-gd
--enable-gd-native-ttf
--without-gdbm
--with-gettext
--with-gmp
--with-iconv
--with-openssl
--with-png
--with-pspell
--with-xml
--with-dom
--with-dom-xslt
--with-dom-exslt
--with-pcre-regex
--with-zlib
--enable-bcmath
--enable-exif
--enable-ftp
--enable-magic-quotes
--enable-sockets
--enable-sysvsem
--enable-sysvshm
--enable-track-vars
--enable-trans-sid
--with-pear
--with-mysql
--enable-memory-limit
--with-mime-magic
--with-apxs2=/usr/bin/apxs2
--without-sqlite
--without-mm
--enable-fastgi
--prefix=/home/xeron/php5
wenn ich allerdings das binary nach dem kompilieren aufrufe bekomme ich
PHP 5.1.4 (cli)
anstatt PHP 5.x.x (cgi-fcgi) wie im tutorial beschrieben.

aber nun zu den configs:

/etc/apache2/mods-available/fastcgi.conf
FastCgiWrapper /usr/lib/apache2/suexec2
FastCgiServer /var/www/php-fcgi-scripts/test.vhost/php-fcgi-starter -user phpfcgi -group phpfcgi

AddHandler php-fastcgi .php

<Location /cgi-bin/php-fcgi-starter>
SetHandler fastcgi-script
Options +ExecCGI
</Location>

Action php-fastcgi /cgi-bin/php-fcgi-starter

AddType application/x-httpd-php .php
default vhost config
NameVirtualHost *
<VirtualHost *>
DocumentRoot /var/www/test.vhost/web
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>
<Directory /var/www/test.vhost>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>

ScriptAlias /cgi-bin/ /var/www/php-fcgi-scripts/test.vhost/
<Directory "/var/www/php-fcgi-scripts/test.vhost">
AllowOverride None
Options +ExecCGI -MultiViews -Indexes
Order allow,deny
Allow from all
</Directory>
SuexecUserGroup phpfcgi phpfcgi
ErrorLog /var/log/apache2/error.log
/var/www/php-fcgi-scripts/test.vhost/php-fcgi-starter
#!/bin/sh
PHPRC="/var/www/test.vhost/conf/"
export PHPRC
PHP_FCGI_CHILDREN=4
export PHP_FCGI_CHILDREN
exec /home/xeron/php5/bin/php-fcgi
ein ls -lR aus /var/www
.:
total 3
drwxr-sr-x 3 root www-data 1024 2006-07-19 21:10 php-fcgi-scripts
-rw-rw-r-- 1 root www-data 1000 2006-07-19 19:24 Welcome.html
drwxr-sr-x 4 root root 1024 2006-07-19 21:10 test.vhost

./php-fcgi-scripts:
total 1
drwxr-sr-x 2 phpfcgi phpfcgi 1024 2006-07-19 21:16 test.vhost

./php-fcgi-scripts/test.vhost:
total 1
-rwxr-xr-x 1 phpfcgi phpfcgi 144 2006-07-19 21:11 php-fcgi-starter

./test.vhost:
total 2
drwxr-sr-x 2 root root 1024 2006-07-19 21:33 conf
drwxr-sr-x 2 phpfcgi phpfcgi 1024 2006-07-19 21:28 web

./test.vhost/conf:
total 46
-rw-r--r-- 1 root root 46066 2006-07-19 21:33 php.ini

./test.vhost/web:
total 2
-rw-r--r-- 1 phpfcgi phpfcgi 20 2006-07-19 21:14 index.php
phpfcgi heisst mein benutzer/gruppe für den vhost

weiss keiner woher der fehler stammt, aus der error_log werd ich nicht schlau :(
athlux
Posts: 61
Joined: 2004-08-20 13:53

Re: phpfcgi mit apache

Post by athlux »

Es scheint am PHP-Binary zu liegen.

Folgendes mal weglassen, denn damit wird eigentlich das Apache Modul für PHP gebaut.

Code: Select all

--with-apxs2=/usr/bin/apxs2  
siehe auch ./configure --help


Hier ist übrigens eine neuere Version des HowTos zu finden.
http://www.debianhowto.de/doku.php/de:h ... 2_php-fcgi
xeron
Posts: 8
Joined: 2006-07-28 15:15

Re: phpfcgi mit apache

Post by xeron »

das wars!
fast.

mit den parametern aus meinem configure zeigt php -v dann "PHP 5.1.4 (cgi)" an, welches immer noch nicht funktioniert.
ich habe nochmal versucht das configure aus dem howto zu übernehmen, damit funktioniert jetzt auch alles.

jetzt heisst es noch rausfinden an welcher option das gelegen hat 8)

großes danke an Athlux :wink:
oxygen
Posts: 2138
Joined: 2002-12-15 00:10
Location: Bergheim

Re: phpfcgi mit apache

Post by oxygen »

an --enable-fastcgi natürlich...