Confixx 3.2 mit Courier IMAPd leere Anzeige im Webmail

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
systemchef
Posts: 9
Joined: 2003-10-21 18:50
Location: Esslingen

Confixx 3.2 mit Courier IMAPd leere Anzeige im Webmail

Post by systemchef » 2006-07-14 11:28

Hallo,

ich habe gestern nacht das Confixx Update 3.2 Pro eingespielt sowie von qpopper auf courier imapd und pop3d umgestellt (mbox konvertiert in Maildir, Maildir liegt jetzt unter $HOME/Maildir).
Läuft soweit alles, Maileingang läuft per Postfix über procmail (mit spamassassin und clamassassin / clamAV) an Maildir Eingang.
Das einzige Problem ist, daß mir im Webmail die INBOX eine leere Seite anzeigt wenn mehr als 25-30 Emails im Eingang sind.
Sind weniger Emails da funktioniert die Anzeige, auch versenden funktioniert.


Bei vielen Nachrichten im Posteingang ist die rechte Seite im Webmail leer und es steht im Logfile:

Jul 14 11:19:21 p15162508 imapd: Connection, ip=[::ffff:127.0.0.1]
Jul 14 11:19:21 p15162508 imapd: LOGIN: DEBUG: ip=[::ffff:127.0.0.1], command=LOGIN
Jul 14 11:19:21 p15162508 imapd: LOGIN: DEBUG: ip=[::ffff:127.0.0.1], username=web1p3
Jul 14 11:19:21 p15162508 imapd: LOGIN, user=web1p3, ip=[::ffff:127.0.0.1], protocol=IMAP
Jul 14 11:19:21 p15162508 imapd: LOGOUT, user=web1p3, ip=[::ffff:127.0.0.1], headers=0, body=0
Jul 14 11:19:21 p15162508 imapd: Connection, ip=[::ffff:127.0.0.1]
Jul 14 11:19:21 p15162508 imapd: LOGIN: DEBUG: ip=[::ffff:127.0.0.1], command=LOGIN
Jul 14 11:19:21 p15162508 imapd: LOGIN: DEBUG: ip=[::ffff:127.0.0.1], username=web1p3
Jul 14 11:19:22 p15162508 imapd: Connection, ip=[::ffff:127.0.0.1]
Jul 14 11:19:22 p15162508 imapd: LOGIN: DEBUG: ip=[::ffff:127.0.0.1], command=LOGIN
Jul 14 11:19:22 p15162508 imapd: LOGIN: DEBUG: ip=[::ffff:127.0.0.1], username=web1p3
Jul 14 11:19:22 p15162508 imapd: LOGIN, user=web1p3, ip=[::ffff:127.0.0.1], protocol=IMAP
Jul 14 11:19:22 p15162508 imapd: LOGIN, user=web1p3, ip=[::ffff:127.0.0.1], protocol=IMAP
Jul 14 11:19:26 p15162508 imapd: LOGOUT, user=web1p3, ip=[::ffff:127.0.0.1], headers=236611, body=4113750
Jul 14 11:19:26 p15162508 imapd: LOGOUT, user=web1p3, ip=[::ffff:127.0.0.1], headers=236611, body=4113750


Bei wenigen Nachrichten im Posteingang wird die rechte Seite im Webmail korrekt angezeigt und es steht im Logfile:


Jul 14 11:19:33 p15162508 imapd: Connection, ip=[::ffff:127.0.0.1]
Jul 14 11:19:33 p15162508 imapd: LOGIN: DEBUG: ip=[::ffff:127.0.0.1], command=LOGIN
Jul 14 11:19:33 p15162508 imapd: LOGIN: DEBUG: ip=[::ffff:127.0.0.1], username=web1p8
Jul 14 11:19:33 p15162508 imapd: LOGIN, user=web1p8, ip=[::ffff:127.0.0.1], protocol=IMAP
Jul 14 11:19:33 p15162508 imapd: LOGOUT, user=web1p8, ip=[::ffff:127.0.0.1], headers=0, body=0
Jul 14 11:19:34 p15162508 imapd: Connection, ip=[::ffff:127.0.0.1]
Jul 14 11:19:34 p15162508 imapd: LOGIN: DEBUG: ip=[::ffff:127.0.0.1], command=LOGIN
Jul 14 11:19:34 p15162508 imapd: LOGIN: DEBUG: ip=[::ffff:127.0.0.1], username=web1p8
Jul 14 11:19:34 p15162508 imapd: Connection, ip=[::ffff:127.0.0.1]
Jul 14 11:19:34 p15162508 imapd: LOGIN, user=web1p8, ip=[::ffff:127.0.0.1], protocol=IMAP
Jul 14 11:19:34 p15162508 imapd: LOGIN: DEBUG: ip=[::ffff:127.0.0.1], command=LOGIN
Jul 14 11:19:34 p15162508 imapd: LOGIN: DEBUG: ip=[::ffff:127.0.0.1], username=web1p8
Jul 14 11:19:34 p15162508 imapd: LOGIN, user=web1p8, ip=[::ffff:127.0.0.1], protocol=IMAP
Jul 14 11:19:34 p15162508 imapd: LOGOUT, user=web1p8, ip=[::ffff:127.0.0.1], headers=1293, body=30182
Jul 14 11:19:35 p15162508 imapd: LOGOUT, user=web1p8, ip=[::ffff:127.0.0.1], headers=1293, body=30182

Irgendjemand eine Idee? Gibt es einen Timeout, der zu niedrig gesetzt ist oder was derartiges?

flo
RSAC
Posts: 2297
Joined: 2002-07-28 13:02
Location: Berlin

Re: Confixx 3.2 mit Courier IMAPd leere Anzeige im Webmail

Post by flo » 2006-07-14 16:13

max_execution_time
ist Dein Freund - oder mal die Mailbox aufräumen :-)

flo.

systemchef
Posts: 9
Joined: 2003-10-21 18:50
Location: Esslingen

Re: Confixx 3.2 mit Courier IMAPd leere Anzeige im Webmail

Post by systemchef » 2006-07-14 17:55

ne, eben nicht, die ist auf 60 Sekunden gesetzt, der Verbindungsaufbau fliegt aber schon nach 3-5 Sekunden auf die Nase und sagt "beendet".

flo
RSAC
Posts: 2297
Joined: 2002-07-28 13:02
Location: Berlin

Re: Confixx 3.2 mit Courier IMAPd leere Anzeige im Webmail

Post by flo » 2006-07-14 18:08

wie schaut es denn mit Fehlern aus? Ist die Darstellung bei Dir abgeschalten?

Allgemein am IMAP-Modul kann es nicht liegen, sonst würde das nie funktionieren.

flo.

systemchef
Posts: 9
Joined: 2003-10-21 18:50
Location: Esslingen

Re: Confixx 3.2 mit Courier IMAPd leere Anzeige im Webmail

Post by systemchef » 2006-07-17 09:51

IMAP funktioniert ja auch ohne Probleme mit jedem beliebigen IMAP-Client (Outlook, Thunderbird, ...). Nur eben die Webmail Ansicht nicht.

salix
Posts: 6
Joined: 2004-08-12 00:32

gleiches Problem auch ohne IMAPd

Post by salix » 2006-07-17 18:41

Hallo,

ich habe o.g. Problem (keine Anzeige bei etwas größerer Mailbox, bei anderen (noch größeren geht es dann wieder ... *#*#* confixx) auch ohne imapd. :(

Hat noch jemand eine Idee?

Vielen Dank
Salix

systemchef
Posts: 9
Joined: 2003-10-21 18:50
Location: Esslingen

Re: Confixx 3.2 mit Courier IMAPd leere Anzeige im Webmail

Post by systemchef » 2006-07-17 23:30

das hab ich auch schon festgestellt, auch Confixx zurückstellen auf POP3 bringt keine Änderung. Ausserdem funktionert der IMAP-Abruf per E-Mail-Programm ohne Probleme. Muß also definitiv ein Skript-Problem sein. Leider gibt weder Apache noch der Imapd eine Syslog-Meldung raus, die Aufschluss über den Fehler geben würde.

caput
Posts: 48
Joined: 2005-06-08 02:06

Re: Confixx 3.2 mit Courier IMAPd leere Anzeige im Webmail

Post by caput » 2006-07-18 20:54

Vergiss das pampige Webinterface von Confixx. RoundCube ist in Sachen IMAP-Webinterface unschlagbar.

http://trac.roundcube.net

nasenmann
Posts: 13
Joined: 2006-02-19 23:52

Re: Confixx 3.2 mit Courier IMAPd leere Anzeige im Webmail

Post by nasenmann » 2006-09-15 14:51

@Systemchef, Salix: Welche Confixx Versionen habt ihr installiert?