apt-get nachinstallieren unter SuSe 10.0

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
opakatze
Posts: 11
Joined: 2006-07-07 12:09

apt-get nachinstallieren unter SuSe 10.0

Post by opakatze » 2006-07-10 21:25

Guten Abend zusammen,

auf meinem "Server" ist die Funktion "apt-get" über SSH nicht aufrufbar, da "apt-get" nicht vorhanden ist. Gibt es eine Möglichkeit, "apt-get" unter SuSe 10.0 nachinstallieren zu können?
Downloadquellen wären ganz nützlich, habe bis jetzt noch nichts gefunden.
Vielen Dank für Eure Hilfe! :-D

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: apt-get nachinstallieren unter SuSe 10.0

Post by Roger Wilco » 2006-07-10 21:46

Hast du irgendetwas gegen YaST?
Außerdem habe ich irgendwie den Eindruck, SuSE wird nur noch von Analphabeten oder übelst lesefaulen Benutzern eingesetzt...

http://www.novell.com/products/linuxpac ... x/apt.html

opakatze
Posts: 11
Joined: 2006-07-07 12:09

Re: apt-get nachinstallieren unter SuSe 10.0

Post by opakatze » 2006-07-10 22:16

Roger Wilco wrote:Hast du irgendetwas gegen YaST?
Na ja, grundsätzlich ja nicht, aber der Online Updater scheitert schon mal bei jedem Packet mit folgender Meldung:

Code: Select all

ERROR(You:RPM has invalid signature.) 
Da stimmt also die RPM-Sigantur bei mir nicht. Weiß jemand, wie ich dieses Problem beheben kann?

Zusätzlich würde ich gerne das Apache-Entwicklungs-RPM-Paket installieren, da wäre die "apt-get"-Variante sehr zuvorkommend. Über Yast ist dies sicherlich auch möglich, aber ich finde wieder die Quellen nicht. :?:

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: apt-get nachinstallieren unter SuSe 10.0

Post by Roger Wilco » 2006-07-10 22:20

opakatze wrote:Da stimmt also die RPM-Sigantur bei mir nicht. Weiß jemand, wie ich dieses Problem beheben kann?
http://en.opensuse.org/SDB:YOU_or_RPM_R ... Signatures
Soviel zu lesefaulem Gemüse.

opakatze
Posts: 11
Joined: 2006-07-07 12:09

Re: apt-get nachinstallieren unter SuSe 10.0

Post by opakatze » 2006-07-11 17:03

Ich habe mir jetzt die oben genannte Webseite einmal genauer angesehen und bin die Anleitung durchgegangen. Dennoch scheinen bei mir alle Keys vorhanden und nicht abgelaufen zu sein:

Code: Select all

pub   1024D/9C800ACA 2000-10-19 [expires: 2008-06-21]
uid                  SuSE Package Signing Key <build@suse.de>
sub   2048g/8495160C 2000-10-19 [expires: 2008-06-21]

pub   2048R/3D25D3D9 1999-03-06
uid                  SuSE Security Team <security@suse.de>

pub   1024D/0DFB3188 2005-01-18
uid                  Open Enterprise Server <support@novell.com>

pub   1024D/15C17DEB 2003-10-28 [expires: 2008-10-26]
uid                  Java Desktop Package Signing Key 
Dennoch besteht das Problem weiterhin und es sind keine Online-Updates möglich. Welches Problem könnte man nun noch in Erwägung ziehen? Für Hilfe freue ich mich sehr.
:-D