Amavis zu restriktiv

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
mcdoogle
Posts: 178
Joined: 2003-07-15 13:36

Amavis zu restriktiv

Post by mcdoogle » 2006-07-05 22:28

Mein Amavis filtert mir etliche Mails heraus, da sie vom Absender ungenau - ich möchte fast sagen falsch - kodiert wurden.
Der Empfänger einer solchen ail bekommt dann:


Subject: INVALID HEADER in mail TO YOU from ...
Mail: Our content checker found
Non-encoded 8-bit data (char E4 hex): Subject: ... Antworten - Aufgabe:
Schaft / Zirkularfr344senn


Da steckt ein "deutsches Zeichen" drin was den zu dieser Meldung bringt.

Oder ein anderer Grund ist:

Subject: INVALID HEADER in mail TO YOU from ...
Mail: Our content checker found
MIME error: error: part did not end with expected boundary
Non-encoded 8-bit data (char AE hex): Subject: Grillen wie die
Weltmeister. | Shirtalarm.de256n

Die Mail ist im Grunde auch o.k. Aber eben nicht korrekt codiert.

Wie kann ich in der Amavis config dieses Verhalten regeln?

dnspyder
Posts: 111
Joined: 2006-03-10 07:13
Location: Dortmund

Re: Amavis zu restriktiv

Post by dnspyder » 2006-07-06 21:16

Die amavisd Config hast du dir aber schon mal angeschaut... oder?

mcdoogle
Posts: 178
Joined: 2003-07-15 13:36

Re: Amavis zu restriktiv

Post by mcdoogle » 2006-07-07 11:03

Ja klar!
Ich hab den amavis bei der Installation komplett konfiguriert und das meiste funktioniert auch entsprechend meiner Vorstellungen.

Nur eben o.g. Problem hab ich. Ich hab auf die Schnelle mal die config durchgesehen und keinen Parameter gefunden der mir Abhilfe besorgen könnte! Leider!

Ideen?

oxygen
RSAC
Posts: 2179
Joined: 2002-12-15 00:10
Location: Bergheim

Re: Amavis zu restriktiv

Post by oxygen » 2006-07-07 22:29

Auszug aus der local.cf von SpamAssassin:

Code: Select all

# Mail using languages used in these country codes will not be marked
# as being possibly spam in a foreign language.
ok_languages           de en

# Mail using locales used in these country codes will not be marked
# as being possibly spam in a foreign language.
# ok_locales              all

zg0re
Posts: 104
Joined: 2003-06-04 15:33

Re: Amavis zu restriktiv

Post by zg0re » 2006-07-07 23:31

Das liegt eher nicht an der sa config ;)

Schau mal in der amavis config, ob du folgendes aktiviert hast:

#$warnbadhrecip = 1; # (defaults to false (undef))

das würde, wenn auskommentiert, nämlich genau dieses Verhalten hervorrufen.