Mal wieder Open Relay mit QMail

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
lurker
Posts: 9
Joined: 2006-06-27 08:48

Mal wieder Open Relay mit QMail

Post by lurker » 2006-06-27 09:21

Hallo,

ich habe seit 2 Wochen meinen ersten Root-Server. Dabei habe ich ein Virtuozzo Image mit Debian Sarge als Grundlage und Plesk 8.01 als Admintool installiert. Plesk hat QMail als E-Mail Tool eingerichtet, an dieser Standardkonfiguration habe ich bislang nichts geändert.

In Plesk selbst habe ich für alle Domains SMTP-AUTH aktiviert, aber scheinbar ist diese Einstellung wirklungslos:

Code: Select all

telnet mail.cycit.de 25

220 host.cycit.de ESMTP
mail from:someone@somewhere.com
250 ok
rcpt to:someone@otherdomain.com
250 ok
data
354 go ahead
subject=test
content
.
250 ok 1151387948 qp 1062
Mein Mailserver nimmt also alles von überall über SMTP an, was mir gar nicht gefällt. Momentan habe ich QMail aber gestoppt, so dass der o.g. Ablauf nicht mehr möglich ist.

Ein EHLO zeigt folgendes an:

Code: Select all

ehlo host.cycit.de
250-host.cycit.de
250-STARTTLS
250-PIPELINING
250 8BITMIME
Wer kann mir behilflich sein die Ursache für dieses Probelem zu finden? Welche Konfigurationsdateien soll ich posten? /var/qmail/control/defaultdomain / locals / me / rcpthosts oder alle?

Grüße,
Lurker

sledge0303
RSAC
Posts: 767
Joined: 2005-09-16 00:06
Location: Berlin-Reinickendorf

Re: Mal wieder Open Relay mit QMail

Post by sledge0303 » 2006-06-27 09:37

Eigentlich wird mit Plesk Qmail so konfiguriert das kein Open Relay entsteht. Du hast auf der Adminoberfläche, ich kenne nur die 7.5.4 - benutze jetzt aber kein Plesk mehr, eine Option bei Mail und dort kannst die Authentifizierungsart festlegen. Hast dort schon mal nachgeschaut?
Ansonsten musst aufpassen das nach Änderungen Plesk diese nach einem evtl. update nicht überschreibt.
Wenn das nicht klappt, poste mal die entsprechenden Konfigdateien

kenzo
RSAC
Posts: 530
Joined: 2003-07-15 20:30

Re: Mal wieder Open Relay mit QMail

Post by kenzo » 2006-06-27 09:45

Einfacher ist es, die gesamte Ausgabe von

Code: Select all

/var/qmail/bin/qmail-showctl
zu posten. Und bitte beende den qmail-smtpd, damit niemand über deinen Server Spam los wird.
Last edited by kenzo on 2006-06-27 09:46, edited 1 time in total.

lurker
Posts: 9
Joined: 2006-06-27 08:48

Re: Mal wieder Open Relay mit QMail

Post by lurker » 2006-06-27 09:45

sledge0303 wrote:Eigentlich wird mit Plesk Qmail so konfiguriert das kein Open Relay entsteht. Du hast auf der Adminoberfläche, ich kenne nur die 7.5.4 - benutze jetzt aber kein Plesk mehr, eine Option bei Mail und dort kannst die Authentifizierungsart festlegen. Hast dort schon mal nachgeschaut?
Ansonsten musst aufpassen das nach Änderungen Plesk diese nach einem evtl. update nicht überschreibt.
Wenn das nicht klappt, poste mal die entsprechenden Konfigdateien
In Plesk habe ich die Authentifizierungsart richtig eingestellt, nur scheinbar hat dies keine Auswirkung. Ich habe gerade bei swsoft noch einen Thread gefunden, welcher zeigt das es wohl tatsächlich ein aktuelles Problem gibt. Nur auf den SWSoft-Support zu vertrauen und zu warten ist wohl auch nicht das wahre. Ich poste später mal die Konfig-Dateien.

Grüße,
Jürgen

lurker
Posts: 9
Joined: 2006-06-27 08:48

Re: Mal wieder Open Relay mit QMail

Post by lurker » 2006-06-27 09:59

kenzo wrote:Einfacher ist es, die gesamte Ausgabe von

Code: Select all

/var/qmail/bin/qmail-showctl
zu posten. Und bitte beende den qmail-smtpd, damit niemand über deinen Server Spam los wird.
Werde ich machen, und qmail (smtpd) ist natürlich bereits gestoppt:
Lurker wrote:Momentan habe ich QMail aber gestoppt, so dass der o.g. Ablauf nicht mehr möglich ist.

os-t
Posts: 65
Joined: 2006-06-05 16:06

Re: Mal wieder Open Relay mit QMail

Post by os-t » 2006-06-27 11:07

Hi,

ich habe einen Server mit Plesk 7.5.4 und einen mit Plesk 8.0 und beide haben KEIN Open Relay. Ich habe keinerlei manuelle Einstellungen am QMail vorgenommen, sondern nur über Plesk konfiguriert.

Gruß Markus

lurker
Posts: 9
Joined: 2006-06-27 08:48

Re: Mal wieder Open Relay mit QMail

Post by lurker » 2006-06-27 22:02

os-t wrote:ich habe einen Server mit Plesk 7.5.4 und einen mit Plesk 8.0 und beide haben KEIN Open Relay. Ich habe keinerlei manuelle Einstellungen am QMail vorgenommen, sondern nur über Plesk konfiguriert.
Ich vermute auch dass es nicht jeden betrifft, sonst würde sich SWSOFT nicht so taub stellen. Ich habe nur leider mit qmail zu wenig bis keine Erfahrung um das zu beurteilen, aber irgendwo muss der Wurm drin sein. Und die Einstellungen in Plesk habe ich jetzt schon zig-mal kontrolliert, sowohl aus Server, Client also auch Domain Sicht. Was das Relaying betrifft kann man nur unter der Serversicht etwas einstellen:

Maximum letter size and relay mode parameters:
Relaying -> authorization is required -> SMTP

ist aktiv.

Hier nun die Ausgabe von /var/qmail/bin/qmail-showctl:

Code: Select all

qmail home directory: /var/qmail.
user-ext delimiter: -.
paternalism (in decimal): 2.
silent concurrency limit: 1000.
subdirectory split: 23.
user ids: 2021, 2020, 2022, 0, 2023, 2520, 2521, 2522.
group ids: 2020, 2520.

badmailfrom: (Default.) Any MAIL FROM is allowed.

bouncefrom: (Default.) Bounce user name is MAILER-DAEMON.

bouncehost: (Default.) Bounce host name is host.cycit.de.

concurrencylocal: (Default.) Local concurrency is 10.

concurrencyremote: (Default.) Remote concurrency is 20.

databytes: SMTP DATA limit is 4194304 bytes.

defaultdomain: (Default.) Default domain name is host.cycit.de.

defaulthost: (Default.) Default host name is host.cycit.de.

doublebouncehost: (Default.) 2B recipient host: host.cycit.de.

doublebounceto: (Default.) 2B recipient user: postmaster.

envnoathost: (Default.) Presumed domain name is host.cycit.de.

helohost: (Default.) SMTP client HELO host name is host.cycit.de.

idhost: (Default.) Message-ID host name is host.cycit.de.

localiphost: (Default.) Local IP address becomes host.cycit.de.

locals:
Messages for localhost are delivered locally.

me: My name is host.cycit.de.

percenthack: (Default.) The percent hack is not allowed.

plusdomain: (Default.) Plus domain name is host.cycit.de.

qmqpservers: (Default.) No QMQP servers.

queuelifetime: (Default.) Message lifetime in the queue is 604800 seconds.

rcpthosts:
SMTP clients may send messages to recipients at cycit.de.
SMTP clients may send messages to recipients at bruchsaler-links.de.

morercpthosts: (Default.) No effect.

morercpthosts.cdb: (Default.) No effect.

smtpgreeting: (Default.) SMTP greeting: 220 host.cycit.de.

smtproutes: (Default.) No artificial SMTP routes.

spfbehavior: The SPF behavior is 0.

spfexp: (Default.) The SPF default explanation is: 550 See http://spf.pobox.com/why.html?sender=%{S}&ip=%{I}&receiver=%{xR}.

spfguess: (Default.) The guess SPF rules are: .

spfrules: (Default.) The local SPF rules are: .

timeoutconnect: (Default.) SMTP client connection timeout is 60 seconds.

timeoutremote: (Default.) SMTP client data timeout is 1200 seconds.

timeoutsmtpd: (Default.) SMTP server data timeout is 1200 seconds.

virtualdomains:
Virtual domain: cycit.de:1
Virtual domain: bruchsaler-links.de:3

smtpplugins: I have no idea what this file does.

rsa512.pem: I have no idea what this file does.

dh512.pem: I have no idea what this file does.

dh1024.pem: I have no idea what this file does.

servercert.pem: I have no idea what this file does.

clientcert.pem: I have no idea what this file does.

rejectnonexist: I have no idea what this file does.
Vielen dank für's drüberschauen.

Grüße,
Jürgen

lurker
Posts: 9
Joined: 2006-06-27 08:48

Re: Mal wieder Open Relay mit QMail

Post by lurker » 2006-06-28 18:44

os-t wrote:ich habe einen Server mit Plesk 7.5.4 und einen mit Plesk 8.0 und beide haben KEIN Open Relay. Ich habe keinerlei manuelle Einstellungen am QMail vorgenommen, sondern nur über Plesk konfiguriert.
Ich teste gerade mal wieder. Es ist wirklich seltsam, selbst wenn ich in Plesk die Option "Relaying" auf "Closed" setze ändert sich nichts am verhalten. An den Config-Dateien im Ordner control ändert sich hierdurch auch nichts, welche Config-Dateien betreffen denn das Relaying?
Hat wirklich niemand eine Idee?

Grüße,
Jürgen

kenzo
RSAC
Posts: 530
Joined: 2003-07-15 20:30

Re: Mal wieder Open Relay mit QMail

Post by kenzo » 2006-06-28 22:01

Das Problem ist, daß es einfach am modifizierten qmail liegen kann und keiner weiß, was die wo flahsc gemacht haben. Guck mal in den Startskript, irgendwo sollte etwas von

Code: Select all

tcpserver (...) -x /(...)/tcp.smtp.cdb
oder ähnliches stehen. Poste den Inhalt der Datei ohne .cdb, also z.B. tcp.smtp.

lurker
Posts: 9
Joined: 2006-06-27 08:48

Re: Mal wieder Open Relay mit QMail

Post by lurker » 2006-06-30 16:05

kenzo wrote:Das Problem ist, daß es einfach am modifizierten qmail liegen kann und keiner weiß, was die wo flahsc gemacht haben. Guck mal in den Startskript, irgendwo sollte etwas von

Code: Select all

tcpserver (...) -x /(...)/tcp.smtp.cdb
oder ähnliches stehen. Poste den Inhalt der Datei ohne .cdb, also z.B. tcp.smtp.
Danke für die Antwort, gibt es bei mir aber leider nicht, soweit ich herausgefunden habe baut das plesk qmail aber auch nicht auf dem tcpserver auf, sondern auf xinetd.d

Hier irgendwelche Ideen was ich prüfen könnte?

Viele Grüße,
Jürgen

lurker
Posts: 9
Joined: 2006-06-27 08:48

Re: Mal wieder Open Relay mit QMail

Post by lurker » 2006-07-01 00:05

Ich habe es rausgefunden, die Lösung stand sogar schon im Thread bei SWSoft welchen ich gefunden hatte:

Im Ordner /etc/xinetd.d gab es zwei Dateien welche den SMTP-Dienst übernehmen wollten; sendmail und smtp_psa. Aus irgendeinem Grund wurde sendmail genommen was natürlich an QMail-Einstellungen vorbeiging.

Ich habe sendmail gelöscht, xinetd und qmail neu gestartet und schon geht alles.

Eines verstehe ich noch nicht: Ich habe gestern testweise ein paar Einträge in /var/qmail/control/badmailfrom vorgenommen, und wenn ich Mails mit einer solchen Absenderadresse über Telnet erzeugen wollte habe ich eine 553-Meldung bekommen. Deswegen war ich mir eigentlich sicher in QMail zu sein. Naja, ich glaube ich will es gar nicht mehr verstehen :roll:

Viele Grüße,
Jürgen