IMAP geht nicht mehr

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
pabera
Posts: 12
Joined: 2006-04-24 11:14

IMAP geht nicht mehr

Post by pabera » 2006-06-12 18:10

hi leute,

und zwar habe ich einen webserver, der hatte bis vor kurzem apache1, php4 und mysql4..

ich habe mich nun ein wenig mit unix vertraut gemacht und habe die jeweils neusten updates installiert..

sprich apache2, php5 und mysql5 .. alles läuft wunderbar.. hab da auch keine probleme.. auch die MAIL-Server ansich (POP und SMTP) funktionieren einwandfrein.. nur mit dem IMAP server hab ich so meine probleme seit dem update geht dieser nicht mehr.. squirrelmail zeigt nur noch einen fehler und outlook weißt mich daraufhin, dass dieser server nicht verfügbar sei! obwohl er ja darüber mails versendet und auch empfängt...

der fehler bei sm sieht so aus:

Code: Select all

Fatal error: Cannot re-assign $this in /usr/share/squirrelmail/class/mime/Message.class.php on line 187
ich habe danach gesucht und darauf hin habe ich sm auf das neuste update gebracht.. hat nix geändert, was ja sicher am IMAP hängt!

ein neustart des COURIER hat nix gebracht..

könnte es am php liegen.. (PHP Version 5.1.4-1.dotdeb.2) am linux? (debian 3.1 sarge)

kennt jemand vielleicht das problem?!
würde mich sehr über ein paar mögliche lösungsvorschläge freuen!!

viele grüße
pat

braindead
RSAC
Posts: 257
Joined: 2002-10-22 09:49
Location: vorm Rechner

Re: IMAP geht nicht mehr

Post by braindead » 2006-06-12 18:14

welche Version von squirrelmail nutzt du? kann die mit php5?!?

pabera
Posts: 12
Joined: 2006-04-24 11:14

Re: IMAP geht nicht mehr

Post by pabera » 2006-06-12 18:28

SquirrelMail version 1.5.0 habe ich.. das läuft denke ich mit php5 ..aber ich denke das hat damit nix zu tun, da eben auch outlook oder thunderbird nicht auf den server zugreifen können.. also nur auf den IMAP server auf meinem root :(

braindead
RSAC
Posts: 257
Joined: 2002-10-22 09:49
Location: vorm Rechner

Re: IMAP geht nicht mehr

Post by braindead » 2006-06-12 18:41

was sagen denn die courier logs? config files?

http://www.squirrelmail.org/wiki/Squirr ... quirements

^^ ich wette das suirrelmail nicht mit php5 läuft *G*

duergner
RSAC
Posts: 976
Joined: 2003-08-20 11:30
Location: Pittsburgh, PA, USA

Re: IMAP geht nicht mehr

Post by duergner » 2006-06-12 18:48

Der Fehler oben ist ein PHP Fehler. Wenn Thunderbird und Outlook nicht zugreifen koennen dann musst du mal in den mail.info oder mail.err Logs nachsehen.

pabera
Posts: 12
Joined: 2006-04-24 11:14

Re: IMAP geht nicht mehr

Post by pabera » 2006-06-12 18:55

Code: Select all

Jun 12 08:33:42 XXX imaplogin: LOGOUT, ip=[::ffff:127.0.0.1]
Jun 12 08:34:29 XXX imaplogin: LOGIN FAILED, ip=[::ffff:127.0.0.1]
Jun 12 08:34:29 XXX imaplogin: DISCONNECTED, ip=[::ffff:127.0.0.1], time=5
Jun 12 08:34:32 XXX imaplogin: LOGIN, user=meine@email.com, ip=[::ffff:127.0.0.1], protocol=IMAP
Jun 12 08:34:32 XXX imaplogin: LOGOUT, user=meine@email.com, ip=[::ffff:127.0.0.1], headers=0, body=0, time=0
Jun 12 08:34:39 XXX imaplogin: LOGOUT, ip=[::ffff:127.0.0.1]
jaja.. das sind die logs aus der mail.info
selbst wenn sm nicht mitz php5 läuft, dann müsste ja zumindest outlook funktionieren.. so richtig aufschluss bringt mir das log leider nicht. fehlt mir ein wenig die erfahrung!!

duergner
RSAC
Posts: 976
Joined: 2003-08-20 11:30
Location: Pittsburgh, PA, USA

Re: IMAP geht nicht mehr

Post by duergner » 2006-06-12 19:00

Loglevel hochstellen.

User avatar
Joe User
Project Manager
Project Manager
Posts: 11583
Joined: 2003-02-27 01:00
Location: Hamburg

Re: IMAP geht nicht mehr

Post by Joe User » 2006-06-12 19:30

Das deaktivieren von IPv6 beziehungsweise Rekompilieren ohne IPv6-Support soll manchmal auch Wunder wirken...
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

pabera
Posts: 12
Joined: 2006-04-24 11:14

Re: IMAP geht nicht mehr

Post by pabera » 2006-06-12 19:38

Joe User wrote:Das deaktivieren von IPv6 beziehungsweise Rekompilieren ohne IPv6-Support soll manchmal auch Wunder wirken...
wie kann man das erst mal abstellen?! recompilieren wird für mich etwas schwierig.. war froh, dass ich das apache2 usw mit hilfe aller tutorials hinbekommen habe :|

wo stellt man das loglevel ein?! habe das nur mal bei mysql gemacht!

duergner
RSAC
Posts: 976
Joined: 2003-08-20 11:30
Location: Pittsburgh, PA, USA

Re: IMAP geht nicht mehr

Post by duergner » 2006-06-12 19:47

Im entsprechenden Configfile!

pabera
Posts: 12
Joined: 2006-04-24 11:14

Re: IMAP geht nicht mehr

Post by pabera » 2006-06-12 20:51

habe jetzt das level auf 2 gesetzt.. da kamen diese einträge hinzu

Code: Select all

Jun 12 19:31:55 XXX imaplogin: LOGIN FAILED, ip=[::ffff:217.68.180.16]
Jun 12 19:31:56 XXX imaplogin: DISCONNECTED, ip=[::ffff:217.68.180.16], time=6
Jun 12 19:31:56 XXX imaplogin: LOGIN: DEBUG: ip=[::ffff:217.68.180.16], command=CAPABILITY
Jun 12 19:31:56 XXX imaplogin: LOGIN: DEBUG: ip=[::ffff:217.68.180.16], command=LOGIN
Jun 12 19:31:56 XXX imaplogin: LOGIN: DEBUG: ip=[::ffff:217.68.180.16], username=XXX
Jun 12 19:31:56 XXX imaplogin: LOGIN: DEBUG: ip=[::ffff:217.68.180.16], password=XXX
ich habe vertrauliche angaben mit XXX ersetzt.. das log sagt, der connect misslingt. was ich nicht verstehe, denn POP und SMTP funktionieren.. passwort und benutzer sind definitiv richtig!! mehr steht nicht im log!!

vg pat

tiberian
Posts: 61
Joined: 2006-04-14 01:45

Re: IMAP geht nicht mehr

Post by tiberian » 2006-06-12 22:07

braindead wrote:^^ ich wette das suirrelmail nicht mit php5 läuft *G*
Und wie es das tut :)

Habs mal damit im Einsatz. Musste allerdings damals auf die 1.4.6 updaten da erst ab dort PHP5 Support drin war.

Grüße
Tiberian

braindead
RSAC
Posts: 257
Joined: 2002-10-22 09:49
Location: vorm Rechner

Re: IMAP geht nicht mehr

Post by braindead » 2006-06-13 09:18

Tiberian wrote:Und wie es das tut :)

Habs mal damit im Einsatz. Musste allerdings damals auf die 1.4.6 updaten da erst ab dort PHP5 Support drin war.

Auf der Sqirrelmailseite steht halt das es net geht, also bin ich auch mal davon ausgegangen das es so ist ;)