Bekomme SFTP nicht zum Laufen

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
mephistos
Posts: 18
Joined: 2004-08-11 23:32

Bekomme SFTP nicht zum Laufen

Post by mephistos » 2006-06-06 15:38

Hallo zusammen

Ich habe einen Root Server, Suse mit Plesk von 1&1.

Nun möchte ich für einen Benutzer SSH bzw. SFTP erlauben.

Ich habe für den User in der sshd.conf folgendes eingefügt

Code: Select all

AllowUsers user_name
Die Aktivierung über

Code: Select all

Subsystem	sftp	/usr/lib/ssh/sftp-server
gabes schon.

Leider kann ich mich weder per SSH noch mit SFTP mit dem User anmelden. Muss ich bei Plesk vlt. irgenwas spezielles beachten oder mache ich generell nur was falsch.

Für Hilfe wäre ich sehr dankbar.
Meph

braindead
RSAC
Posts: 257
Joined: 2002-10-22 09:49
Location: vorm Rechner

Re: Bekomme SFTP nicht zum Laufen

Post by braindead » 2006-06-06 16:04

fehlermeldungen? ssh -vvv?!?

mephistos
Posts: 18
Joined: 2004-08-11 23:32

Re: Bekomme SFTP nicht zum Laufen

Post by mephistos » 2006-06-06 16:15

Hallo

Naja. Als Fehlermeldung kommt halt nur, dass ich mich nicht einloggen kann.

Was genau meinst Du mit ssh -vvv? Die Version?
OpenSSH_4.1p1, OpenSSL 0.9.7d

Sorry, wenn ich mich etwas blöd anstelle, aber ich auf dem Gebiet kein Fachmann.

braindead
RSAC
Posts: 257
Joined: 2002-10-22 09:49
Location: vorm Rechner

Re: Bekomme SFTP nicht zum Laufen

Post by braindead » 2006-06-06 17:22

man ssh? was sagt /var/log?

poste mal deine sshd config!

mephistos
Posts: 18
Joined: 2004-08-11 23:32

Re: Bekomme SFTP nicht zum Laufen

Post by mephistos » 2006-06-06 17:49

Also im Log steht zum Beispiel

Code: Select all

Jun  6 15:10:19 pxx sshd[23417]: Accepted keyboard-interactive/pam for root from xxx.xxx.xxx.xxx port 3703 ssh2
Jun  6 15:12:39 pxx sshd[23543]: Accepted keyboard-interactive/pam for user1 from xxx.xxx.xxx port 3710 ssh2
Jun  6 15:12:58 pxx sshd[23558]: Accepted keyboard-interactive/pam for user1 from xxx.xxx.xxx.xxx port 3715 ssh2
Die sshd_conf sieht folgendermaßen aus

Code: Select all

#	$OpenBSD: sshd_config,v 1.70 2004/12/23 23:11:00 djm Exp $

# This is the sshd server system-wide configuration file.  See
# sshd_config(5) for more information.

# This sshd was compiled with PATH=/usr/bin:/bin:/usr/sbin:/sbin

# The strategy used for options in the default sshd_config shipped with
# OpenSSH is to specify options with their default value where
# possible, but leave them commented.  Uncommented options change a
# default value.

#Port 22
#Protocol 2,1
#AddressFamily any
#ListenAddress 0.0.0.0
#ListenAddress ::

# HostKey for protocol version 1
#HostKey /etc/ssh/ssh_host_key
# HostKeys for protocol version 2
#HostKey /etc/ssh/ssh_host_rsa_key
#HostKey /etc/ssh/ssh_host_dsa_key

# Lifetime and size of ephemeral version 1 server key
#KeyRegenerationInterval 1h
#ServerKeyBits 768

# Logging
#obsoletes QuietMode and FascistLogging
#SyslogFacility AUTH
#LogLevel INFO

# Authentication:

AllowUsers user1

#LoginGraceTime 2m
#PermitRootLogin yes
#StrictModes yes
#MaxAuthTries 6

#RSAAuthentication yes
#PubkeyAuthentication yes
#AuthorizedKeysFile	.ssh/authorized_keys

# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
#RhostsRSAAuthentication no
# similar for protocol version 2
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# RhostsRSAAuthentication and HostbasedAuthentication
#IgnoreUserKnownHosts no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes

# To disable tunneled clear text passwords, change to no here!
PasswordAuthentication yes
#PermitEmptyPasswords no

# Change to no to disable s/key passwords
#ChallengeResponseAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes
#KerberosGetAFSToken no

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

# Set this to 'yes' to enable support for the deprecated 'gssapi' authentication
# mechanism to OpenSSH 3.8p1. The newer 'gssapi-with-mic' mechanism is included
# in this release. The use of 'gssapi' is deprecated due to the presence of 
# potential man-in-the-middle attacks, which 'gssapi-with-mic' is not susceptible to.
#GSSAPIEnableMITMAttack no
 

# Set this to 'yes' to enable PAM authentication, account processing, 
# and session processing. If this is enabled, PAM authentication will 
# be allowed through the ChallengeResponseAuthentication mechanism. 
# Depending on your PAM configuration, this may bypass the setting of 
# PasswordAuthentication, PermitEmptyPasswords, and 
# "PermitRootLogin without-password". If you just want the PAM account and 
# session checks to run without PAM authentication, then enable this but set 
# ChallengeResponseAuthentication=no
UsePAM yes

#AllowTcpForwarding yes
#GatewayPorts no
X11Forwarding yes 
#X11DisplayOffset 10
#X11UseLocalhost yes
#PrintMotd yes
#PrintLastLog yes
#TCPKeepAlive yes
#UseLogin no
#UsePrivilegeSeparation yes
#PermitUserEnvironment no
#Compression yes
#ClientAliveInterval 0
#ClientAliveCountMax 3
#UseDNS yes
#PidFile /var/run/sshd.pid
#MaxStartups 10

# no default banner path
#Banner /some/path

# override default of no subsystems
Subsystem	sftp	/usr/lib/ssh/sftp-server

# This enables accepting locale enviroment variables LC_* LANG, see sshd_config(5).
AcceptEnv LANG LC_CTYPE LC_NUMERIC LC_TIME LC_COLLATE LC_MONETARY LC_MESSAGES 
AcceptEnv LC_PAPER LC_NAME LC_ADDRESS LC_TELEPHONE LC_MEASUREMENT 
AcceptEnv LC_IDENTIFICATION LC_ALL

mephistos
Posts: 18
Joined: 2004-08-11 23:32

Re: Bekomme SFTP nicht zum Laufen

Post by mephistos » 2006-06-06 18:05

Mir ist geerade noch was aufgefallen

Auch mit

Code: Select all

su - user1
kann ich nicht zum jeweiligen User wechseln. Nach whoami bin ich immer noch root.

Keine Ahnung, ob das was hilft oder es nur ein weiteres Indiz ist, dass der user1 nicht per ssh eingeloggt sein darf.

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: Bekomme SFTP nicht zum Laufen

Post by Roger Wilco » 2006-06-06 18:48

Der Benutzer hat vermutlich keine gültige Shell, sondern nur /usr/sbin/nologin, /usr/bin/true oder /usr/bin/false.

mephistos
Posts: 18
Joined: 2004-08-11 23:32

Re: Bekomme SFTP nicht zum Laufen

Post by mephistos » 2006-06-06 19:23

Roger Wilco wrote:Der Benutzer hat vermutlich keine gültige Shell, sondern nur /usr/sbin/nologin, /usr/bin/true oder /usr/bin/false.
Hallo

Ich Depp. Das war das Problem. Jetzt funzt es.

Vielen Dank für Eure Hilfe.
Meph