blacklisten blocken meine einwahl-ip

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
rok°ǃ
Posts: 34
Joined: 2006-02-24 17:51

blacklisten blocken meine einwahl-ip

Post by rok°ǃ » 2006-05-03 17:12

hallo!

hat jemand schon erfahrungen mit blacklisten gesammelt? ich nutze folgende vier:

sbl-xbl.spamhaus.org
list.dsbl.org
dnsbl.njabl.org
bl.spamcop.net

um gleich alle mails abzuweisen. erspart mir ne menge traffic. allerdings hab ich dabei ein kleines problem: wenn ich eine dynamische ip bekomme, die auf den listen steht, werde ich auch abgewiesen. ist das ein konfigproblem meinerseits? (btw: ich nutze debian mit exim).

gruß!

antondollmaier
Posts: 485
Joined: 2004-03-30 10:06

Re: blacklisten blocken meine einwahl-ip

Post by antondollmaier » 2006-05-03 17:36

Du musst eMails über einen Relayhost "umleiten"... von dynamischen IP-Adressen werden - die Listen verwendest du ja schon - in 99% der Fälle alle eMails abgewiesen ...

rok°ǃ
Posts: 34
Joined: 2006-02-24 17:51

Re: blacklisten blocken meine einwahl-ip

Post by rok°ǃ » 2006-05-03 17:53

ich hab deine antwort nicht wirklich verstanden. liegt wohl auch daran, dass ich meine config nicht ausführlich genug beschrieben habe.

der mailserver hat eine feste ip. auf diesem ist exim installiert, welcher meine mails annimmt. über diesen server versende ich mails. das klappt auch super. nur ab und zu erwische ich wohl mal eine ip adresse, die auf einer blackliste steht und ich kann keine mails versenden (empfangen geht - hat ja auch nix mit exim zu tun ;)). ich muss mich erst wieder reconnecten, damit mir eine neue ip zugeteilt wird.

stimmt da was mit den regeln (router) nicht, denn als mailuser melde ich mich per smtp-auth an. wahrscheinlich tritt aber vorher die regel zum überprüfen der ip in kraft...

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: blacklisten blocken meine einwahl-ip

Post by Roger Wilco » 2006-05-03 17:57

rok°! wrote:stimmt da was mit den regeln (router) nicht, denn als mailuser melde ich mich per smtp-auth an. wahrscheinlich tritt aber vorher die regel zum überprüfen der ip in kraft...
Du mußt einfach eine Regel erstellen, dass du sobald du via SMTP-Auth authentifiziert bist, immer verschicken darfst (wie z. B. hier beschrieben).

rok°ǃ
Posts: 34
Joined: 2006-02-24 17:51

Re: blacklisten blocken meine einwahl-ip

Post by rok°ǃ » 2006-05-03 18:00

Roger Wilco wrote:wie z. B. hier beschrieben).
exakt nach dem tut ist das ding gebaut... :(

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: blacklisten blocken meine einwahl-ip

Post by Roger Wilco » 2006-05-03 18:06

Ja aber hast du die unter dem Link beschriebene Konfigurationsänderung durchgeführt und Exim neugestartet?

-> Poste deine Exim-Konfiguration (ohne Kommentare und in CODE-Tags).

rok°ǃ
Posts: 34
Joined: 2006-02-24 17:51

Re: blacklisten blocken meine einwahl-ip

Post by rok°ǃ » 2006-05-03 18:13

meine /etc/exim4/vexim-acl-check-rcpt.conf sieht so aus:

Code: Select all

    accept  authenticated = *
            condition     = ${if eq{$authenticated_id}{$sender_address}{yes}{no}}

    deny    message       = DNSBL listed at $dnslist_domainn$dnslist_text
            dnslists      = sbl-xbl.spamhaus.org:list.dsbl.org:dnsbl.njabl.org:bl.spamcop.net

    warn
            message       = X-DNSBL: listed at $dnslist_domainnX-DNSBL-Text: $dnslist_text
            dnslists      = sbl-xbl.spamhaus.org:list.dsbl.org:dnsbl.njabl.org:bl.spamcop.net

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: blacklisten blocken meine einwahl-ip

Post by Roger Wilco » 2006-05-03 18:19

Code: Select all

  warn  log_message = verified peer dn $tls_peerdn
  condition = $tls_certificate_verified
  accept condition = $tls_certificate_verified

  accept  authenticated = *

  deny    message       = DNSBL listed at $dnslist_domainn$dnslist_text
          # Nach Belieben RBL hinzufügen oder entfernen
          dnslists      = sbl-xbl.spamhaus.org:list.dsbl.org:dynablock.njabl.org:ix.dnsbl.manitu.net:dnsbl.sorbs.net:sbl.spamhaus.org:relays.ordb.org

rok°ǃ
Posts: 34
Joined: 2006-02-24 17:51

Re: blacklisten blocken meine einwahl-ip

Post by rok°ǃ » 2006-05-03 18:20

hey, danke. kannst du noch kurz was zu den ersten 3 zeilen sagen (das ist doch das, was sich von meinem unterscheidet, oder?). was machen die?

edit:
ok, hab ich mir selbst beantwortet. das ist tls. ich verwende das aber nicht. also muss das auch zunächst nicht in der config stehen.
was auch fehlt ist diese zeile:

Code: Select all

condition     = ${if eq{$authenticated_id}{$sender_address}{yes}{no}} 
da die nicht bei dir mit drin steht, gehe ich davon aus, dass diese evtl. mein leid nimmt. allerdings weiß ich leider nicht, was die macht. hat jmd. eine erklärung evtl.?

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: blacklisten blocken meine einwahl-ip

Post by Roger Wilco » 2006-05-03 18:39

rok°! wrote:da die nicht bei dir mit drin steht, gehe ich davon aus, dass diese evtl. mein leid nimmt. allerdings weiß ich leider nicht, was die macht. hat jmd. eine erklärung evtl.?
Das steht z. B. in dem Howto auf debianhowto.de.
Die Bedingung sorgt dafür, dass du nur mit der E-Mail-Adresse, die als Login dient, Mails verschicken kannst.

rok°ǃ
Posts: 34
Joined: 2006-02-24 17:51

Re: blacklisten blocken meine einwahl-ip

Post by rok°ǃ » 2006-05-03 18:40

Roger Wilco wrote:Die Bedingung sorgt dafür, dass du nur mit der E-Mail-Adresse, die als Login dient, Mails verschicken kannst.
für smtp-auth ist das doch aber notwendig! nicht?

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: blacklisten blocken meine einwahl-ip

Post by Roger Wilco » 2006-05-03 18:44

rok°! wrote:für smtp-auth ist das doch aber notwendig! nicht?
Nein.

rok°ǃ
Posts: 34
Joined: 2006-02-24 17:51

Re: blacklisten blocken meine einwahl-ip

Post by rok°ǃ » 2006-05-03 18:47

entschuldige, dass ich nochmals nachfrage, ich bin ein wenig verwirrt aber hier steht folgendes:
Er bewirkt, dass nur E-Mails zum Versenden angenommen werden, bei denen die ID des angemeldeten Benutzers (SMTP-Auth) mit der Sender-Adresse übereinstimmt.
das widerspricht doch deiner aussage. oder?

duergner
RSAC
Posts: 976
Joined: 2003-08-20 11:30
Location: Pittsburgh, PA, USA

Re: blacklisten blocken meine einwahl-ip

Post by duergner » 2006-05-03 18:57

Nein das heißt das nicht. Diese Bedindung besagt nur, dass im From: Feld der Email nur die Adresse stehen darf, die du als USER_ID beim SMTP-Auth übertragen hast.

Sprich wenn du dich mit user1@example.com angemeldet hast, dann muss im From: Header der Email auch user1@example.com stehen. Obwohl der Benutzer vielleicht noch user1a@example.com hat und emails von diesem Account aus über den gleichen SMTP-Auth Zugang verschicken wollen würde.

rok°ǃ
Posts: 34
Joined: 2006-02-24 17:51

Re: blacklisten blocken meine einwahl-ip

Post by rok°ǃ » 2006-05-03 19:00

also steht das

Code: Select all

accept  authenticated = * 

für SMTP-Auth?

edit:
selbst wenn ich die "condition"-zeile rausnehme, dürfte das anfangsproblem damit ja noch nicht behoben sein. und tls ist ja nur für die verschlüsselung der übermittlung. oder verstehe ich da was falsch?

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: blacklisten blocken meine einwahl-ip

Post by Roger Wilco » 2006-05-03 22:37

rok°! wrote:selbst wenn ich die "condition"-zeile rausnehme, dürfte das anfangsproblem damit ja noch nicht behoben sein.
Jein, du hast vermutlich versucht, mit einer E-Mail-Adresse != Loginname im From-Header zu verschicken und wurdest deshalb abgewiesen bzw. die Bedingung hat nicht gegriffen.

antondollmaier
Posts: 485
Joined: 2004-03-30 10:06

Re: blacklisten blocken meine einwahl-ip

Post by antondollmaier » 2006-05-04 00:18

rok°! wrote:der mailserver hat eine feste ip. auf diesem ist exim installiert, welcher meine mails annimmt. über diesen server versende ich mails. das klappt auch super. nur ab und zu erwische ich wohl mal eine ip adresse, die auf einer blackliste steht und ich kann keine mails versenden (empfangen geht - hat ja auch nix mit exim zu tun ;)). ich muss mich erst wieder reconnecten, damit mir eine neue ip zugeteilt wird.

stimmt da was mit den regeln (router) nicht, denn als mailuser melde ich mich per smtp-auth an. wahrscheinlich tritt aber vorher die regel zum überprüfen der ip in kraft...
hast du also eine statische Internet-IP, die nicht im 10/24, 192.168/16 bzw 172.16.xx.xx steht, oder hast du eine dynamische IP, wie sie von jedem DSL-Provider bei der Einwahl zugewiesen wird? ... Ich lese aus deiner Antwort heraus, dass dein Mailserver zwar eine statische IP hat, dieser aber hinter einem Router hängt, welcher sich ins Internet mit einer dynamischen IP einwählt ... wenn falsch, sorry ...

rok°ǃ
Posts: 34
Joined: 2006-02-24 17:51

Re: blacklisten blocken meine einwahl-ip

Post by rok°ǃ » 2006-05-04 08:37

Roger Wilco wrote:
rok°! wrote:selbst wenn ich die "condition"-zeile rausnehme, dürfte das anfangsproblem damit ja noch nicht behoben sein.
Jein, du hast vermutlich versucht, mit einer E-Mail-Adresse != Loginname im From-Header zu verschicken und wurdest deshalb abgewiesen bzw. die Bedingung hat nicht gegriffen.
nope, versucht hab ich noch gar nix. ist alles theorie. an nem server will ich so wenig wie möglich versuchen.
ich bin von der obigen aussage ausgegangen, dass die condition eben benutzername in der from zeile überprüft. ich habe aber ein ganz anderes problem:
mein server (mit statischer ip) weißt mich ab und zu mal ab (wegen dnsbl). ich wähle mich wie jeder andere user auch ins internet ein. und versuche mails über meinen server zu versenden. mein server steht nicht in meinem netz, hinter meinem router, sondern in einem rechenzentrum.
antondollmaier wrote:Ich lese aus deiner Antwort heraus, dass dein Mailserver zwar eine statische IP hat, dieser aber hinter einem Router hängt, welcher sich ins Internet mit einer dynamischen IP einwählt ... wenn falsch, sorry ...
siehe oben.

rootsvr
Posts: 538
Joined: 2005-09-02 11:12

Re: blacklisten blocken meine einwahl-ip

Post by rootsvr » 2006-05-04 11:33

Hmm also irgendwie wird man trotzdem nicht ganz schlau ich versuche nochmal:

Du hast einen Server im Rechenzentrum mit der IP XYZ, die ist statisch ändert sich nie

Du hast zuhause nen DSL (o.ä.) und willst von da aus Mails an deinen Server weiterleiten.

- machst Du das mit nem lokalen Mailserver und lieferst direkt über SMTP ein
- Oder meldest Du dich an deinem Server an und willst dann die Mails loswerden?

Beides sollte eigentlich für autehntifizierte User möglich sein, zumindest bei Postfix wüßte ich wie es geht.

Oder hast Du ein anderes Szenario? (mal nen Bild)

rok°ǃ
Posts: 34
Joined: 2006-02-24 17:51

Re: blacklisten blocken meine einwahl-ip

Post by rok°ǃ » 2006-05-04 11:55

rootsvr wrote:Du hast einen Server im Rechenzentrum mit der IP XYZ, die ist statisch ändert sich nie

Du hast zuhause nen DSL (o.ä.) und willst von da aus Mails an deinen Server weiterleiten.
exakt.
rootsvr wrote:- Oder meldest Du dich an deinem Server an und willst dann die Mails loswerden?
ja. ganz normal mit outlook. kein lokales extragedöhns.
rootsvr wrote:Beides sollte eigentlich für autehntifizierte User möglich sein, zumindest bei Postfix wüßte ich wie es geht.
ich kann mich ja auch anmelden und mails versenden. nur werde ich mindestens 2x im monat abgewiesen, weil meine ip, die ich von meinem dsl-provider bei jeder neueinwahl bekomme auf einer blacklist steht.

und das ist das eigentliche problem:
da ich mich am server anmelde, dürfte gar nicht die blacklistenüberprüfung stattfinden. oder?

rootsvr
Posts: 538
Joined: 2005-09-02 11:12

Re: blacklisten blocken meine einwahl-ip

Post by rootsvr » 2006-05-04 12:17

Kenne Exim nicht, aus den Configs würde ich schliessen das Authentifizierte User immer dürfen, zumdindest sieht das so ähnlich aus wie in dem Exim Howto (mit netter Doku)
http://www.lug-untermain.de/howto/exim.php

ka woran das dann bei Dir leigt.. logfiles?

rok°ǃ
Posts: 34
Joined: 2006-02-24 17:51

Re: blacklisten blocken meine einwahl-ip

Post by rok°ǃ » 2006-05-04 12:52

in den logfiles steht immer nur drin, dass die adresse rejected wurde, weil sie auf einer dnsbl steht.
wenn ich die blacklist überprüfe, stimmt das auch immer.
hier gern noch ein logfile-auszug:

Code: Select all

2006-05-03 13:09:38 H=nbb1e.n.pppool.de (namel6ac981ome) [89.50.187.30] F=<meine@email.de> rejected RCPT <empfaenger@email.de>: DNSBL listed at sbl-xbl.spamhaus.org
oulook erzählt was von error 550 rquested action not taken, mailbox unavailable

rok°ǃ
Posts: 34
Joined: 2006-02-24 17:51

Re: blacklisten blocken meine einwahl-ip

Post by rok°ǃ » 2006-05-06 10:12

:roll:
keiner, der evtl. ungefähr ne ahnung hat, welcher parameter dazwischen schießt?

vielleicht ist es ja die reihenfolge, mit der die router includiert werden? weil sie vielleicht auch so abgerufen werden?

irnbru
Posts: 31
Joined: 2003-05-19 11:50

Re: blacklisten blocken meine einwahl-ip

Post by irnbru » 2006-05-17 17:52

Moin,

Du bist Dir auch sicher die Konfiguration neu gebaut zu haben (unter Debian Sarge notwendig)?

--> update-exim4.conf

und dann ein Reload auf den Exim.

Es klappt in jedem Falle, wenn Du eine Zeile

Code: Select all

accept  authenticated = * 
VOR den Zeilen

Code: Select all

deny    message       = DNSBL listed at $dnslist_domainn$dnslist_text 
          # Nach Belieben RBL hinzufügen oder entfernen 
          dnslists      = sbl-xbl.spamhaus.org:list.dsbl.org:dynablock.njabl.org:ix.dnsbl.manitu.net:dnsbl.sorbs.net:sbl.spamhaus.org:relays.ordb.org
hast.

Grüße
Bru.

rok°ǃ
Posts: 34
Joined: 2006-02-24 17:51

Re: blacklisten blocken meine einwahl-ip

Post by rok°ǃ » 2006-05-17 19:07

irnbru wrote:Moin,

Du bist Dir auch sicher die Konfiguration neu gebaut zu haben (unter Debian Sarge notwendig)?

--> update-exim4.conf

und dann ein Reload auf den Exim.
den reload hab ich gemacht. aber was es mit dem update zu tun hat vertsehe ich nicht.
irnbru wrote:Es klappt in jedem Falle, wenn Du eine Zeile

Code: Select all

accept  authenticated = * 
VOR den Zeilen hast.
yo, so wie oben beschrieben...