Probleme nach exim-Update

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
dirkv99
Posts: 54
Joined: 2003-07-31 16:01

Probleme nach exim-Update

Post by dirkv99 » 2006-04-26 20:19

hallo zusammen!
ich bin leider kein exim-experte - daher folgende frage...
nach einem update auf exim4 ist leider kein versand von mails an externe adressen mehr möglich. von einem account auf dem server zu einem anderen auf dem gleichen server - kein problem. auch der empfang von mails läuft noch problemlos.
leider finde ich keine problematischen einträge in den logs. nur folgendes, was für mich aber normal aussieht:

Code: Select all

2006-04-26 07:15:21 1FYcMz-0003jE-1d <= info@xxxxxxxxx.de H=pxxxxxxx.dip0.t-ipconnect.de (DELL) [xx.xxx.xxx.xxx] P=esmtpa A=login:web2p1 S=1341 id=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx@xxxx
2006-04-26 07:15:21 1FYcMz-0003jE-1d => xxxxxxx@gmx.de R=dnslookup T=remote_smtp H=mx0.gmx.net [213.165.64.100]
meine update-exim4.conf.conf sieht im moment so aus:

Code: Select all

dc_eximconfig_configtype='internet'
dc_other_hostnames='/etc/exim4/confixx/confixx-domains:xxxxxx.xxxxxxxxxx.de'
dc_local_interfaces='127.0.0.1:xx.xx.xxx.xx'
dc_readhost=''
dc_relay_domains=''
dc_minimaldns='false'
dc_relay_nets=''
dc_smarthost=''
CFILEMODE='644'
dc_use_split_config='true'
dc_hide_mailname=''
dc_mailname_in_oh='true'
x steht natürlich für ip-adressen etc.
hat jemand eine idee? wo soll ich ansetzen? danke!

dirk

felixs
Posts: 119
Joined: 2003-06-01 20:57

Re: Probleme nach exim-Update

Post by felixs » 2006-04-26 22:26

Interessant wäre, ob du noch Mails in der Queue hast - prinzipiell sieht dein geposteter Logeintrag aber für mich sehr normal aus.

Was passiert denn, wenn du Exim mit "exim -bd -d+all" startest und eine "problematische" Mail versendest? Dieses Log müsste eigentlich zeigen, wo Probleme liegen. Kann es sein, dass nur der externe Server Probleme hat?

fs

dirkv99
Posts: 54
Joined: 2003-07-31 16:01

Re: Probleme nach exim-Update

Post by dirkv99 » 2006-04-26 23:20

dann kommt folgender eintrag in der exim4/mainlog:

Code: Select all

2006-04-26 23:17:47 1FYrON-0006V1-7x <= xxxx@xxxxxxxxxxxxxxxx.de H=pxxxxxxxx.dip0.t-ipconnect.de (DELL) [xx.xxx.xxx.xxx] P=esmtpa A=login:web2p1 S=1335 id=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx@xxxx
2006-04-26 23:17:47 1FYrON-0006V1-7x => xxxxxxx@gmx.de R=dnslookup T=remote_smtp H=mx0.gmx.de [213.165.64.100]
2006-04-26 23:17:47 1FYrON-0006V1-7x Completed
und ja, es betrifft nur die mails, die zu einem externen account verschickt werden. wo finde ich denn die queue?

danke!
dirk

felixs
Posts: 119
Joined: 2003-06-01 20:57

Re: Probleme nach exim-Update

Post by felixs » 2006-04-27 09:07

dirkv99 wrote:dann kommt folgender eintrag in der exim4/mainlog: (...)
Eigentlich meinte ich die (vermutlich recht umfangreiche) Debugausgabe auf der Konsole, auf der Exim mit "-bd -d+all" gestartet wurde.

Laut dem Logeintrag wurde aber die genannte Mail korrekt verschickt, d.h. das Problem liegt aller Wahrscheinlichkeit nach beim externen Mailserver.

[quote
wo finde ich denn die queue?
[/quote]

exim -bp

fs