Xen und Netzwerkkonfiguration

VirtualBox, VMWare, KVM, XEN, OpenVZ, Virtuozzo, etc.
os_destroyer
Posts: 12
Joined: 2005-05-26 11:13

Xen und Netzwerkkonfiguration

Post by os_destroyer » 2006-04-22 10:44

Hallo,

ich habe Xen 3.0.2 auf meinem Debian Sarge installiert und soweit alles eingerichtet. Das System bootet ohne Probleme. Wenn ich jedoch aus einer domU heraus versuche die Welt mittels NAT zu erreichen gelingt mir das nicht (ping funktioniert nicht o.ä.).

Code: Select all

dom0:
Chain POSTROUTING (policy ACCEPT)
target     prot opt source               destination
SNAT       all  --  anywhere             anywhere            to:85.214.49.222



xenintbr  Protokoll:Ethernet  Hardware Adresse FE:FF:FF:FF:FF:FF
          inet Adresse:192.168.1.1  Bcast:192.168.1.255  Maske:255.255.255.0
          inet6 Adresse: fe80::200:ff:fe00:0/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:11 errors:0 dropped:0 overruns:0 frame:0
          TX packets:215 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:0
          RX bytes:539 (539.0 b)  TX bytes:9976 (9.7 KiB)
eth0      Protokoll:Ethernet  Hardware Adresse 00:E0:81:5A:0B:6B
          inet Adresse:85.214.49.222  Bcast:85.214.49.222  Maske:255.255.255.255
          inet6 Adresse: fe80::2e0:81ff:fe5a:b6b/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:262479 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4517 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX bytes:85880494 (81.9 MiB)  TX bytes:629270 (614.5 KiB)
          Interrupt:17

www1:~# route
Kernel IP Routentabelle
Ziel            Router          Genmask         Flags Metric Ref    Use Iface
85.214.48.1     *               255.255.255.255 UH    0      0        0 eth0
192.168.1.0     *               255.255.255.0   U     0      0        0 xenintbr
default         85.214.48.1     0.0.0.0         UG    0      0        0 eth0

-----------------------------------
domU:
eth0      Protokoll:Ethernet  Hardware Adresse 00:16:3E:57:7B:22
          inet Adresse:192.168.1.10  Bcast:192.168.1.255  Maske:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:203 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX bytes:8554 (8.3 KiB)  TX bytes:903 (903.0 b)


Kernel IP Routentabelle
Ziel            Router          Genmask         Flags Metric Ref    Use Iface
192.168.1.0     *               255.255.255.0   U     0      0        0 eth0
default         192.168.1.1     0.0.0.0         UG    0      0        0 eth0
Evtl kann mir jemand einen Denkanstoß geben, warum mein Netzwerk nicht funktioniert. Danke schonmal im Voraus!

//edit: Im Prinzip ist das ganze mit einem Heimnetzwerk bestehend aus mehreren PC's und einem Router zu vergleichen. Nur in meinem Fall funktioniert das NAT nicht...

wirsing
RSAC
Posts: 611
Joined: 2002-11-20 21:32
Location: Vaihingen und Karlsruhe

Re: Xen und Netzwerkkonfiguration

Post by wirsing » 2006-04-22 15:38

Hast du schon mal genauer geschaut, was für Pakete beim Host ankommen bzw. wie sie ihn wieder verlassen? (Stichwort tcpdump oder (t)ethereal)