amavis[28515]: (28515-02) (!!) TROUBLE in check_mail: mime_decode-1 FAILED:

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
atlantex
Posts: 9
Joined: 2004-02-27 15:56

amavis[28515]: (28515-02) (!!) TROUBLE in check_mail: mime_decode-1 FAILED:

Post by atlantex » 2006-04-21 12:33

Hallo,

hab seit heute morgen Probleme mit dem Mailserver, folgende Meldungen kommen im Maillog:

amavis[28515]: (28515-02)(!!) TROUBLE in check_mail: mime_decode-1 FAILED: MIME::Parser: can't open tmpfile: Invalid argument
amavis[28515]: (28515-02)(!) PRESERVING EVIDENCE in /var/amavis/tmp/amavis-20060421T121500-28516

Das Sytem ist FC3, Postfix, Amavisd-new, Qpopper

an den Configfiles wurde seit Monaten nichts geändert.

Eine Neuinstall des Amavis brachte keinen Erfolg.



Könnte bitte jemand einen Tip geben wo ich ansetzen sollte ?


thx

atlantex

adjustman
Posts: 1132
Joined: 2003-03-26 23:29
Location: SA

Re: amavis[28515]: (28515-02) (!!) TROUBLE in check_mail: mime_decode-1 FAILED:

Post by adjustman » 2006-04-21 14:14

/etc/init.d/amavis stop
und dann
amavisd (oder wie auch immer das bei dir heisst) debug 2>&1 |more

Könnte ein Rechteproblem beim tmp Ordner sein

atlantex
Posts: 9
Joined: 2004-02-27 15:56

Re: amavis[28515]: (28515-02) (!!) TROUBLE in check_mail: mime_decode-1 FAILED:

Post by atlantex » 2006-04-21 21:20

Hallo,

im Debugmode sehe ich das die Tmpfiles erstellt werden.

/usr/sbin/amavisd[6824]: (06824-01) TempDir::prepare: creating directory /var/amavis/tmp/amavis-20060421T205326-06824

/usr/sbin/amavisd[6824]: (06824-01) TempDir::prepare_file: creating file /var/amavis/tmp/amavis-20060421T205326-06824/email.txt

sobald er die Files parsen will kommt es zum Problem.

/usr/sbin/amavisd[6824]: (06824-01) Extracting mime components

/usr/sbin/amavisd[6824]: (06824-01) TROUBLE in check_mail: mime_decode-1 FAILED: MIME::Parser: can't open tmpfile: Invalid argument

/usr/sbin/amavisd[6824]: (06824-01) sending SMTP response: "451 4.5.0 Error in processing, id=06824-01, mime_decode-1 FAILED: MIME::Parser: can't open tmpfile: Invalid argument"

/usr/sbin/amavisd[6824]: (06824-01) ESMTP> 451 4.5.0 Error in processing, id=06824-01, mime_decode-1 FAILED: MIME::Parser: can't open tmpfile: Invalid argument


Ich hab den Perl und CPan Teil auch nochmal neu installiert aber immer noch genau das gleiche Problem :?

Auch in google is nichts der gleichen zu finden.



was kann ich noch versuchen ?


atlantex

adjustman
Posts: 1132
Joined: 2003-03-26 23:29
Location: SA

Re: amavis[28515]: (28515-02) (!!) TROUBLE in check_mail: mime_decode-1 FAILED:

Post by adjustman » 2006-04-21 22:12

wem gehört denn /var/amavis/tmp ?

atlantex
Posts: 9
Joined: 2004-02-27 15:56

Re: amavis[28515]: (28515-02) (!!) TROUBLE in check_mail: mime_decode-1 FAILED:

Post by atlantex » 2006-04-22 07:04

Guten Morgen,
wem gehört denn /var/amavis/tmp ?
drwxr-x--- 1235 amavis amavis 69632 Apr 21 20:53 tmp


Der Fehler scheint beim MIME::Parser CPAN Modul zu kommen, "invalid argument" liefert dieses zurück, nur leider ist auch im Debugmode nicht mehr rauszukriegen.



atlantex

felixs
Posts: 119
Joined: 2003-06-01 20:57

Re: amavis[28515]: (28515-02) (!!) TROUBLE in check_mail: mime_decode-1 FAILED:

Post by felixs » 2006-04-22 10:25

Schau mal in der amavis-user Mailingliste auf Sourceforge nach. Wenn ich mich recht erinnere, gab es da in den letzten Tagen/Wochen ein paar sehr ähnliche Problembeschreibungen.

Ich habe die entspr. Threads aber nicht verfolgt, so dass ich dir nicht direkt weiterhelfen kann.

fs

atlantex
Posts: 9
Joined: 2004-02-27 15:56

Re: amavis[28515]: (28515-02) (!!) TROUBLE in check_mail: mime_decode-1 FAILED:

Post by atlantex » 2006-04-22 10:45

Danke für den Hinweis !!


atlantex

adjustman
Posts: 1132
Joined: 2003-03-26 23:29
Location: SA

Re: amavis[28515]: (28515-02) (!!) TROUBLE in check_mail: mime_decode-1 FAILED:

Post by adjustman » 2006-04-22 13:28

felixs wrote:Schau mal in der amavis-user Mailingliste auf Sourceforge nach. Wenn ich mich recht erinnere,
ist immer ne gute Idee ;)
felixs wrote: gab es da in den letzten Tagen/Wochen ein paar sehr ähnliche Problembeschreibungen.
IMO ging es da aber um Net::Server (0.90 - 0.93)
nichtsdestotrotz - wenn man amavis einsetzt, ist das Lesen immer gut. Und das Updaten auf 2.4.0 kann auch nicht schaden.

atlantex
Posts: 9
Joined: 2004-02-27 15:56

Re: amavis[28515]: (28515-02) (!!) TROUBLE in check_mail: mime_decode-1 FAILED:

Post by atlantex » 2006-04-22 16:15

Hallo,

die Mailingliste hilft mich nicht weiter, die beschriebenen Probleme sind zu verschieden als dass ich etwas davon ableiten könnte.

installierte Version ist amavisd-new-2.4.0-3

Ich hab den Amavis nun nochmal neu installiert und die Configs neu angepasst, immer noch das gleiche Problem.

Am Amavis wird es nicht liegen, irgendwas am Perl CPAN wird foule sein.



atlantex

adjustman
Posts: 1132
Joined: 2003-03-26 23:29
Location: SA

Re: amavis[28515]: (28515-02) (!!) TROUBLE in check_mail: mime_decode-1 FAILED:

Post by adjustman » 2006-04-22 17:33

wenn du meinst. ;) Ich würde da mal ne Anfrage starten.
Dann eben
perl -MCPAN -e shell
force install MIME::Parser

rootsvr
Posts: 538
Joined: 2005-09-02 11:12

Re: amavis[28515]: (28515-02) (!!) TROUBLE in check_mail: mime_decode-1 FAILED:

Post by rootsvr » 2006-04-24 11:21

Jep.. in der Amavis Liste gab es mit einigen 2.4 Versionen Probleme mit Net::Server da sollte man auf 0.90 downgraden oder die aktuelle 2.4 nehmen und das neue Net::Server 0.93 nutzen

Versuch ist es wert..

atlantex
Posts: 9
Joined: 2004-02-27 15:56

Re: amavis[28515]: (28515-02) (!!) TROUBLE in check_mail: mime_decode-1 FAILED:

Post by atlantex » 2006-04-24 18:15

Hallo,


ich habe es nun mit Hilfe der amavis_user Mailinglist hinbekommen.

Die Rechte von /tmp waren tatsächlich falsch. Ein ändern auf 1777 führte zum gewünschten Ergebnis.

Nun stellt sich mir die Frage, wodurch sind diese Rechte nun verstellt worden ?

Auf dem Server sind mehrere Kunden mit CMS Systemen, möglicherweise ist da wiedermal ein exploid am Werk gewesen.
Jedenfalls konnte ich keine höhere Traffic oder CPU Last feststellen.


Danke für Eure Unterstützung

atlantex

cirox
Posts: 212
Joined: 2006-05-08 23:20
Location: Berlin

Re: amavis[28515]: (28515-02) (!!) TROUBLE in check_mail: mime_decode-1 FAILED:

Post by cirox » 2009-09-01 18:43

noexec,nosuid,rw -> 0777 tuts aber auch!