Probleme mit spamassasin

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
toberkel
Posts: 86
Joined: 2004-07-16 17:22
Location: Hamburg

Probleme mit spamassasin

Post by toberkel » 2006-03-31 13:30

Hi.

Ich habe leider seit kurzem Probleme mit Spamassasin. Er produziert immer komisch Fehlermeldungen in der mail.log-Datei. Diese sehen so aus:

Code: Select all

Mar 31 04:04:03 fuckup amavis[4552]: (04552-07) SA TIMED OUT, backtrace: at /usr/share/perl5/Mail/SpamAssassin/Message/Node.pm line 565nteval {...} called at /usr/share/perl5/Mail/SpamAssassin/Message/Node.pm line 565ntMail::SpamAssassin::Message::Node::get_header('Mail::SpamAssassin::Message=HASH(0x9c90f94)', 'From', '') called at /usr/share/perl5/Mail/SpamAssassin/PerMsgStatus.pm line 1423ntMail::SpamAssassin::PerMsgStatus::get('Mail::SpamAssassin::PerMsgStatus=HASH(0x9c12310)', 'From:addr') called at /usr/share/perl5/Mail/SpamAssassin/EvalTests.pm line 1034ntMail::SpamAssassin::PerMsgStatus::all_from_addrs('Mail::SpamAssassin::PerMsgStatus=HASH(0x9c12310)') called at /usr/share/perl5/Mail/SpamAssassin/EvalTests.pm line 1376ntMail::SpamAssassin::PerMsgStatus::check_rbl_from_host('Mail::SpamAssassin::PerMsgStatus=HASH(0x9c12310)', 'DNS_FROM_AHBL_RHSBL', 'ahbl', 'rhsbl.ahbl.org.') called at /usr/share/perl5/Mail/SpamAssassin/PerMsg...

Mar 31 02:08:27 fuckup amavis[4552]: (04552-05) SA TIMED OUT, backtrace: at /usr/share/perl5/Mail/SpamAssassin/EvalTests.pm line 1254nteval {...} called at /usr/share/perl5/Mail/SpamAssassin/EvalTests.pm line 1254ntMail::SpamAssassin::PerMsgStatus::check_rbl_backend('Mail::SpamAssassin::PerMsgStatus=HASH(0x9c37dd8)', 'RCVD_IN_XBL', 'sblxbl-notfirsthop', 'sbl-xbl.spamhaus.org.', 'A', '127.0.0.[456]') called at /usr/share/perl5/Mail/SpamAssassin/EvalTests.pm line 1330ntMail::SpamAssassin::PerMsgStatus::check_rbl('Mail::SpamAssassin::PerMsgStatus=HASH(0x9c37dd8)', 'RCVD_IN_XBL', 'sblxbl-notfirsthop', 'sbl-xbl.spamhaus.org.', '127.0.0.[456]') called at /usr/share/perl5/Mail/SpamAssassin/PerMsgStatus.pm line 2408nteval {...} called at /usr/share/perl5/Mail/SpamAssassin/PerMsgStatus.pm line 2407ntMail::SpamAssassin::PerMsgStatus::run_rbl_eval_tests('Mail::SpamAssassin::PerMsgStatus=HASH(0x9c37dd8)', 'HASH(0x962c128)') called at /usr/shar...
Hat da jemand eine Idee?

Als Software wird eingesetzt:

Debian 3.1 mit allen verfügbaren Updates
amavisd-new 20030616p1
postfix 2.1.5-9
spamassasin 3.0.3-2
perl 5.8.4-8

Keines dieser Programme wurde aus den Sourcen gebaut, es sind immer die in Debian Sarge verfügbaren .deb Pakete. Seit das Problem besteht ist nichts an der Konfiguration der Programme geändert worden, das ist ja was mich so stutzig macht... :(

Wenn es geht würde ich auch gerne keine der Programme aus den Sourcen bauen, sondern .deb Pakete verwenden. Hoffe mir kann jemand helfen...

mfg,

toberkel

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: Probleme mit spamassasin

Post by dodolin » 2006-04-01 00:23

Hast du diverse Pakete aus

Code: Select all

Recommends: perl (>= 5.8.0) | libmime-base64-perl, libnet-dns-perl (>= 0.34)
Suggests: libnet-smtp-perl | perl-modules (>= 5.8.0), libmail-spf-query-perl, razor (>= 2.361-2), libnet-ident-perl, libio-socket-ssl-perl, perl (>= 5.8.0) | libtime-hires-perl, libdbi-perl, dcc-client, pyzor
installiert? Insbesondere libnet-dns-perl?

Passiert das bei allen Mails oder nur bei bestimmten? Ansonsten mal amavis und/oder spamassassin abschalten und eine entsprechende Mail direkt per Kommandozeile und Debug-Flags an Spamassassin übergeben, um zu sehen, was der genau meldet.

toberkel
Posts: 86
Joined: 2004-07-16 17:22
Location: Hamburg

Re: Probleme mit spamassasin

Post by toberkel » 2006-04-01 12:32

hi.

Ja, die Pakete sind alle installiert. Das komische ist ja, das das Problem erst seit letztem Samstag auftritt. Und es wurden seit dem keine neuen Version der Pakete installiert... :(

Mail von Hand an Spamassasin übergeben? Helf mir mal bitte kurz auf die Sprünge... ;)

mfg,

toberkel

oxygen
RSAC
Posts: 2179
Joined: 2002-12-15 00:10
Location: Bergheim

Re: Probleme mit spamassasin

Post by oxygen » 2006-04-01 13:03

Ich hatte das Probleme auch manchmal, als die Anzahl der Regeln und die Bayes Datenbank ziemlich gewachsen sind. Ein einfaches $sa_timeout=600; in der amavisd.conf hat schon geholfen. Das ist kein SpamAssassin sondern ein amavis Problem.

toberkel
Posts: 86
Joined: 2004-07-16 17:22
Location: Hamburg

Re: Probleme mit spamassasin

Post by toberkel » 2006-04-01 13:12

Danke. Werde das mal testen und dann mal hier bescheid geben...

mfg,

toberkel