Automatischer Reboot?

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
nb-magnum
Posts: 10
Joined: 2006-02-13 14:54

Automatischer Reboot?

Post by nb-magnum » 2006-02-13 15:07

Hallo!

Von diesen Einträgen scheint es wohl schon viele zugeben, nur habe ich bis jetzt keinen gefunden der ungefähr das Beschreibt was mir in den letzten Wochen so passiert ist.

Also ich betreibe einen V-Server
Linux 2.4.20-021stab028.729.777-smp #1 SMP Fri Nov 18 17:08:43 MSK 2005 x86_64 x86_64 x86_64 GNU/Linux

Nu ist es so das sich der Server warum auch immer in unregelmäßigen Abständen neu rebootet.

Die letzten Zeilen und ersten neuen Zeilen aus der messages sind:

Code: Select all

Feb 13 14:10:19 v22961 init: Switching to runlevel: 0
Feb 13 14:10:21 v22961 xinetd[23006]: Exiting...
Feb 13 14:10:22 v22961 sshd[23019]: Received signal 15; terminating.
Feb 13 14:10:24 v22961 saslauthd[22973]: server_exit     : master exited: 22973
Feb 13 14:10:24 v22961 exiting on signal 15
Feb 13 14:45:46 v22961 syslogd 1.4.1: restart.
Feb 13 14:45:46 v22961 saslauthd[22774]: detach_tty      : master pid is: 22774
Feb 13 14:45:46 v22961 saslauthd[22774]: ipc_init        : listening on socket: /var/run/sasl2//mux
hat jemand eine plausible Erklärung?

encbladexp
Posts: 84
Joined: 2006-01-04 12:09
Location: Lichtenfels

Re: Automatischer Reboot?

Post by encbladexp » 2006-02-13 15:52

nb-magnum wrote: Nu ist es so das sich der Server warum auch immer in unregelmäßigen Abständen neu rebootet.
Warum? Kein einziger Threadstarter konnte bis jetzt erlären warum man nen Server rebooten sollte! Ist das wirklich so modern?

Code: Select all

Feb 13 14:10:19 v22961 init: Switching to runlevel: 0
Feb 13 14:10:21 v22961 xinetd[23006]: Exiting...
Feb 13 14:10:22 v22961 sshd[23019]: Received signal 15; terminating.
Feb 13 14:10:24 v22961 saslauthd[22973]: server_exit     : master exited: 22973
Feb 13 14:10:24 v22961 exiting on signal 15
Feb 13 14:45:46 v22961 syslogd 1.4.1: restart.
Feb 13 14:45:46 v22961 saslauthd[22774]: detach_tty      : master pid is: 22774
Feb 13 14:45:46 v22961 saslauthd[22774]: ipc_init        : listening on socket: /var/run/sasl2//mux
Keine Angst, das sind ganz normale Meldungen bei einem SystemBoot...

mfg Betz Stefan
PS: In der Log steht aber auch nix abnormales drin, wie kommst du dauf das es nicht normal sein könnte?

nb-magnum
Posts: 10
Joined: 2006-02-13 14:54

Re: Automatischer Reboot?

Post by nb-magnum » 2006-02-13 16:02

Schon mal danke für deine Antwort.

Ich will meinen Server ja gar nicht automatisch neustartet. Von mir aus kann der 365Tage im Jahr ohne reboot durchlaufen. Nur leider scheint es mir so das er alle 3-4 Tage, in unregelmäßigen Abständen, was schon mal nicht auf einen cron-job hinweist, einen reboot zu machen ohne das ich es will.

Gruß
Niels

wgot
RSAC
Posts: 1707
Joined: 2003-07-06 02:03

Re: Automatischer Reboot?

Post by wgot » 2006-02-13 16:11

Hallo,

gib mal

Code: Select all

uptime
ein, da wird angezeigt wie lange das System schon läuft.

Möglicherweise wird das Gesamtsystem alle paar Tage automatisch oder vom Provider neu gestartet.

Gruß, Wolfgang

encbladexp
Posts: 84
Joined: 2006-01-04 12:09
Location: Lichtenfels

Re: Automatischer Reboot?

Post by encbladexp » 2006-02-13 17:25

Okey, ich sollte den Text doch ein bischen genauer lesen... Mein Fehler...

Schon mal dem Provider ne Mail geschickt?

Das dein System in Runlevel 0 wechselt finde ich irgendwie komisch, Cron-Job usw. schließe ich auch aus, es ist ja wie du sagst unregelmäßig...

Ich würde erst mal den Provider Feuer unterm Arsch machen...

mfg Betz Stefan

nb-magnum
Posts: 10
Joined: 2006-02-13 14:54

Re: Automatischer Reboot?

Post by nb-magnum » 2006-02-14 07:42

Hallo,
nein dem Provider habe ich noch keine Mail geschrieben, wollte mir wenn noch mal ein paar Zeiten aufschreiben wann er so weg is.

Uptime sagt:

Code: Select all

v22961:~ # uptime
  7:39am  up  16:41,  1 user,  load average: 0.23, 0.07, 0.02
Gruß
Niels

wgot
RSAC
Posts: 1707
Joined: 2003-07-06 02:03

Re: Automatischer Reboot?

Post by wgot » 2006-02-14 10:24

Hallo,
nb-magnum wrote: 7:39am up 16:41, 1 user, load average: 0.23, 0.07, 0.02
bei den gängigen einfachen Vserversystemen ist die angegebene Uptime (16:41 Stunden) die Uptime des Gesamtsystems, ob das auch für Deinen gilt kannst Du schnell ausprobieren, einfach selbst neu starten und nachsehen ob die Uptime unverändert ist.

Falls der Provider das System häufig neu starten muß (oder das System sich selbst) liegt entweder ein Hardwareproblem vor oder zu hohe Auslastung.

Gruß, Wolfgang