Prob mit Mysql /php-Forum

MySQL, PostgreSQL, SQLite
firewall
Posts: 4
Joined: 2006-01-29 16:09

Prob mit Mysql /php-Forum

Post by firewall » 2006-01-29 16:19

Hi,
Ich habe folgendes Problem:
Auf unserem Root-Server ist ein PHP-Forum installiert. Bei manchen Beiträgen dauert es stunden bis sie sich öffnen lassen. Ich habe mir die Auslastung des Servers angeschaut, jedoch ist alles normal.
Ein Freund hat sich das ganze dann angeschaut und hat mir gesagt, dass der Mysql ein Problem mit einem Apache-Modul habe und dass das Problem durch ein update via yast gelöst sein würde. Dies hab ich dann auch durchgeführt jedoch hat sich an den ladezeiten des Forums nichts getan.
Der Mysql lässt sich auch nicht fehlerfrei neustarten.
beim starten wird mir "failure" angezeigt, jedoch läuft er trotzdem.

Danke für euere Hilfe. Und bitte zerfleischt mich nicht gleich :) Bin ziemlicher neuling auf dem linuxgebiet

niemand
Posts: 142
Joined: 2003-12-12 18:36

Re: Prob mit Mysql /php-Forum

Post by niemand » 2006-01-29 16:47

Aalso
dass es SuSE zu sein scheint,konnte ich gerade noch rauslesen. Ansonsten: Welche Version von
- mysql
- php
- Apache
- welche Forensoftware,
wie sind die jeweiligen Sachen konfiguriert, und was sagen die relevanten Logs?

cu

firewall
Posts: 4
Joined: 2006-01-29 16:09

Re: Prob mit Mysql /php-Forum

Post by firewall » 2006-01-29 20:19

MySQL 4.0.15
phpMyAdmin 2.5.3
PHP Version 4.3.3
apache 2.0.48
und die Forensoftware ist phpBB 2.0.17


beim restarten von mysql wird mir follgendes angezeigt:

kassel094:/ # /etc/init.d/mysql restart
Restarting service MySQL
Shutting down service mysql
done
Starting service MySQL
failed


bei weitern logs brauch ich hilfe: - wie komm ich dran ?

User avatar
Joe User
Project Manager
Project Manager
Posts: 11137
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Prob mit Mysql /php-Forum

Post by Joe User » 2006-01-29 20:32

Als Erstes installierst Du bitte sämtliche verfügbaren Updates für sämtliche installierte Software (inklusive Scripte). Danach führst Du folgende Befehle aus:

Code: Select all

/etc/init.d/mysql stop
/etc/init.d/mysql stop
/etc/init.d/mysql start
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

firewall
Posts: 4
Joined: 2006-01-29 16:09

Re: Prob mit Mysql /php-Forum

Post by firewall » 2006-01-29 20:37

die die mir von yast aufgelistet werden ?
oder gibt es da noch welche die ich irgendwie manuel nachinstallieren muss ?

User avatar
Joe User
Project Manager
Project Manager
Posts: 11137
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Prob mit Mysql /php-Forum

Post by Joe User » 2006-01-29 20:41

Firewall wrote:die die mir von yast aufgelistet werden ?
Ja.
Firewall wrote:oder gibt es da noch welche die ich irgendwie manuel nachinstallieren muss ?
Ja, beispielsweise phpMyAdmin und phpBB2...
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

firewall
Posts: 4
Joined: 2006-01-29 16:09

Re: Prob mit Mysql /php-Forum

Post by firewall » 2006-01-29 21:28

k nächstes problem... dreh bald durch ^^

ich komm nicht mehr in phpmyadmin rein... zeigt mir folgendes an:

Code: Select all

Warning: ini_set(): Unable to access in /srv/www/htdocs/phpMyAdmin/libraries/session.inc.php on line 39

Warning: parse_url(http:///phpmyadmin/): Unable to parse url in /srv/www/htdocs/phpMyAdmin/libraries/common.lib.php on line 1297

Warning: Cannot modify header information - headers already sent by (output started at /srv/www/htdocs/phpMyAdmin/libraries/session.inc.php:39) in /srv/www/htdocs/phpMyAdmin/libraries/select_theme.lib.php on line 92

Warning: Cannot modify header information - headers already sent by (output started at /srv/www/htdocs/phpMyAdmin/libraries/session.inc.php:39) in /srv/www/htdocs/phpMyAdmin/index.php on line 121