Problem Mailversand von Client an Server....

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
leechi
Posts: 33
Joined: 2005-02-10 17:16

Problem Mailversand von Client an Server....

Post by leechi » 2006-01-19 09:09

hallo,

habe arge probleme beim mailversand.

Server: Plesk 7.5.4 auf debian 3.1

Ich und auch meine kunden wollen mails mit thunderbird oder outlook versenden,

problem ist:

sobald man mal 2 oder 3 oder auch mehrere mails hintereinander versenden will,

dann kommt der fehler das der smtp nicht erreichbar ist!

hier mal ein screenshot von einem Kunden:

http://www.fitnessgate.de

die logfiles bringen mich leider nicht weiter, weil ich nix darin finde!

wäre für jeden hinweis dankbar !
Last edited by leechi on 2006-02-23 12:18, edited 2 times in total.

7lifes
Posts: 60
Joined: 2005-08-09 11:46

Re: Problem Mailversand von Client an Server....

Post by 7lifes » 2006-01-19 09:49

sag mir doch bitte mal wie wir dir so helfen sollen.
mit einem screen shot?

Poste die wichtigsten logdatien.
ach ja, welchem mta benutzt du eigentlich?

also da musst du shcon mit mehr infos rüberkommen. sonst kann dir hier wohl niemand helfen.

leechi
Posts: 33
Joined: 2005-02-10 17:16

Re: Problem Mailversand von Client an Server....

Post by leechi » 2006-01-19 09:59

sorry,

es läuft qmail auf der kiste !

die logfiles sagen nichts aus,

außer das halt keine smtp verbindung aufgebaut werden konnte !
wegen timeout !

kann man denn bei qmail begrenzen oder einstellen wieviele smtp server verbindungen laufen sollen ??

bin leider schon fast am verzweifeln...

7lifes
Posts: 60
Joined: 2005-08-09 11:46

Re: Problem Mailversand von Client an Server....

Post by 7lifes » 2006-01-19 10:08

schrieb mir mal die gneaue fehlermeldung die im log steht. auch wenns nur der timeout ist.

leechi
Posts: 33
Joined: 2005-02-10 17:16

Re: Problem Mailversand von Client an Server....

Post by leechi » 2006-01-19 10:18

bin leider momentan auf arbeit.
hab hier kein ssh zugang.

welche logfiles wären denn wichtig für dich ?

ich weiß nur eines,

der versand von mail ist allg. möglich,

jedoch sobald ich halt eine oder 2 versendet habe mit thunderbird oder outlook, dann kann er sich nicht mehr verbinden.

kennt sich jemand mit qmail aus ob man dort maximale connections einstellen kann.

dieses problem ist im swsoft forum auch zu finden, aber eine lösung kann ich dort nicht erkennen.

habe auch unter/courier-imap/pop3d und imapd den wert maxperip erhöht, aber daran liegt es nicht.

irgendwas scheint da buggy zu sein!

die kiste habe ich auch schon komplett neu aufgesetzt und siehe da, gleiches problem besteht weiterhin!

7lifes
Posts: 60
Joined: 2005-08-09 11:46

Re: Problem Mailversand von Client an Server....

Post by 7lifes » 2006-01-19 10:30

würde mich persönlich wundern. da qmail ja nur einen deamon hat um smtp anfragen auf port 25 entgegen zu nehmen. ich denke die genaue fehlermeldung wird da schon weierhelfen.

poste diese mal, dann kann man schauen.

aber mal als kleine anmerkung.

in qmail werden einstellungen über anlegen einzelner config dateien relisiert.

ins qmail config verzichniss gehen. dort müsen für jede einzelne einstellung eine einzelne datei angelegt werden.

dein problem könnten diese 3 sein. wenn es sie nicht gibt anlegen, und einfach den gwünschten wert reinschreiben. mehr nicht.

Datei: concurrencyincoming
Standtwartwert:none
Benutzt: /service/qmail-smtpd/run
Zweck: Maximum der gleichzeitig hereinkommenden SMTP-Verbindungen

Datei: timeoutconnect
Standartwert: 60
Benutzt: qmail-remote
Zweck: Wie lange, in Sekunden, auf eine SMTP-Verbindung gewartet wird

Datei: timeoutsmtpd
Standartwert: 1200
Benutzt: qmail-smtpd
Zweck: Wie lange, in Sekunden, auf einen SMTP-Client gewartet wird

Mfg,
7

leechi
Posts: 33
Joined: 2005-02-10 17:16

Re: Problem Mailversand von Client an Server....

Post by leechi » 2006-01-19 10:41

7lifes wrote:Datei: concurrencyincoming
Standtwartwert:none
Benutzt: /service/qmail-smtpd/run
Zweck: Maximum der gleichzeitig hereinkommenden SMTP-Verbindungen

da hätte ich doch glatt noch eine frage dazu,

datei anlegen und "MAXSMTP= irgendnezahl" reinschreiben und mehr nicht ?

geht das wirklich, denn qmail wird mit plesk automatisch installiert und nutzt kein vpopmail!

und dazu, den pfad /service/qmail-smtpd/run gibts bei mir nicht.

7lifes
Posts: 60
Joined: 2005-08-09 11:46

Re: Problem Mailversand von Client an Server....

Post by 7lifes » 2006-01-19 10:58

also, dies beizeht sich alles auf eine installation aus den sourcen, eines normalen qmail. in wie weit das plesk paket dort änderungen hat, kann ich dir nicht sagen.

ich denke es ist aber einen versuch wert.
geh in /var/qmail/control.

Dort liegen die Config Datei bei einer "normalen" Installation.

Dort legst du die Datei concurrencyincoming an. ohne .cf etc.
in diese datei schriebt du einfach den wert hinein, welche für dieses kontrollelement gelten soll. also z.b. 30 für 30 gleichzeitge verbindungen.

speichern, qmail restart fertig.

kann dafür natürlich keien garantie übernhemen, aber ich denke der aufbau bei plesk wird sich in sachen kontrolle nicht viel unterscheiden. hab noch nie mit dem plesk qmail gearbeitet, daher kann ich dir nur den weg aus den sourcen sagen.

sorry :(

leechi
Posts: 33
Joined: 2005-02-10 17:16

Re: Problem Mailversand von Client an Server....

Post by leechi » 2006-01-19 18:50

mhhh also damit hat es auch nix zu tun !

würde meinen es liegt an

POP autorisierung --> ja
SMTP Autorisierung __> ja


was meint ihr ??