gdlibc

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
atolos
Posts: 5
Joined: 2005-07-26 17:03

gdlibc

Post by atolos »

ok seit 3 tagen lese ich mich durchs internet, um ein gdlibc update zu machen...

Code: Select all

Dedicated Server
Linux Suse 9.0
Confixx 3 pro

Code: Select all

glibc-2.3.2 -> glibc-2.3.6
ich suche ein howto oder jemand der einen es auf deutsch erklärt... es muss doch irgendwo so etwas wie in der art...

schritt a:
schritt b:
schritt c:

... geben

bitte leute ich kann nicht nicht mehr... kann doch nicht so die welt sein...

ich brauche es für eine software die ich installieren will...

habt ein herz...

gruss ato
aubergine
Posts: 471
Joined: 2005-09-10 17:52
Location: Frankfurt am Main

Re: gdlibc

Post by aubergine »

Ich bin zwar normal gegen solche Betteln Threads, aber es ist ja Weihnachten...

Du läds dir das jeweilige für dein system runter:
ftp.softnet.tuc.gr/pub/linux/suse/projects/glibc/2.3.6/

Gibst ein:
rpm -i packetname.rpm
diavolo86
Posts: 22
Joined: 2005-01-19 18:37

SUSE 9.0 GLIBC

Post by diavolo86 »

Hi Leute ich hab auch das Selbe problem hab das gleiche gemacht bekomm aber eine kleine fehler meldung!!! :(
Kann mir da jemand helfen???

Code: Select all

rpm -i glibc-2.3.6-2.0.20051123.i586.rpm
        file /etc/ld.so.conf from install of glibc-2.3.6-2.0.20051123 conflicts with file from package aaa_base-9.0-10
        file /etc/nsswitch.conf from install of glibc-2.3.6-2.0.20051123 conflicts with file from package aaa_base-9.0-10
        file /lib/ld-linux.so.2 from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /lib/libBrokenLocale.so.1 from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /lib/libNoVersion.so.1 from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /lib/libSegFault.so from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /lib/libanl.so.1 from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /lib/libc.so.6 from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /lib/libcrypt.so.1 from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /lib/libdl.so.2 from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /lib/libm.so.6 from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /lib/libmemusage.so from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /lib/libnsl.so.1 from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /lib/libnss_compat.so.2 from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /lib/libnss_dns.so.2 from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /lib/libnss_files.so.2 from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /lib/libnss_hesiod.so.2 from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /lib/libnss_nis.so.2 from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /lib/libnss_nisplus.so.2 from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /lib/libpcprofile.so from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /lib/libpthread.so.0 from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /lib/libresolv.so.2 from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /lib/librt.so.1 from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /lib/libthread_db.so.1 from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /lib/libutil.so.1 from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /sbin/ldconfig from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /usr/bin/gencat from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /usr/bin/getconf from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /usr/bin/getent from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /usr/bin/iconv from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /usr/bin/ldd from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /usr/bin/lddlibc4 from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /usr/bin/locale from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /usr/bin/localedef from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /usr/lib/pt_chown from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /usr/sbin/iconvconfig from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /usr/sbin/rpcinfo from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /usr/share/man/man1/getconf.1.gz from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /usr/share/man/man1/getent.1.gz from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /usr/share/man/man1/iconv.1.gz from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /usr/share/man/man1/locale.1.gz from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /usr/share/man/man1/localedef.1.gz from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /usr/share/man/man5/locale.alias.5.gz from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
        file /usr/share/man/man8/rpcinfo.8.gz from install of glibc-2.3.6-2.0.20051123 conflicts with file from package glibc-2.3.2-92
Roger Wilco
Posts: 5923
Joined: 2004-05-23 12:53

Re: gdlibc

Post by Roger Wilco »

Warum wollen eigentliche alle immer sofort ihr System zerschießen? :roll:
oxygen
Posts: 2138
Joined: 2002-12-15 00:10
Location: Bergheim

Re: gdlibc

Post by oxygen »

Du kannst die glibc nicht upgraden. Da musst du schon auf eine neuere SuSE Version umsteigen.
diavolo86
Posts: 22
Joined: 2005-01-19 18:37

Re: gdlibc

Post by diavolo86 »

AJA gut zu wissen

kannst du mir sagen wie ich dieses auf einem Strato Dedicatet Server mache??? weil ich ja keine CD oder so einlegen kann!?!?!

Kann ich das über Yast über Online update machen???

Wenn ja macht das mein Confixx 3 mit???
User avatar
Joe User
Project Manager
Project Manager
Posts: 11165
Joined: 2003-02-27 01:00
Location: Hamburg

Re: gdlibc

Post by Joe User »

Wofür benötigt Ihr denn die glibc-2.3.6?
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
captaincrunch
Userprojekt
Userprojekt
Posts: 7066
Joined: 2002-10-09 14:30
Location: Dorsten

Re: gdlibc

Post by captaincrunch »

Vermutlich geht's wieder um irgend einen Gameserver-Krempel....schließlich muss sich anscheinend jeder Gameserver-Admin mal das System wegen eines "unbedingt nötigen" glibc-Upgrades zerschossen haben.

SCNR
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc
User avatar
isotopp
Posts: 471
Joined: 2003-08-21 10:21
Location: Berlin

Re: gdlibc

Post by isotopp »

diavolo86 wrote:Kann ich das über Yast über Online update machen???
Am einfachsten ist es mit einem Reinstall, wenn eine neuere Version angeboten wird.

In meinem Fall habe ich das mit einem neuen MR2 Suse 9.3 und install-apt4suse gemacht, ich habe das System dann mit einem apt dist-upgrade auf 10.0 gemacht.

Das ist eine High Risk Operation, deswegen habe ich das nicht auf meinem alten Dedi gemacht sondern nur auf dem neuen.

1. Neuinstallation mit 9.3 Professional ohne Adminstützräder.
2. vi /etc/SuSE-release, %s/9.3/10.0/g
3. rpm -Uvh http://..../install-apt4suse...rpm
4. apt update
5. apt dist-upgrade
6. Reboot
diavolo86
Posts: 22
Joined: 2005-01-19 18:37

Re: gdlibc

Post by diavolo86 »

Hi

also das ist kein Gameserver das ist ein Webserver und soll genau dazu verwendet werden!!!

wir haben einen Hostserver bei 1und1 der läuft aber noch auf Suse 8 und Confixx 2!

Deswegen haben wir und den neuen Bei Strato dazu gemietet und Spielen mit diesem befor ich aber ale Kunden von 1und1 zu Strato hole will ich PHP 5 installiert haben und dabei ist das Problem das ich LIBXML2 benötige höher als 2.6.11 wenn ich richtig bin und sobald ich dieses installiere will er eine LIBHISTORY.SO 4 und 5 und eione LIBREADLINER.so 4 und 5. Und nach langer sucherei hab ich heraus gefunden das diese in der GLIBC enthalten aber da die v. die drauf ist ja nicht geht und im Yast steht bei Probleme zu lösen ich soll GLIBC 2.4.4 installieren und das geht ja nicht da ich SUSE Linux 9.0 habe!!!

Ich habe kein Plan wie ich Confixx installiere usw. und ob Confixx dann immernoch im Paket mit drin ist wenn ich das Teil mit Suse 9.3 neu installiere!!!

Also was soll ich am besten tun bin kein Linux Crack bin eher Windows-Admin aber Windows im Webserver betrieb ist ja mehr wie unsicher!!! :D

MfG.
Diavolo
oxygen
Posts: 2138
Joined: 2002-12-15 00:10
Location: Bergheim

Re: gdlibc

Post by oxygen »

Das klingt für mich so, als wenn das libxml2 Paket nicht für deine Distribution bestimmt ist. Eh du die glibc updatest und dich damit ins verderben stürzt, solltest du eher mal genau nach einem passenden libxml2 Paket suchen. Oder es selbst kompilieren, sollte kein alzu großes Problem darstellen. Bei den meisten Source Paketen ist heuzutage ein .spec file bei, womit man geschwint ein passendes .rpm erzeugen kann. Damit bleibt sogar die Paketverwaltung konsistent. Wenn nicht, halt nach /usr/local damit und nur php dagegen linken.
diavolo86
Posts: 22
Joined: 2005-01-19 18:37

Re: gdlibc

Post by diavolo86 »

Is ja schön und gut mit dem LIBXML2 ich find aber keine v. 2.6.11 oder höher für suse 9.0 nur für 9.2 und die sagt ich will LIB-HISTORY.so 4 ud 5 und LIB-READLINER.so 4 und 5!!! also funzt das nicht so ganz da hilft mir doch auch das kompilieren nichts oder???
oxygen
Posts: 2138
Joined: 2002-12-15 00:10
Location: Bergheim

Re: gdlibc

Post by oxygen »

Doch. Da hilft selbst kompileren, oder selbst rpm bauen.
User avatar
Joe User
Project Manager
Project Manager
Posts: 11165
Joined: 2003-02-27 01:00
Location: Hamburg

Re: gdlibc

Post by Joe User »

Die fehlenden *.so befinden sich nicht in den glibc-Paketen, sondern in den bash/readline-Paketen...
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
diavolo86
Posts: 22
Joined: 2005-01-19 18:37

Re: gdlibc

Post by diavolo86 »

Moin Leute das Problem mit dem LibXML2 konnte ich gestern lösen dank OXYGEN hab das teil kompiliert und installiert bekommen :D!

SO hab aber leider immer noch im Apache v. 4.3.3.

Hab dann noch eine Anleitung gefunden worin alles nochmal schritt für schritt erklärt ist. [http://www.zdnet.de/builder/program/0,3 ... 6-3,00.htm]

Hab auch den Apache usq noch installiert aber der hat mir das komplett in ein anderes verzeichniss gelegt usw. aber da geht null PHP :/!

kann mir jemand helfen???