E-Mailproblem auf Schlund-Rootserver

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
beamish
Posts: 11
Joined: 2005-12-22 20:38
Location: Berlin

E-Mailproblem auf Schlund-Rootserver

Post by beamish » 2005-12-22 20:45

Hallo zusammen,

ich habe seit einigen Wochen einen Rootserver bei Schlund und Partner gemietet und nun tauchen folgende Probleme auf:

1.) Von Domain A nach B (beide auf demselben Server) gehen die Mails problemlos durch.
Replies oder Mails von B nach A kommen nicht an... Eine serverseitige Fehlermeldung an den Absender erfolgt nicht.

2.) Eine Domain bekommt von eizelnen externen Domains keine Mails.
Der Spamfilter ist aktiv - Spams werden aber nur markiert im header, aber nicht gelöscht - daran sollte es also nicht liegen.


Wer kann einen Tip geben???

weitere Infos:
Domains werden bei X-Link (Schlundtech) gehostet... MX-Records zeigen auch auf den Rootserver..

Admininterface auf dem Server: Plesk 7.5 reloaded


Gruß aus Berlin,

Marco

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: E-Mailproblem auf Schlund-Rootserver

Post by dodolin » 2005-12-23 13:02

Sorry, aber so ist nicht zu helfen!

Es fehlen:
- Echte Domainnamen, die betroffen sind
- verwendete MTA Software
- Logfiles
- bisher unternommene Versuche, dem Problem auf den Grund zu gehen

beamish
Posts: 11
Joined: 2005-12-22 20:38
Location: Berlin

Re: E-Mailproblem auf Schlund-Rootserver

Post by beamish » 2006-01-02 16:09

Hi Dodolin...

also ..

folgendes Problem..

Mails von info@chamaeleonreisen.de (auf meinem Server) kommen bei martinrichter@vietnam-air.de an.

Andersrum geht es nicht.
Eine Fehlermeldung wird nicht an die Absenderadresse von vietnam-air geschickt.
Eine Mail von Vietnam-Air.de an marco.gau@king-com.de (meine Adresse auf demselben Rootserver wie chamaeleonreisen.de) kommt ebenfalls nicht an.

Andere Mails von anderen Absendern kommen problemlos an.

Im var/log-Verzeichnis auf dem Server liegen ja nun einige Logs.

weder in der mail.err noch in der mail.warn oder der mail.info konnte ich Einträge finden, in denen eine Mail VON vietnam-air.de auftaucht. Einige Einträge AN vietnam-air finde ich .. sind auch ohne Error rausgegangen.

Es taucht aber ab und zu folgender Logeintrag auf:
-----------------------------

Jan 2 15:19:29 s15185846 qmail: 1136211569.628089 new msg 21001193
Jan 2 15:19:29 s15185846 qmail: 1136211569.628185 info msg 21001193: bytes 3447 from <#@[]> qp 7332 uid 2522
Jan 2 15:19:29 s15185846 qmail: 1136211569.635694 starting delivery 135393: msg 21001193 to remote postmaster@s15185846.rootmaster.info
Jan 2 15:19:29 s15185846 qmail: 1136211569.635792 status: local 0/10 remote 1/20
Jan 2 15:19:29 s15185846 qmail: 1136211569.639696 delivery 135393: failure: Sorry._Although_I'm_listed_as_a_best-preference_MX_or_A_for_that_host,/it_isn't_in_my_control/locals_file,_so_I_don't_treat_it_as_local._(#5.4.6)/

-----------------------------------

Was kann ich noch machen, um sicherzustellen, dass das Problem nicht auf meinem Server liegt?

Was meinst du mit MTA-Software ??

Gruß,

Marco

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: E-Mailproblem auf Schlund-Rootserver

Post by dodolin » 2006-01-02 23:17

Jan 2 15:19:29 s15185846 qmail: 1136211569.639696 delivery 135393: failure: Sorry._Although_I'm_listed_as_a_best-preference_MX_or_A_for_that_host,/it_isn't_in_my_control/locals_file,_so_I_don't_treat_it_as_local._(#5.4.6)/
Das ist doch schonmal recht eindeutig. Du musst deinem QMail auch sagen, für welche Domains er zuständig ist. Da ich mich aber mit QMail nicht auskenne und mich da auch nicht mittels Googel schlau machen möchte, musst du für mehr Details wohl warten, bis ein QMail-Experte sich zu Wort meldet.

Wenn du das alles über Plesk machst, musst du eventuell dort mal nachschauen, dass auch alle betroffenen Domains da korrekt eingetragen sind, damit dein QMail die dann kennt. Auch von Plesk habe ich keine Ahnung, kann daher nicht viel dazu sagen.

beamish
Posts: 11
Joined: 2005-12-22 20:38
Location: Berlin

Re: E-Mailproblem auf Schlund-Rootserver

Post by beamish » 2006-01-03 08:00

Hmmm.

das kann doch aber eigentlich garnicht sein, oder?
Deine Antwort würde bedeuten, dass GARKEINE Message an mein E-Mailpostfach weitergeleitet wird.

Das Postfach als solches bekommt ja aber Mail.. nur eben nicht von Absendern der Domain vietnam-air.de.

Ich habe mir gestern von Vietnam-Air auch eine Mail an mein Postfach marco.gau@king-com.de schicken lassen, welches ebenfalls auf demselben Server liegt. Auch diese Mails kamen nicht an - verliessen den Absender aber ohne Fehlermeldung.

Es scheint also so, dass die Mails

1.) entweder garnicht erst an meinem Server ankommen
2.) oder aus irgendeinem Grund ignoriert werden. Ich habe die komplette Domain in die Whitelist meines SPAM-ASSASSIN eingetregen, aber es hilft nichts. Also das kann auch nicht der Grund sein.

Gruß,

Marco