InnoDB Tabellentyp einschalten??

MySQL, PostgreSQL, SQLite
becks123
Posts: 28
Joined: 2005-03-11 00:19

InnoDB Tabellentyp einschalten??

Post by becks123 » 2005-12-03 10:01

Servus Leute,

habe folgendes Problem:

Ich würde gerne InnoDB bei MySql einschalten. Wenn ich aber die entsprechenden Zeilen in der my.cnf einschalte, dann startet der mysql dienst nicht mehr ("failed").

Hier meine my.cnf

Code: Select all

# Example mysql config file for medium systems.
#
# This is for a system with little memory (32M - 64M) where MySQL plays
# a important part and systems up to 128M very MySQL is used together with
# other programs (like a web server)
#
# You can copy this file to
# /etc/my.cnf to set global options,
# mysql-data-dir/my.cnf to set server-specific options (in this
# installation this directory is /var/lib/mysql) or
# ~/.my.cnf to set user-specific options.
#
# One can in this file use all long options that the program supports.
# If you want to know which options a program support, run the program
# with --help option.

# The following options will be passed to all MySQL clients
[client]
#password	= your_password
port		= 3306
socket		= /var/lib/mysql/mysql.sock

# Here follows entries for some specific programs

# The MySQL server
[mysqld]
port		= 3306
socket		= /var/lib/mysql/mysql.sock
skip-locking
set-variable	= key_buffer=16M
set-variable	= max_allowed_packet=1M
set-variable	= table_cache=64
set-variable	= sort_buffer=512K
set-variable	= net_buffer_length=8K
set-variable	= myisam_sort_buffer_size=8M
set-variable    = max_connection=200
log-bin
server-id	= 1

# Point the following paths to different dedicated disks
#tmpdir		= /tmp/		
#log-update 	= /path-to-dedicated-directory/hostname

# Uncomment the following if you are using BDB tables
#set-variable	= bdb_cache_size=4M
#set-variable	= bdb_max_lock=10000

# Uncomment the following if you are using InnoDB tables
#innodb_data_home_dir = /var/lib/mysql/
#innodb_data_file_path = ibdata1:10M:autoextend
#innodb_log_group_home_dir = /var/lib/mysql/
#innodb_log_arch_dir = /var/lib/mysql/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
#set-variable = innodb_buffer_pool_size=16M
#set-variable = innodb_additional_mem_pool_size=2M
# Set .._log_file_size to 25 % of buffer pool size
#set-variable = innodb_log_file_size=5M
#set-variable = innodb_log_buffer_size=8M
#innodb_flush_log_at_trx_commit=1
#set-variable = innodb_lock_wait_timeout=50

# The safe_mysqld script
[safe_mysqld]
err-log=/var/lib/mysql/mysqld.log

[mysqldump]
quick
set-variable	= max_allowed_packet=16M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[isamchk]
set-variable	= key_buffer=20M
set-variable	= sort_buffer=20M
set-variable	= read_buffer=2M
set-variable	= write_buffer=2M

[myisamchk]
set-variable	= key_buffer=20M
set-variable	= sort_buffer=20M
set-variable	= read_buffer=2M
set-variable	= write_buffer=2M

[mysqlhotcopy]
interactive-timeout

Folgende Zeilen hab ich jetzt wieder auskommentiert:

Code: Select all

# Uncomment the following if you are using InnoDB tables
innodb_data_home_dir = /var/lib/mysql/
innodb_data_file_path = ibdata1:10M:autoextend
innodb_log_group_home_dir = /var/lib/mysql/
innodb_log_arch_dir = /var/lib/mysql/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
set-variable = innodb_buffer_pool_size=16M
set-variable = innodb_additional_mem_pool_size=2M
# Set .._log_file_size to 25 % of buffer pool size
set-variable = innodb_log_file_size=5M
set-variable = innodb_log_buffer_size=8M
innodb_flush_log_at_trx_commit=1
set-variable = innodb_lock_wait_timeout=50
Jetzt startet der mysql dienst mit "/etc/init.d/mysql restart" nicht mehr.

Hab ich was falsch gemacht?

Danke![/code]

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: InnoDB Tabellentyp einschalten??

Post by Roger Wilco » 2005-12-03 11:53

Schau in deine mysqld.log und mysqld.err. Da sollte drinstehen, weshalb MySQL nicht mehr startet.

becks123
Posts: 28
Joined: 2005-03-11 00:19

Re: InnoDB Tabellentyp einschalten??

Post by becks123 » 2005-12-04 16:02

Also die mysqld.log hab ich gefunden. Da steht folgendes, wenn ich den mysql restarte:

Code: Select all

051204 15:12:00  mysqld started
/usr/sbin/mysqld: unrecognized option `--innodb_data_home_dir=/var/lib/mysql/'
/usr/sbin/mysqld  Ver 3.23.52 for suse-linux on i686

Ich denke mal er kennt die option nicht....wie kann ich den fehler beheben? Bzw. was muss ich umstellen?

Danke!