mysqld.sock fehlt

MySQL, PostgreSQL, SQLite
tecci
Posts: 48
Joined: 2003-09-07 14:40

mysqld.sock fehlt

Post by tecci » 2005-11-27 19:33

Hallo,

habe bereits in der Suche gesucht, jedoch hat mir nichts weitergeholfen... Also poste ich euch mal die ganzen Fehlermeldungen:

Shell

Code: Select all

vhost1:~# /etc/init.d/mysql start
Starting MySQL database server: mysqld...failed.
        Please take a look at the syslog.
/usr/bin/mysqladmin: connect to server at 'localhost' failed
error: 'Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)'
Check that mysqld is running and that the socket: '/var/run/mysqld/mysqld.sock' exists!
Syslog

Code: Select all

Nov 27 19:23:07 vhost1 mysqld_safe[4485]: started
Nov 27 19:23:08 vhost1 mysqld[4489]: 051127 19:23:08 /usr/sbin/mysqld: unknown variable 'old_passwords=1'
Nov 27 19:23:08 vhost1 mysqld[4489]: 
Nov 27 19:23:08 vhost1 mysqld_safe[4492]: ended
Nov 27 19:23:13 vhost1 /etc/init.d/mysql[4558]: 0 processes alive and '/usr/bin/mysqladmin --defaults-file=/etc/mysql/debian.cnf ping' resulted in
Nov 27 19:23:13 vhost1 /etc/init.d/mysql[4558]: ^G/usr/bin/mysqladmin: connect to server at 'localhost' failed
Nov 27 19:23:13 vhost1 /etc/init.d/mysql[4558]: error: 'Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)'
Nov 27 19:23:13 vhost1 /etc/init.d/mysql[4558]: Check that mysqld is running and that the socket: '/var/run/mysqld/mysqld.sock' exists!
Nov 27 19:23:13 vhost1 /etc/init.d/mysql[4558]: 
my.cnf

Code: Select all

#
# The MySQL database server configuration file.
#
# You can copy this to one of:
# - "/etc/mysql/my.cnf" to set global options,
# - "/var/lib/mysql/my.cnf" to set server-specific options or
# - "~/.my.cnf" to set user-specific options.
# 
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.
#
# For explanations see
# http://dev.mysql.com/doc/mysql/en/server-system-variables.html

# This will be passed to all mysql clients
# It has been reported that passwords should be enclosed with ticks/quotes
# escpecially if they contain "#" chars...
# Remember to edit /etc/mysql/debian.cnf when changing the socket location.
[client]
port		= 3306
socket		= /var/run/mysqld/mysqld.sock

# Here is entries for some specific programs
# The following values assume you have at least 32M ram

# This was formally known as [safe_mysqld]. Both versions are currently parsed.
[mysqld_safe]
socket		= /var/run/mysqld/mysqld.sock
nice		= 0

[mysqld]
#
# * Basic Settings
#
user		= mysql
pid-file	= /var/run/mysqld/mysqld.pid
socket		= /var/run/mysqld/mysqld.sock
port		= 3306
basedir		= /usr
datadir		= /var/lib/mysql
tmpdir		= /tmp
language	= /usr/share/mysql/english
skip-external-locking
#
# For compatibility to other Debian packages that still use
# libmysqlclient10 and libmysqlclient12.
old_passwords	= 1
#
# Instead of skip-networking you can now listen only on
# localhost which is more compatible and is not less secure.
#bind-address		= 127.0.0.1
skip-networking
#
# * Fine Tuning
#
key_buffer		= 16M
max_allowed_packet	= 16M
thread_stack		= 128K
#
# * Query Cache Configuration
#
query_cache_limit	= 1048576
query_cache_size        = 16777216
query_cache_type        = 1
#
# * Logging and Replication
#
# Both location gets rotated by the cronjob.
# Be aware that this log type is a performance killer.
#log		= /var/log/mysql.log
#log		= /var/log/mysql/mysql.log
#
# Error logging goes to syslog. This is a Debian improvement :)
#
# Here you can see queries with especially long duration
#log-slow-queries	= /var/log/mysql/mysql-slow.log
#
# The following can be used as easy to replay backup logs or for replication.
#server-id		= 1
log-bin			= /var/log/mysql/mysql-bin.log
# See /etc/mysql/debian-log-rotate.conf for the number of files kept.
max_binlog_size         = 104857600
#binlog-do-db		= include_database_name
#binlog-ignore-db	= include_database_name
#
# * BerkeleyDB
#
# According to an MySQL employee the use of BerkeleyDB is now discouraged
# and support for it will probably cease in the next versions.
skip-bdb
#
# * InnoDB
#
# InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
# Read the manual for more InnoDB related options. There are many!
#
# * Security Features
#
# Read the manual, too, if you want chroot!
# chroot = /var/lib/mysql/
#
# If you want to enable SSL support (recommended) read the manual or my
# HOWTO in /usr/share/doc/mysql-server/SSL-MINI-HOWTO.txt.gz
# ssl-ca=/etc/mysql/cacert.pem
# ssl-cert=/etc/mysql/server-cert.pem
# ssl-key=/etc/mysql/server-key.pem



[mysqldump]
quick
quote-names
max_allowed_packet	= 16M

[mysql]
#no-auto-rehash	# faster start of mysql but no tab completition

[isamchk]
key_buffer		= 16M

#
# * NDB Cluster
#
# See /usr/share/doc/mysql-server-*/README.Debian for more information.
#
# The following configuration is read by the ndbd storage daemons,
# not from the ndb_mgmd management daemon.
#
# [MYSQL_CLUSTER]
# ndb-connectstring=127.0.0.1
Danke im Voraus und noch einen schönen ersten Advent,
Michael

P.S.: MySQL läuft definitiv nicht.

snowball
Posts: 218
Joined: 2004-09-15 10:14

Re: mysqld.sock fehlt

Post by snowball » 2005-11-27 19:49

Hi,
was passiert denn, wenn du hier
Nov 27 19:23:08 vhost1 mysqld[4489]: 051127 19:23:08 /usr/sbin/mysqld: unknown variable 'old_passwords=1'
mal nachschaust? Einfach mal auskommentieren und schauen was passiert.

Viele Grüße
Jochen

tecci
Posts: 48
Joined: 2003-09-07 14:40

Re: mysqld.sock fehlt

Post by tecci » 2005-11-27 20:06

Hab ich schon versucht, aber die Datei besteht nur aus Hyrogliephen... Da steht -zumindest nichts lesbar- von old_passwords

snowball
Posts: 218
Joined: 2004-09-15 10:14

Re: mysqld.sock fehlt

Post by snowball » 2005-11-27 20:08

Ok, der Tipp galt auch nicht für die Datei: mysqld, sondern für die my.cnf.

tecci
Posts: 48
Joined: 2003-09-07 14:40

Re: mysqld.sock fehlt

Post by tecci » 2005-11-27 21:01

Oh wie dumm von mir, hab das in der my.cnf gar nicht gesehen... :roll:

Tausend dank, jetzt klappt es :-D :-D :-D :-D :-D