Spamassassin tut nichts

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
webmartin
Posts: 7
Joined: 2005-09-28 20:39

Spamassassin tut nichts

Post by webmartin » 2005-11-16 04:39

Hallo Leute,
ich versuche jetzt schon ewig meinen Spamassassin unter Confixx3 und postfix zum laufen zu bringen, aber leider klappt das irgendwie nicht...
Habe jetzt aber eine gute Anleitung unter

http://forum.webhostlist.de/show/showthread.php?t=48503

gefunden mit der eigtl alles wunderbar aussieht, nur leider scheint Spamassassin die email überhaupt nicht anzuschauen. Der spamd prozess läuft aber die mails werden unverändert weitergereicht... Auch z.B. wird
X-Spam-Checker-Version: SpamAssassin
im Header der mail nicht ergänzt...

Wo könnte mein Fehler sein? Wo finde ich Anhaltspunkte?!?

Danke und Gruss,
Martin

schl
Posts: 343
Joined: 2003-02-05 11:26
Location: München/Unterschleißheim

Re: Spamassassin tut nichts

Post by schl » 2005-11-16 07:24

Ich tippe mal darauf, dass Du vergessen hast den Content Filter in Deinem MTA zu konfigurieren. Schau dazu bitte hier in der FAQ nach. Dort gibt es ein Beispiel, wie man Spamassassin in Postfix einbaut.

Und schau Dir das hier mal an:

http://www.geekly.com/entries/archives/00000155.htm

webmartin
Posts: 7
Joined: 2005-09-28 20:39

Re: Spamassassin tut nichts

Post by webmartin » 2005-11-16 17:16

vielleicht nochmal 2 auszuege aus meinen logfiles:

Code: Select all

procmail: [5781] Wed Nov 16 05:10:32 2005
procmail: Match on "< 256000"
procmail: Locking "spamassassin.lock"
procmail: Error while writing to "_VaB.4EreDB.h648148"
procmail: Lock failure on "spamassassin.lock"
procmail: Executing "/usr/bin/spamc"
procmail: No match on ! "^From[ ]"
procmail: Assigning "PATH=/XnirvanaX/bin:/bin:/usr/bin:/sbin:/usr/sbin:/usr/local/bin:/usr/local/sbin:/usr/bin/X11"
From xxx@xxx.de Wed Nov 16 05:10:32 2005
Subject: sdfsdf
Folder: /var/spool/mail/web1p1 2800

Code: Select all

Nov 16 05:10:32 h648148 spamd[871]: connection from localhost [127.0.0.1] at port 32989 
Nov 16 05:10:32 h648148 spamd[5784]: Still running as root: user not specified with -u, not found, or set to root.  Fall back to nobody. 
Nov 16 05:10:32 h648148 spamd[5784]: processing message <20051116041032.12B9C63C0C5@mein_server.de> for web1p1:65534. 
Nov 16 05:10:32 h648148 spamd[5784]: Use of uninitialized value in pattern match (m//) at /usr/lib/perl5/site_perl/5.8.1/Mail/SpamAssassin/Message/Node.pm line 119.  
Nov 16 05:10:32 h648148 spamd[5784]: Use of uninitialized value in pattern match (m//) at /usr/lib/perl5/site_perl/5.8.1/Mail/SpamAssassin/Message/Node.pm line 119.  
Nov 16 05:10:32 h648148 spamd[5784]: auto-whitelist: open of auto-whitelist file failed: locker: safe_lock: cannot create tmp lockfile /var/lib/nobody/.spamassassin/auto-whitelist.lock.mein_server.de.5784 for /var/lib/nobody/.spamassassin/auto-whitelist.lock: No such file or directory  
Nov 16 05:10:32 h648148 spamd[5784]: Use of uninitialized value in split at /usr/lib/perl5/site_perl/5.8.1/Mail/SpamAssassin/PerMsgStatus.pm line 863.  
Nov 16 05:10:32 h648148 spamd[5784]: Use of uninitialized value in pattern match (m//) at /usr/lib/perl5/site_perl/5.8.1/Mail/SpamAssassin/PerMsgStatus.pm line 870.  
Nov 16 05:10:32 h648148 spamd[5784]: Use of uninitialized value in concatenation (.) or string at /usr/lib/perl5/site_perl/5.8.1/Mail/SpamAssassin/PerMsgStatus.pm line 944.  
Nov 16 05:10:32 h648148 spamd[5784]: identified spam (3.7/2.0) for web1p1:65534 in 0.1 seconds, 2800 bytes.
ich hoffe das hilft weiter...

Danke,
Martin