SpamAssassin läst meinen Speicher voll laufen

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
deta
Posts: 64
Joined: 2003-09-17 12:09

SpamAssassin läst meinen Speicher voll laufen

Post by deta » 2005-09-30 16:39

Hallo

Ich habe ein extreme Problem..

SpamAssassin läst immer mehr meinen Speicher RAM voll laufen.

Belegt ca. 10 MB nach dem Start und geht auf über 150 MB und mehr so das der Server seinen Dienst quitiert..

Wer kann mir da helfen?

Kennt jemand das Problem?

cu Deta

stefanpropehan
Posts: 335
Joined: 2002-12-17 22:25
Location: Berlin

Re: SpamAssassin läst meinen Speicher voll laufen

Post by stefanpropehan » 2005-09-30 16:49

Das Problem sagt mir jetzt zwar nix, aber ich denke du lässt den sa als daemon laufen oder? Dann den sa mal im Debug Modus (Parameter -D wenn mich nicht alles täuscht) starten und evtl. relevante Logauszüge hier posten.

--
Stefan

deta
Posts: 64
Joined: 2003-09-17 12:09

Re: SpamAssassin läst meinen Speicher voll laufen

Post by deta » 2005-09-30 17:09

stefanpropehan wrote:Das Problem sagt mir jetzt zwar nix, aber ich denke du lässt den sa als daemon laufen oder? Dann den sa mal im Debug Modus (Parameter -D wenn mich nicht alles täuscht) starten und evtl. relevante Logauszüge hier posten.

--
Stefan
gestartet wird der beim booten ja über
die /etc/init.d/spamassassin

Da hab ich nix dran geändert hab da mal geschaut wie der Start ausschaut

PATH=/sbin:/bin:/usr/sbin:/usr/bin
DAEMON=/usr/sbin/spamd
PNAME=spamd
NAME=spamd
SNAME=spamassassin
DESC="SpamAssassin Mail Filter Daemon"

# Defaults - don't touch, edit /etc/default/spamassassin
OPTIONS=""

test -f /etc/default/spamassassin && . /etc/default/spamassassin

test -f $DAEMON || exit 0

set -e

case "$1" in
start)
echo -n "Starting $DESC: "
start-stop-daemon --start --quiet --name $PNAME
--oknodo --startas $DAEMON -- -d $OPTIONS

echo "$NAME."
;;



Mh und was soll ich jetzt wie verändern?
In welches Log soll ich mal schauen?

cu Deta

stefanpropehan
Posts: 335
Joined: 2002-12-17 22:25
Location: Berlin

Re: SpamAssassin läst meinen Speicher voll laufen

Post by stefanpropehan » 2005-09-30 17:18

Bitte lies doch meinen Post, du sollst den sa in den Debug Modus versetzen...
# Defaults - don't touch, edit /etc/default/spamassassin
OPTIONS=""
Also bitte editiere die /etc/default/spamassassin und setze in den Options den Parameter "-D", danach starte den sa neu und schaue in die entsprechenden log Dateien... /var/log/syslog



--
Stefan

deta
Posts: 64
Joined: 2003-09-17 12:09

Re: SpamAssassin läst meinen Speicher voll laufen

Post by deta » 2005-10-06 17:15

matzewe01 wrote:Hi,

kann es sein, dass Du eine ausgibiege Anzahl an filterregeln definiert hast ggf. noch eine grosse Menge an Blacklists?
Dadurch bläht sich der Speicherverbrauch extrem auf.
Zusätzlich prüfe doch mal, wieviele spamd Prozesse aktuell laufen.
ggf. kann man hier etwas optimieren.

Gruss Matze
Filter hab ich nichts besonderes..

Was etwas besserung schon gebracht hat ist
den zweiten Doppelpunkt zu entfernen.

:0: > :0

Was ich noch gesehen habe, das unmengen von Prozesse spamd aufmacht.
Kann man diese ev. einschränken? Wenn ja wo?

cu Deta

deta
Posts: 64
Joined: 2003-09-17 12:09

Re: SpamAssassin läst meinen Speicher voll laufen

Post by deta » 2005-10-06 21:30

bei mir Debian Woody wird das in der

/etc/default/spamassassin gemacht

Da hab ich das drinnen bei den Optionen

OPTIONS="--create-prefs --max-children 2 --helper-home-dir -d -x -q -L"

--max-children 2 damit funzt es bisher sehr gut mit..

cu Deta

deta
Posts: 64
Joined: 2003-09-17 12:09

Re: SpamAssassin läst meinen Speicher voll laufen

Post by deta » 2005-10-06 23:11

Werde ich sehen, wenn ich den Server freigebe..

Wenn richtig Traffic drauf ist bis jetzt luft er seit 2 Tagen stabil..

Wenn ich davor denke alle 6 Stunden war er platt und muste booten.

Danke

cu Deta