Quota Problem ohne ende :(

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
blnsnoopy26
Posts: 660
Joined: 2002-10-19 14:01

Quota Problem ohne ende :(

Post by blnsnoopy26 »

Hi,

OS: Suse 9.1 von 1&1
Kernel: 2.6.11.12 mit grsec
quota Support ist dort aktiviert.

Habe hier schon gesucht und habe dies gefunden.

--> http://www.rootforum.org/forum/viewtopi ... quotacheck

Leider lieferte mir dies und andere suchergebnisse kein erfolg auch google lieferte mir keine Lösung.

So mein Prpblem... Ich bekomme das quotasupport nur für /dev/sda1 aktiviert und /dev/sda1 ist die "/" Partition.

Wenn ich es aber auf die /home (/dev/sda7) Partition machen möchte sagt er immer nu Skipping es ist unmöglich dort irgendwas zu aktivieren.

ein: quotacheck -vagumf liefert:

Code: Select all

quotacheck: Checked 1030 directories and 27166 files
quotacheck: Skipping /dev/sda7 [/home]
alle benötigten files sind erstellt worden und selbst im /home Verzeichnis hatte ich es versucht - keine Chance.

Meine fstab sieht so aus:

Code: Select all

LABEL=/    /       ext3    defaults,usrquota        0       1
/dev/sda2    none    swap    sw
/dev/sda5            /usr                 xfs        defaults              0 2
/dev/sda6            /var                 xfs        defaults              0 2
/dev/sda7            /home                xfs        defaults,usrquota     0 2
proc            /proc   proc    defaults        0       0
devpts          /dev/pts        devpts  mode=0620,gid=5 0 0
/dev/tmpMnt     /tmp    ext2    loop,noexec,nosuid,rw 0 0
Und ein quotaon -guvp /home ergibt nur dies:
Und es lässt sich auch nicht aktivieren :(

Code: Select all

group quota on /home (/dev/sda7) is off
user quota on /home (/dev/sda7) is off

Code: Select all

rcquota stop
Turning off quota
/dev/sda1 [/]: user quotas turned off
                                                                                                                                                   done
rcquota start
Turning on quota
/dev/sda1 [/]: user quotas turned on
Ich habe die Vermutung, das die von 1&1 das Filesystem so aufgebaut das dies irgendwie nicht so funktioniert wie es soll. Selbst beim 1&1 Support konnte mir da nicht behilflich sein, daher seit ihr meine letzte Hoffnung eine Lösung zu finden.

Selbst nach diesem tollen Howto funzt es nicht:

--> http://www.linuxhaven.de/dlhp/HOWTO/min ... .html#toc4

Roger Wilco
Administrator
Administrator
Posts: 5923
Joined: 2004-05-23 12:53

Re: Quota Problem ohne ende :(

Post by Roger Wilco »

Nur / und /home sind mit der Option usrquota gemountet. / ist ext3, die Quota kann daher mit dem quotatool gesteuert werden. XFS hat ein eigenes Quotasystem (`man xfs_quota`), weshalb das mit den normalen Tools nicht ohne weiteres geht.

blnsnoopy26
Posts: 660
Joined: 2002-10-19 14:01

Re: Quota Problem ohne ende :(

Post by blnsnoopy26 »

Hi,

Ich habe schon so gut wie alles durch.

Auch habe ich gefunden, ist nur für Debian :(:

--> http://www.debianforum.de/wiki/?page=XF ... einrichten

aber quotatool gibs nicht für suse und aktiviert ist auch alles.
selbst google liefert mir da nichts.

Es ist nicht zu schaffen es zu aktivieren.
Gebt mir mal nen ansatz wonach ich noch suchen kann ausser nach "xfs quota aktivieren" bei google. Ich finde dazu sonst weiter nichts.

alexander newald
Posts: 1117
Joined: 2002-09-27 00:54
Location: Hannover

Re: Quota Problem ohne ende :(

Post by alexander newald »

Bei XFS wird quota aktiviert, wenn die Option quota in der fstab steht und die Partition gemountet wird. Quota setzen sollte dann gehen, quotacheck funktioniert aber generell nicht.

blnsnoopy26
Posts: 660
Joined: 2002-10-19 14:01

Re: Quota Problem ohne ende :(

Post by blnsnoopy26 »

Alexander Newald wrote:Bei XFS wird quota aktiviert, wenn die Option quota in der fstab steht und die Partition gemountet wird. Quota setzen sollte dann gehen, quotacheck funktioniert aber generell nicht.
Ist das dann so korrekt?

/dev/sda7 /home xfs defaults,usrquota 0 2

oder meinst du so?

/dev/sda7 /home xfs defaults,quota 0 2

alexander newald
Posts: 1117
Joined: 2002-09-27 00:54
Location: Hannover

Re: Quota Problem ohne ende :(

Post by alexander newald »

Ich habe es nur mit quota, aber usrquota sollte auch gehen. Einfach mal ausprobieren

Roger Wilco
Administrator
Administrator
Posts: 5923
Joined: 2004-05-23 12:53

Re: Quota Problem ohne ende :(

Post by Roger Wilco »

`man mount` und lies den Abschnitt "Mount options for xfs". Es gibt sowohl die Option quota, als auch usrquota in XFS.

blnsnoopy26
Posts: 660
Joined: 2002-10-19 14:01

Re: Quota Problem ohne ende :(

Post by blnsnoopy26 »

Roger Wilco wrote:`man mount` und lies den Abschnitt "Mount options for xfs". Es gibt sowohl die Option quota, als auch usrquota in XFS.
Ich habe mir das man mount durchgelesen und die platten sind nun folgender maßen gemounted:

Code: Select all

 mount -l
LABEL=/ on / type ext3 (rw,usrquota)
proc on /proc type proc (rw)
tmpfs on /dev/shm type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/sda5 on /usr type xfs (rw) [usr]
/dev/sda6 on /var type xfs (rw) [var]
/dev/sda7 on /home type xfs (rw,quota,usrquota) [home]
/dev/tmpMnt on /tmp type ext2 (rw,noexec,nosuid,loop=/dev/loop0)
Aber wenn ich dann in meinem Webmin gehe kann ich da nix auf enable stellen, also funzt das auch nicht.

Im Webmin steht:

- Type: SGI Filesystem
- Status: User Quotas Active
- Action: Can only enable at mount

Bei der / Partition is ein link da zum aktivieren oder deaktivieren, aber nicht bei der Home Partition :(

Ein: repquota /dev/sda7 ergibt folgendes:

Code: Select all


*** Report for user quotas on device /dev/sda7
Block grace time: 7days; Inode grace time: 7days
                        Block limits                File limits
User            used    soft    hard  grace    used  soft  hard  grace
----------------------------------------------------------------------
root      -- 21265708       0       0            457     0     0
wwwrun    --       8       0       0              2     0     0
mysql     --   37324       0       0           1589     0     0
web0      --       8       0       0              9     0     0
web1      -- 9886388       0       0          51217     0     0
web2      --   77596       0       0          10298     0     0
Kann ich nu quota nutzen oder nicht is die frage, weil wie gesagt im Webmin lassen sich die User nicht bearbeiten aufgrund weil ich das dort nicht auf enable stellen kann. :(



edit: Nach einem komplett reboot nimmt er es nun auch im Webmin an, was ich sehr komisch finde *staun* Es ist zwar nicht der link enable da, aber direkt auf /home und userwählen und limits setzen funzt nu.
Last edited by blnsnoopy26 on 2005-09-25 16:41, edited 1 time in total.

alexander newald
Posts: 1117
Joined: 2002-09-27 00:54
Location: Hannover

Re: Quota Problem ohne ende :(

Post by alexander newald »

In der Shell:

edquota /dev/sda7 web0

und dann

repquota /dev/sda7

Roger Wilco
Administrator
Administrator
Posts: 5923
Joined: 2004-05-23 12:53

Re: Quota Problem ohne ende :(

Post by Roger Wilco »

Vielleicht kann Webmin einfach nicht mit XFS umgehen?

blnsnoopy26
Posts: 660
Joined: 2002-10-19 14:01

Re: Quota Problem ohne ende :(

Post by blnsnoopy26 »

Hi,

Noch eine Kurze frage und zwar:

Code: Select all

web1      -- 9886388       0       0          51217     0     0
wird da in Kilobyte oder byte gerechnet oder gar in Megabyte?
Weil wollte das mal wissen, wenn ich einem User quota zuteile, damit ich dann die richtige zahl eintrage.

Wenn das in MB dargestellt wird müsste dies 9,886,388 MB sein also knapp 9,9 GB. Liege ich da mit meiner Vermutung richtig?

blnsnoopy26
Posts: 660
Joined: 2002-10-19 14:01

Re: Quota Problem ohne ende :(

Post by blnsnoopy26 »

Roger Wilco wrote:Vielleicht kann Webmin einfach nicht mit XFS umgehen?
Hab mein anderen Thread editiert:
edit: Nach einem komplett reboot nimmt er es nun auch im Webmin an, was ich sehr komisch finde *staun* Es ist zwar nicht der link enable da, aber direkt auf /home und userwählen und limits setzen funzt nu.