Mysql 4.1: Kollation richtig konfigurieren?

MySQL, PostgreSQL, SQLite
phpcoder
Posts: 5
Joined: 2005-09-01 22:18

Mysql 4.1: Kollation richtig konfigurieren?

Post by phpcoder » 2005-09-12 20:34

Hallo Leute,

Habe mir eine frische MySQL von der Suse 9.3 installiert, Version 4.1.10a.

Wollte anschließend meine Dumps einspielen, und sah dann, das teilweise die Umlaute nicht mehr richtig dargestellt werden. Habe mich schlau gemacht und weiß jetzt das es an den Standarteinstellungen von MySQL liegt und das als Standart latin1_swedish_ci als Kollation eingestellt ist.

Habe auch hier im Forum bei der Suche nach einer Lösung gelesen das es dadurch probleme mit Mysqldumb geben kann.

Habe schon versucht mysql mit so zustarten:
rcmysql start --default-collation=latin1_german1_ci
Das brachte mal nix. Wahrscheinlich muss das in die my.cnf rein.

Kann mir jemand sagen was ich genau zu tun habe? Möchte nicht
unbedingt mysql selbst mit einem angepassten ./configure nochmal kompilieren müssen.

Bin für jeden Tipp dankbar.

Gruß

Daniel
:)

phpcoder
Posts: 5
Joined: 2005-09-01 22:18

Re: Mysql 4.1: Kollation richtig konfigurieren?

Post by phpcoder » 2005-09-12 21:16

Hi,

hab nun die Lösung gefunden, denke ich:

my.cnf
[client]
default-character-set=latin1

[mysqld]
default-character-set=latin1
collation-server=latin1_german1_ci

[mysql]
default-character-set=latin1
Edit: Habe bei mir den Eintrag in mysqld auf latin1_german2_ci umgestellt. Jetzt kann ich in phpMyAdmin auch nach Umlauten suchen ...

Die Ã?nderung wirkt sich aber nicht auf schon bestehende DB's aus.

Die Daten müssen komplett neu importiert werden.

Gruß