[sendmail] php mail() sendet keine mails

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
eisi
Posts: 65
Joined: 2002-10-05 16:07

[sendmail] php mail() sendet keine mails

Post by eisi » 2005-09-06 19:59

hallo leute! ich habe folgendes problem, ich kann via mail() keine eMails mehr versenden und ich kann den fehler nicht finden.

es handelt sich um ein redhat 9er system mit sendmail.

ich versuchte folgendes:

Code: Select all

mail -vs 'test' j.huppertz@web.de
test
.
als antwort bekam ich folgendes:

Code: Select all

Cc:
j.huppertz@web.de... Connecting to [127.0.0.1] via relay...
220 km10107.keymachine.de ESMTP Sendmail 8.12.11/8.12.10; Tue, 6 Sep 2005 19:58:00 +0200
>>> EHLO km10107.keymachine.de
250-km10107.keymachine.de Hello localhost [127.0.0.1], pleased to meet you
250-ENHANCEDSTATUSCODES
250-PIPELINING
250-8BITMIME
250-SIZE
250-DSN
250-ETRN
250-AUTH GSSAPI LOGIN PLAIN
250-DELIVERBY
250 HELP
>>> MAIL From:<root@km10107.keymachine.de> SIZE=42 AUTH=root@km10107.keymachine.de
553 5.3.0 <root@km10107.keymachine.de>... No such user here
root... Using cached ESMTP connection to [127.0.0.1] via relay...
>>> RSET
250 2.0.0 Reset state
>>> MAIL From:<> SIZE=1066
250 2.1.0 <>... Sender ok
>>> RCPT To:<root@km10107.keymachine.de>
>>> DATA
553 5.3.0 <root@km10107.keymachine.de>... No such user here
503 5.0.0 Need RCPT (recipient)
>>> RSET
250 2.0.0 Reset state
>>> RSET
250 2.0.0 Reset state
postmaster... Using cached ESMTP connection to [127.0.0.1] via relay...
>>> MAIL From:<> SIZE=2090
250 2.1.0 <>... Sender ok
>>> RCPT To:<postmaster@km10107.keymachine.de>
>>> DATA
553 5.3.0 <postmaster@km10107.keymachine.de>... No such user here
503 5.0.0 Need RCPT (recipient)
>>> RSET
250 2.0.0 Reset state
Closing connection to [127.0.0.1]
>>> QUIT
221 2.0.0 km10107.keymachine.de closing connection
kann damit leider nicht sehr viel anfangen.

hoffe ihr könnt mir da weiterhelfen!

vielen dank schon einmal!

gruß,
eiSi

debianjunge
Posts: 9
Joined: 2005-07-18 21:47

Re: [sendmail] php mail() sendet keine mails

Post by debianjunge » 2005-09-07 10:29

schuss in's blaue:

web.de macht einen sender-verify. wenn du web.de deine email annimmt, prüft der server ob der dortz übermittelte absender (hier wohl <i>root@km10107.keymachine.de</i>) auch eine antwort erhalten kann. sagt dein mailserver: <i>root@km10107.keymachine.de ? kenn ich nicht!</i> wird web.de diese EMail nicht annehmen.

probier's mal so:

mail -s "testmail" deine.adresse@web.de -fechter.absender@deine.domain

damit sollte es klappen.

cheers,
rene

eisi
Posts: 65
Joined: 2002-10-05 16:07

Re: [sendmail] php mail() sendet keine mails

Post by eisi » 2005-09-07 20:07

hm das klappt leider irgendwie nicht.. es klappt auch mit keiner anderen eMail adr. und vor wenigen wochen ging noch alles.. ich setze mich gerade mit dem support auseinander und hoffe dass die mir da weiterhelfen kennen.

edit: habs hinbekommen, postfix installiert und alles richtig konfiguriert. nun gehts :)