php4.4.0 + mysql + phpMyAdmin = segmentation fault

Bash, Shell, PHP, Python, Perl, CGI
as-n
Posts: 196
Joined: 2002-12-19 17:42

php4.4.0 + mysql + phpMyAdmin = segmentation fault

Post by as-n »

Hallo,

habe heute php 4.4.0 installiert:

Code: Select all

./configure 
--prefix=/usr/share 
--datadir=/usr/share/php 
--bindir=/usr/bin 
--libdir=/usr/share 
--includedir=/usr/include 
--sysconfdir=/etc 
--with-_lib=lib 
--with-config-file-path=/etc 
--with-exec-dir=/usr/lib/php/bin 
--disable-debug 
--enable-bcmath 
--enable-calendar 
--enable-ctype 
--enable-dbase 
--enable-discard-path 
--enable-exif 
--enable-filepro 
--enable-force-cgi-redirect 
--enable-ftp 
--enable-gd-imgstrttf 
--enable-gd-native-ttf 
--enable-inline-optimization 
--enable-magic-quotes 
--enable-mbstr-enc-trans 
--enable-mbstring 
--enable-mbregex 
--enable-memory-limit 
--enable-safe-mode 
--enable-shmop 
--enable-sigchild 
--enable-sysvsem 
--enable-sysvshm 
--enable-track-vars 
--enable-trans-sid 
--enable-versioning 
--enable-wddx 
--enable-yp 
--with-bz2 
--with-dom=/usr/include/libxml2 
--with-ftp 
--with-gdbm 
--with-gettext 
--with-gmp 
--with-imap=yes 
--with-iodbc 
--with-jpeg-dir=/usr 
--with-ldap=yes 
--with-mcal=/usr 
--with-mpost 
--with-mhash 
--with-mysql=/usr 
--with-ndbm 
--with-png-dir=/usr 
--with-readline 
--with-snmp 
--with-t1lib 
--with-tiff-dir=/usr 
--with-ttf 
--with-freetype-dir=yes 
--with-xml 
--with-xpm-dir=/usr/X11R6 
--with-zlib=yes 
--with-gd 
--with-openssl 
--with-curl 
--with-imap-ssl 
--with-iconv 
--with-apxs2=/usr/sbin/apxs2-prefork 
i586-suse-linux
Lief alles wunderbar durch, leider bekomme ich, wenn ich nun im phpMyAdmin eine Tabelle auswähle und dann auf Inhalt anzeigen gehe, einen segmentation fault des Apachen2.

Auf einer zweiten Kiste läuft das aber, der Unterschied der beiden Rechner liegt bei mysql.
Auf dem betroffenen Server ist mysql 4.1.14 drauf und das hat immer noch eine ungelöste Abhängigkeit, es wird procps benötigt, was es aber für SuSE9.0 als rpm nicht gibt.

Auf dem Rechner wo alles läuft ist eine ältere mysql Version drauf, die eben procps nicht braucht.

Mit den original php rpm von SuSE läuft alles.

Liegt das jetzt an mysql an php oder an beidem?

Ich werde das jetzt mal nach und nach testen.

Ciao
AS-N
as-n
Posts: 196
Joined: 2002-12-19 17:42

Re: php4.4.0 + mysql + phpMyAdmin = segmentation fault

Post by as-n »

Kann mysql ausschließen, daran liegt es nicht, muss also irgendwie an der php Installation liegen.

Ciao
AS-N
as-n
Posts: 196
Joined: 2002-12-19 17:42

Re: php4.4.0 + mysql + phpMyAdmin = segmentation fault

Post by as-n »

Hat keiner irgend einen Anhaltspunkt?
Habe nochmal php in der neusten Version vom CVS Server kompiliert, gleiches Ergenis :-(

Ciao
AS-N