Delivered-To Problem

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
dfusion
Posts: 31
Joined: 2003-09-01 12:25

Delivered-To Problem

Post by dfusion » 2005-09-05 15:41

Hallo zusammen,

habe über das WE unseren Server mit Suse9.1, PLESK 7.5.3 initialisiern lassen.

Nach der Einrichtung der Benutzer und Domain läuft jetzt soweit alles in Ordnung. Von einem Nutzer habe ich jetzt jedoch die Rückmeldung bekommen, dass der Mailtransport im Gegensatz zu füher anders verläuft.
Nach Analyse des Headers habe ich nun das Problem gefunden, dass zugestellte mails an z.B die.mail@adresse.tld in der Delivered-To Zeile einen Zusatzvermerk bekommen:

Delivered-To: 5-die.mail@adresse.tld

Habe nach Prüfung anderer Server das gleiche Phänomen gefunden und kann es auch direkt im qmail Mailordner nachvollziehen.

Woher kommt dieser Zusatz, wofür ist er zuständig und vor allem, kann man das abstellen?


Nachtrag:

Die vorangestellten Ziffern bleiben innerhalb eines Postfach konstant. Andere Postfächer haben andere Ziffern.

Alle Alias die ich auf das Postfach lege, bekommen diese Ziffer ebenfalls vorangestellt

Im To: Feld steht die Adresse ohne vorangestellte Ziffer.

dfusion
Posts: 31
Joined: 2003-09-01 12:25

Re: Delivered-To Problem

Post by dfusion » 2005-09-06 10:13

Könnte das eine Kennzeichnung für die einzelnen Postfächer sein? Ich finde dazu leider keine Informationen...

dfusion
Posts: 31
Joined: 2003-09-01 12:25

qmail config

Post by dfusion » 2005-09-07 13:43

Hallo zusammen,

habe mich mal per Suchmaschine auf den langen Weg gemacht und ein paar Seiten über qmail gefunden.
Ich habe nun schon mal die Liste gefunden, aus der diese Zusatznummern gezogen werden.

/var/qmail/control/virtualdomains

Dies ist eine Liste mit allen Domains meines Servers. Die Domains werden darin wie folgt gelistet:

Code: Select all

adresse.tld:2
nocheineadresse.tdl:1
Die Zuordnung der Nummern zu den Domains resultiert daraus, in welcher Reihenfolge diese eingerichtet wurden.

Diese, in der virtualdomains, stehende Ziffer hinter de Domain, wird in jeder Mail, die an unseren Mailserver gesendet wird, vor die Adresse im Delivered-To: Feld gesetzt.

Kann man das irgendwie deaktivieren?

kenzo
RSAC
Posts: 530
Joined: 2003-07-15 20:30

Re: Delivered-To Problem

Post by kenzo » 2005-09-07 15:14

Kann man das irgendwie deaktivieren?
Frag den Plesk-Support - ansonsten halt einfach die betreffende Ziffer aus der virtualdomains entfernen. Möglicherweise haben sich die Pleskler aber etwas dabei gedacht?!

dfusion
Posts: 31
Joined: 2003-09-01 12:25

Re: Delivered-To Problem

Post by dfusion » 2005-09-07 15:29

kenzo wrote:
Kann man das irgendwie deaktivieren?
Frag den Plesk-Support - ansonsten halt einfach die betreffende Ziffer aus der virtualdomains entfernen. Möglicherweise haben sich die Pleskler aber etwas dabei gedacht?!
Hab ich entfernt, dann ist das Mailing nicht mehr möglich...
PLESK Support... :roll:

kawfy
Posts: 307
Joined: 2002-08-08 23:45

Plesk/Qmail Delivered-To header

Post by kawfy » 2005-09-23 02:01

:?: Ja, was ist denn mit dem Plesk-Support? Falls du keinen direkten Support-Vertrag mit SWsoft hast, tüte dein Anliegen bei deinem Provider ein.

:!: Lt. diesem Thread im SWsoft-Forum scheint es Differenzen zw. Bernstein und SWsoft wg. der Qmail-Lizenz zu geben. Das macht das Ganze nicht einfacher.

dfusion
Posts: 31
Joined: 2003-09-01 12:25

Re: Plesk/Qmail Delivered-To header

Post by dfusion » 2005-09-26 13:23

kawfy wrote::?: Ja, was ist denn mit dem Plesk-Support? Falls du keinen direkten Support-Vertrag mit SWsoft hast, tüte dein Anliegen bei deinem Provider ein.

:!: Lt. diesem Thread im SWsoft-Forum scheint es Differenzen zw. Bernstein und SWsoft wg. der Qmail-Lizenz zu geben. Das macht das Ganze nicht einfacher.
Was mit dem PLESK Support ist? Na erstens haben die ein Antwort-Delay welches sich gewaschen hat, zweitens schieben die das Problem wieder zu J. Bernstein rüber... da hab ich mal keinen Bock drauf, hab mir einen anderen Lösungsweg ohne PLESK und Qmail gesucht.

Ich warte doch nicht bis sich irgend jemand mal erbarmt hat mir mitzuteilen, dass die Nummerierung vor der Mail einfach mit den Virtual-Domains zu tun hat. Leider nicht zu umgehen...
Ich finde es recht lächerlich wenn weder PLESK, noch qmail, noch mein Hoster (1&1) in ihrer "Supportdatenbank" einen entsprechenden Eintrag zu diesem Problem verzeichen können. Sry, da komme ich mir schon mächtig verschaukelt vor, besonders wenn ich nach stundenlanger Suche im PLESK-Forum die benötigten Informationen dazu finde. Bevor ich eine Rückmeldung von einer der dreien bekommen habe...

Betr. der Differenzen... danke für die Info, jetzt wird mir einiges klar... :roll: