Einige Domains bekommen keine Mails

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
bambam
Posts: 8
Joined: 2005-09-03 19:58

Einige Domains bekommen keine Mails

Post by bambam » 2005-09-03 20:09

Hallo alle zusammen,

ich habe folgendes Problem, (suse 9, confixx v3, postfix)

ich bekomme alle mails... für ein nutzer konto, aber wenn
ich das andere "web" abrufe kommen keinerlei mails an,
dann manchmal nach 1-2 Tagen kommen alle Mails auf einmal
an, das ist aber nur bei 2 "Webs" der Fall.

Die Boardsuche habe ich bereits genutzt aber irgendwie immer
nur ähnliche Probleme gefunden und nichts gleiches.

Falls ich irgendwas übersehen habe tut es mir ehrlich leid!
Vielleicht hat ja jemand einen Tipp... Webserver, Mailserver
wurden beide bereits mehrfach neugestartet, confixx gibt
keine Fehlermeldungen an.

Freue mich über jeden auch noch so kleinsten Tipp!

wgot
RSAC
Posts: 1707
Joined: 2003-07-06 02:03

Re: Einige Domains bekommen keine Mails

Post by wgot » 2005-09-03 20:38

Hallo,
bambam wrote:ich bekomme alle mails... für ein nutzer konto,
aber wenn ich das andere "web" abrufe kommen keinerlei mails an,
dann manchmal nach 1-2 Tagen kommen alle Mails auf einmal
an, das ist aber nur bei 2 "Webs" der Fall.
gibt es auch Zusammenhänge mit den Domains, z.B. Mails an eine Domain problemlos an eine andere klemmt's o.ä.?

Schau über SSH in die Postfächer, kommen die Mails dort nicht an oder liegen sie im Postfach und können nicht abgeholt werden?
Und natürlich Logfiles lesen.

Gruß, Wolfgang

bambam
Posts: 8
Joined: 2005-09-03 19:58

Jetzt aber

Post by bambam » 2005-09-03 21:02

Hi, sorry habe gerade versehentlich einen neuen thread geöffnet...

erstmal danke für die Antwort.
Die Mails kommen nicht mal im Postfach an.

Log files hab ich total vergessen (doh')
werde gleich mal schauen ob da etwas drin ist.



Hi,

im mail.err log (/var/log/mail.err) ist nix aktuelles drin.
Was ich so absolut nicht verstehe ist das ich alles bekomme an mails und der andere user nur sachen die von der gleichen Mc gesendet werden- also nix was von draußen kommt?!

bambam
Posts: 8
Joined: 2005-09-03 19:58

Fehler vielleicht gefunden??

Post by bambam » 2005-09-03 21:13

im mail.warn ist folgendes drinnen

Sep 3 19:38:09 server name postfix/local[10919]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
Sep 3 19:41:22 server name postfix/smtpd[11198]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
Sep 3 19:41:28 server name postfix/smtpd[11198]: warning: the "check_relay_domains" restriction is going away; use "reject_unauth_destination" instead
Sep 3 19:54:48 server name postfix/smtp[11408]: warning: no MX host for fgh.com has a valid A record
Sep 3 19:54:48 server name postfix/smtp[11418]: warning: no MX host for vardhman.net has a valid A record
Sep 3 19:54:49 server name postfix/smtp[11417]: warning: no MX host for nsimail.com has a valid A record
Sep 3 19:58:13 server name postfix/smtpd[11469]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
Sep 3 19:58:13 server name postfix/smtpd[11469]: warning: the "check_relay_domains" restriction is going away; use "reject_unauth_destination" instead
Sep 3 20:05:54 server name postfix/smtpd[11584]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
Sep 3 20:05:59 server name postfix/smtpd[11584]: warning: the "check_relay_domains" restriction is going away; use "reject_unauth_destination" instead
Sep 3 20:11:28 server name postfix/smtp[11705]: warning: no MX host for fesi.com has a valid A record
Sep 3 20:11:33 server name postfix/smtp[11702]: warning: valid_hostname: empty hostname
Sep 3 20:11:33 server name postfix/smtp[11702]: warning: malformed domain name in resource data of MX record for hotmil.com:
Sep 3 20:26:00 server name postfix/local[11881]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
Sep 3 20:28:08 server name postfix/smtp[11910]: warning: no MX host for mediaone.net has a valid A record
Sep 3 20:38:31 server name postfix/smtpd[12070]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
Sep 3 20:38:31 server name postfix/smtpd[12070]: warning: the "check_relay_domains" restriction is going away; use "reject_unauth_destination" instead
Sep 3 20:44:49 server name postfix/smtp[12165]: warning: no MX host for eunet.com has a valid A record
Sep 3 20:45:09 server name postfix/smtpd[12205]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
Sep 3 20:45:10 server name postfix/smtpd[12205]: warning: the "check_relay_domains" restriction is going away; use "reject_unauth_destination" instead
Sep 3 20:59:30 server name postfix/smtpd[12452]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
Sep 3 20:59:31 server name postfix/smtpd[12452]: warning: the "check_relay_domains" restriction is going away; use "reject_unauth_destination" instead
Sep 3 21:01:29 server name postfix/smtp[12526]: warning: no MX host for vardhman.net has a valid A record
Sep 3 21:01:29 server name postfix/smtp[12515]: warning: no MX host for fgh.com has a valid A record
Sep 3 21:01:29 server name postfix/smtp[12524]: warning: no MX host for nsimail.com has a valid A record

wie gehe ich nun am besten vor, ich nehme an das es hierbei um ein offenes relay geht- richtig? Kann so etwas der Grund für das eigentliche Problem sein?

wgot
RSAC
Posts: 1707
Joined: 2003-07-06 02:03

Re: Jetzt aber

Post by wgot » 2005-09-03 23:02

Hallo,
bambam wrote: Die Mails kommen nicht mal im Postfach an.
dann sollte der Absender eine Fehlermeldung erhalten, welche?
Log files hab ich total vergessen
alle Mail-Logs lesen, nicht nur mail.err und mail.warn.
Was ich so absolut nicht verstehe ist das ich alles bekomme an mails und der andere user nur sachen die von der gleichen Mc gesendet werden- also nix was von draußen kommt?!
Was unterscheidet die beiden User außer dem Postfach? Vermutlich die Domain. Seit wann ist die problematische Domain auf den Server geschaltet? Nameservereinträge korrekt?
ich nehme an das es hierbei um ein offenes relay geht
Prüfen! http://www.abuse.net/relay.html

Konfiguration (main.cf) posten, komplett und unverändert, aber ohne Kommentare, oder - besser - auf deinem Server zum Angucken bereitstellen und Link in's Forum,. dann können auch die Kommentare drinbleiben.

Gruß, Wolfgang

bambam
Posts: 8
Joined: 2005-09-03 19:58

RE

Post by bambam » 2005-09-03 23:34

Die Absender bekommen keinerlei Fehlermeldungen.
Ja es handelt sich um eine andere Domain, die Domain
ist seit einigen Monaten geschaltet, bisher ohne Probleme.

Relay test war ok.
Nameserver sind ok.

bambam
Posts: 8
Joined: 2005-09-03 19:58

RE

Post by bambam » 2005-09-04 00:15

jetzt werden die mails an die domain ausgeliefert, nach und nach...
ist es möglich das der mailserver irgendwie überlastet ist oder Probleme hat? Müsste das nicht in den Logs auftauchen?

Was ich wie gesagt nicht verstehe ist das es insgesamt nur 2 domains betrifft... von vielleicht insgesamt 20 oder 25 Domains.

timeless2
Posts: 416
Joined: 2005-03-04 14:45
Location: Paris

Re: Einige Domains bekommen keine Mails

Post by timeless2 » 2005-09-04 13:50

da hast du deinen DNS-Server nicht richtig installiert: "warning: no MX host for fgh.com has a valid A record".

bambam
Posts: 8
Joined: 2005-09-03 19:58

RE:

Post by bambam » 2005-09-04 14:05

diese Domain ist aber nicht von mir?! Deswegen dachte ich ja das irgendwo etwas offen ist... aber firewall und relays sind ok?!?

timeless2
Posts: 416
Joined: 2005-03-04 14:45
Location: Paris

Re: Einige Domains bekommen keine Mails

Post by timeless2 » 2005-09-04 14:24

Je nachdem, wo der DNS-Server läuft, musst du die Einstellungen vornehmen.
z.B. bei fgh.com ergibt host -t mx fgh.com

Code: Select all

fgh.com mail is handled by 10 dev.null.
Wie soll Postfix da E-Mails verschicken können, wenn es nicht mal einen Mailserver gibt?
Wenn der Nameserver nicht bei dir läuft, musst du das halt über das Konfigurations-Menü deines Anbieters richtig einstellen.

bambam
Posts: 8
Joined: 2005-09-03 19:58

RE:

Post by bambam » 2005-09-04 14:53

Wieso? fgh.com hat doch nichts mit mir zu tun? ist nicht meine domain!

bambam
Posts: 8
Joined: 2005-09-03 19:58

RE:

Post by bambam » 2005-09-04 14:58

Also, es sind bei einer Domain heute 22 mails auf einmal angekommen, zum teil waren diese aber schon 1-3 Tage alt.

Gut ist das die mails nicht verloren gegangen sind, gab ja auch keine Fehlermeldung wenn man an die Domain mailte.

Blöd ist nur das damit das Problem in keinster Weise gelöst ist.
Die Logs gaben keinerlei Aufschluss, die Nameserver sind ok, alle anderen Domains haben diese Probleme nicht.

Ist vielleicht Unsinn aber kann es sein das Confixx irgendein Problem macht? Vielleicht hilft es ja wenn man das betroffene "web"
einfach löscht und nochmals einrichtet?!?!?!

Gut, ich danke erstmal allen die sich mit meinem Problem befasst haben! Vielen Dank!

Vielleicht fällt ja irgendjemandem noch etwas ein, bin für jeden Tipp dankbar.