Ich kann keine Mails von O2online auf meinen Root-Server schicken

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
ck001
Posts: 5
Joined: 2003-09-08 15:45
Location: Tambach-Dietharz

Ich kann keine Mails von O2online auf meinen Root-Server schicken

Post by ck001 » 2005-08-25 13:32

Hallo,

seit einiger Zeit kämpfe ich mit folgendem Problem:

ich versuche von einer E-Mail-Adresse bei O2Online eine E-Mail an eine Adresse auf meinem Root-Server (Strato) zu schicken.

Jedesmal kommt die E-mail mit folgender Fehlermeldung zurück:

Failed; 5.4.0 (other or undefined network or routing status)

Das gleiche passiert auch, wenn ein Kumpel von mir versucht mir mit seinem O2online-Account eine Mail zu schicken.

Eine Anfrage bei O2 ergibt jedesmal das ich meinen Server falsch konfiguriert hätte.

Alle anderen E-Mails kommen jedoch problemlos bei mir an, die Antwort von der O2-Hotline kommt ebenfalls problemlos auf der gleichen Mail-Adresse an.
Jetzt weiß ich eigentlich nicht, was ich bei mir falsch gemacht haben könnte. Meiner Meinung nach hat das Mail-System von O2 ein Problem mit der IP von meinem Server.

Nachfolgend noch eine Kopie der erhaltenen Fehler-Mail:
Return-Path: <>
Original-Recipient: rfc822;carsten.koeppchen@o2online.de
Received: by mail.o2.co.uk (7.0.045) id 42A278A5008AA619 for carsten.koeppchen@o2online.de; Wed, 24 Aug 2005 16:06:55 +0100
From: Mail Delivery Service <postmaster@mail.o2.co.uk>
Subject: Delivery Status Notification
To: carsten.koeppchen@o2online.de
Date: Wed, 24 Aug 2005 16:06:55 +0100
X-CP-Transaction-ID: 42A278A5008AA616
X-CP-For: carsten@koeppchen.de
Message-ID: <42A278A5008AA617@holly.london.ongenie.net>
MIME-Version: 1.0
Content-Type: Multipart/Report; report-type=delivery-status; boundary="========/42A278A5008AA616/mail.o2.co.uk"

This multi-part MIME message contains a Delivery Status Notification.
If you can see this text, your mail client may not be able to understand MIME
formatted messages or DSNs (see RFC 2045 through 2049 for general MIME
information and RFC 1891 through 1894 for DSN specific information).

--========/42A278A5008AA616/mail.o2.co.uk
Content-Type: text/plain; charset=US-ASCII
Content-Transfer-Encoding: 8bit

- These recipients of your message have been processed by the mail server:
carsten@koeppchen.de; Failed; 5.4.0 (other or undefined network or routing status)



--========/42A278A5008AA616/mail.o2.co.uk
Content-Type: Message/Delivery-Status

Reporting-MTA: dns; mail.o2.co.uk
Received-from-MTA: dns; NotebookCK (217.185.136.78)
Arrival-Date: Wed, 24 Aug 2005 16:06:55 +0100

Final-Recipient: rfc822; carsten@koeppchen.de
Action: Failed
Status: 5.4.0 (other or undefined network or routing status)

--========/42A278A5008AA616/mail.o2.co.uk
Content-Type: Message/RFC822

Return-Path: <carsten.koeppchen@o2online.de>
Received: from NotebookCK (217.185.136.78) by mail.o2.co.uk (7.0.045)
id 42A278A5008AA616 for carsten@koeppchen.de; Wed, 24 Aug 2005 16:06:55 +0100
Message-ID: <002401c5a8be$01acc680$fe79a8c0@NotebookCK>
From: =?iso-8859-1?Q?Carsten_K=F6ppchen?= <carsten.koeppchen@o2online.de>
To: =?iso-8859-1?Q?Carsten_K=F6ppchen?= <carsten@koeppchen.de>
Subject: Test 3
Date: Wed, 24 Aug 2005 17:10:44 +0200
MIME-Version: 1.0
Content-Type: multipart/alternative;
boundary="----=_NextPart_000_0021_01C5A8CE.C3511F10"
X-Priority: 3
X-MSMail-Priority: Normal
X-Mailer: Microsoft Outlook Express 6.00.2900.2527
x-mimeole: Produced By Microsoft MimeOLE V6.00.2900.2527

This is a multi-part message in MIME format.

------=_NextPart_000_0021_01C5A8CE.C3511F10
Content-Type: text/plain;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

hghgkhg
------=_NextPart_000_0021_01C5A8CE.C3511F10
Content-Type: text/html;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=3DContent-Type content=3D"text/html; =
charset=3Diso-8859-1">
<META content=3D"MSHTML 6.00.2900.2722" name=3DGENERATOR>
<STYLE></STYLE>
</HEAD>
<BODY bgColor=3D#ffffff>
<DIV><FONT face=3DArial size=3D2>hghgkhg</FONT></DIV></BODY></HTML>

------=_NextPart_000_0021_01C5A8CE.C3511F10--


--========/42A278A5008AA616/mail.o2.co.uk--
Wer weiß, woran das liegen kann ?

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: Ich kann keine Mails von O2online auf meinen Root-Server schicken

Post by dodolin » 2005-08-25 15:01

Wer weiß, woran das liegen kann ?
Das Logfile des MTAs von koeppchen.de, du Nase! ;)

Tipp, damit du es schneller findest: Schau auf die Uhrzeit und suche diese in deinem Log. Alternativ suche nach "o2", o.ae.

herrchen
Posts: 19
Joined: 2005-08-23 12:50
Location: Berlin

Re: Ich kann keine Mails von O2online auf meinen Root-Server schicken

Post by herrchen » 2005-08-25 16:13

versuch' doch mal deinen hostnamen im MTA auf
"mail.koeppchen.de" zu setzen.

herrchen

ck001
Posts: 5
Joined: 2003-09-08 15:45
Location: Tambach-Dietharz

Re: Ich kann keine Mails von O2online auf meinen Root-Server schicken

Post by ck001 » 2005-08-25 17:23

dodolin
Das Logfile des MTAs von koeppchen.de, du Nase!
In den Logfiles habe ich schon nachgeschaut, da taucht nicht einmal ein Versuch einer Mail-Zustellung auf. Deshalb ja von mir die Vermutung, das diese Mails gar nicht bis zu meinem Server kommen !

herrchen
versuch' doch mal deinen hostnamen im MTA auf
"mail.koeppchen.de" zu setzen.
Da ich meine Mail-Accounts mit Visas verwalte wüßte ich jetzt nicht gleich, wie ich das anstellen soll ?
die Domain koeppchen.de ist nicht die Hauptdomain von meinem Server.

Danke Euch beiden für die schnellen Antworten !

Carsten Köppchen

herrchen
Posts: 19
Joined: 2005-08-23 12:50
Location: Berlin

Re: Ich kann keine Mails von O2online auf meinen Root-Server schicken

Post by herrchen » 2005-08-25 17:45

ck001 wrote:herrchen
versuch' doch mal deinen hostnamen im MTA auf
"mail.koeppchen.de" zu setzen.
Da ich meine Mail-Accounts mit Visas verwalte wüßte ich jetzt nicht gleich, wie ich das anstellen soll ?
die Domain koeppchen.de ist nicht die Hauptdomain von meinem Server.
Visas kenne ich nicht.
mir ist aber aufgefallen, dass dein MTA sich mit "...serverkompetenz.net" meldet. vielleicht stolpert O2 darüber.
du hast doch bestimmt einen "ssh" zugang. einfach mal nachsehen, ob du damit weiterkommst. bei Postfix wäre z.b. in /etc/postfix/main.cf
"myhostname = mail.koeppchen.de" zu setzen.

herrchen

ck001
Posts: 5
Joined: 2003-09-08 15:45
Location: Tambach-Dietharz

Re: Ich kann keine Mails von O2online auf meinen Root-Server schicken

Post by ck001 » 2005-08-25 18:03

herrchen wrote: Visas kenne ich nicht.
mir ist aber aufgefallen, dass dein MTA sich mit "...serverkompetenz.net" meldet. vielleicht stolpert O2 darüber.
du hast doch bestimmt einen "ssh" zugang. einfach mal nachsehen, ob du damit weiterkommst. bei Postfix wäre z.b. in /etc/postfix/main.cf
"myhostname = mail.koeppchen.de" zu setzen.

herrchen
Bei mir läuft qmail.
Ich denka mal die von Dir vorgeschlagene Ã?nderung müßte ich in /etc/qmail/me vornehmen, bin damit jedoch nicht sehr glücklich, da ich mehrere Domains auf diesem Server hoste.

Ich werde jetzt mal versuchen in /etc/qmail/rcpthosts einen entsprechenden Eintrag zu machen. Melde mich dann noch einmal, so ca. in 1 Stunde.

Carsten Köppchen

ck001
Posts: 5
Joined: 2003-09-08 15:45
Location: Tambach-Dietharz

Re: Ich kann keine Mails von O2online auf meinen Root-Server schicken

Post by ck001 » 2005-08-25 19:08

Hallo herrchen

Dein Tip war vollkommen richtig !!

Ich habe einfach in /etc/qmail/rcpthosts einen zusätzlichen Eintrag mit mail.koeppchen.de gemacht und siehe da, die Mails kommen jetzt an.
Jetzt werde ich noch die anderen Hostnamen entsprechend bearbeiten.

Vielen Dank für die superschnelle Hilfe !

Carsten Köppchen

kenzo
RSAC
Posts: 530
Joined: 2003-07-15 20:30

Re: Ich kann keine Mails von O2online auf meinen Root-Server schicken

Post by kenzo » 2005-08-25 20:09

Ich habe einfach in /etc/qmail/rcpthosts einen zusätzlichen Eintrag mit mail.koeppchen.de gemacht und siehe da, die Mails kommen jetzt an.
Ich kann mir nicht so recht vorstellen, dass da das Problem gelegen hat - die rcpthosts sagt nur aus, für welche Domain dein qmail Mails annimmt; in diesem Fall wäre das dann z.B. carsten@mail.koeppchen.de. Das wiederum war nicht die Adresse, die letztlich gebounct hat. Wenn außerdem für den fraglichen Zeitraum
In den Logfiles habe ich schon nachgeschaut, da taucht nicht einmal ein Versuch einer Mail-Zustellung auf.
stimmt, dann kann das auch nicht das Problem gewesen sein.
Naja, Hauptsache, es geht jetzt.

ck001
Posts: 5
Joined: 2003-09-08 15:45
Location: Tambach-Dietharz

Re: Ich kann keine Mails von O2online auf meinen Root-Server schicken

Post by ck001 » 2005-08-25 23:06

Hallo kenzo

um das Ganze noch einmal auf Richtigkeit zu überprüfen habe ich die Gegenprobe gemacht, also die Ã?nderungen in /etc/qmail/rcpthosts rückgängig gemacht.
Und jetzt kommt es - Die Mails kommen immer noch an !!!
Was ist also los ?
Die endgültige Lösung ist relativ einfach: es lag an meinem Nameserver bzw. an den MX-Records in den zone-files. Die haben einfach gefehlt.
Gestern hatte ich probehalber die entsprechenden MX-Records nachgetragen. Wahrscheinlich haben dann heute Nachmittag die Nameserver der DENIC bzw. NIC ihre Aktualisierungen durchgeführt (jedenfalls kann ich in meinen Logdateien entsprechende Abfragen des Secondary-Nameserver nachvollziehen).
So haben sich einfach 2 Dinge zeitlich überschnitten, die Aktualisierung der Nameserver und meine Ã?nderungen an o.g. Datei.

Jetzt frage ich mich nur, warum die E-Mails von allen anderen Accounts bei mir angekommen sind, nur die über O2Online geschickten nicht ??

Jedenfalls erklären sich so auch die fehlenden Log-Einträge im MTA.

Allen also noch einmal herzlichen Dank für die Hilfe.

Carsten Köppchen