horde/vhost/login directory

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
umbroboy
Posts: 258
Joined: 2005-05-11 11:49

horde/vhost/login directory

Post by umbroboy » 2005-08-14 19:13

Hallo zusammen,

habe eine subdomain eingerichtet wie folgt:

Code: Select all

<VirtualHost 
                        XXX.XXX.XXX.XXX:80 
                        >
        DocumentRoot /home/httpd/vhosts/horde

        ServerName webmail
        ServerAlias webmail.*

        UseCanonicalName Off
        <Directory /home/httpd/vhosts/horde>
                <IfModule sapi_apache2.c>
                        php_admin_flag engine on
                        php_admin_flag magic_quotes_gpc off
                        php_admin_flag safe_mode off
                        php_admin_value open_basedir none
                        php_admin_value include_path "/home/httpd/vhosts/horde:/usr/local/psa/admin/plib:/usr/share/php:/usr/local/psa/admin/javascripts:/usr/local/psa/admin/plib/locales:/usr/local/psa/admin/auto_prepend:."
                </IfModule>

        </Directory>
</VirtualHost>
Nur das komische ist jetzt wenn ich :

webmail.subdomain.de eingebe

dass dann kommt objekt nicht gefunden.Der richtige pfad wie webmail.subdomain.de/horde/login.php steht allerdings da.

Gebe ich allerdings:

Code: Select all

webmail.subdomain.de/test.php öffnet er mir die datei.

Und wenn ich als directory und root nur :

Code: Select all

/home/httpd/vhosts/ 
und diesem befehl arbeite:

Code: Select all

Alias /home/httpd/vhosts /home/httpd/vhosts/horde/
komme ich in horde nicht rein.

:-(

KAnn mir jemand helfen?
Viele Grüße

mem
Posts: 45
Joined: 2003-12-22 11:09

Re: horde/vhost/login directory

Post by mem » 2005-08-15 10:30

Horde will in einem eigenen Unterverzeichnis namens "horde" liegen. Daher muss die Horde-Installation innerhalb des Verzeichnisses "/home/httpd/vhosts/horde/horde" liegen.

Der Redirect zum Login endet dann in http://webmail.example.com/horde/login.php was der Datei /home/httpd/vhosts/horde/horde/login.php entsprechen sollte.

umbroboy
Posts: 258
Joined: 2005-05-11 11:49

Re: horde/vhost/login directory

Post by umbroboy » 2005-08-15 23:36

Hallo mem,

also ich verzweifele jetzt regelrecht.


Habe jetzt das horde Verzeichnis unter:

Code: Select all

home/httpd/vhosts/horde/horde
Meine webmail.conf liegt derzeit in:

Code: Select all

/etc/apache2/conf.d/
Hier wird diese automatisch mitgeladen.

Dies ist wohl der einzigste weg bei PLESK für alle domains die gleiche subdomain festzulegen.


Nur leider kommt jetzt immer noch Zugriff verweigert.

Hier mal der Auszug aus der aktuellen conf. WEil bei der die ich gepostet habe kommt auch immer. Zugriff verweigert Error 403.
Wann muss ich eigentlich mit einem / enden?

Code: Select all

<VirtualHost 
                        XXX.XXX.XXX.XXX:80 
                        >
        DocumentRoot /home/httpd/vhosts/horde/
ScriptAlias /horde/ /home/httpd/vhosts/horde
        ServerName webmail
        ServerAlias webmail.*

        UseCanonicalName Off
        <Directory /home/httpd/vhosts/>
                <IfModule sapi_apache2.c>
                        php_admin_flag engine on
                        php_admin_flag magic_quotes_gpc off
                        php_admin_flag safe_mode off
                        php_admin_value open_basedir none
                        php_admin_value include_path "/home/httpd/vhosts/horde:/usr/local/psa/admin/plib:/usr/share/php:/usr/local/psa/admin/javascripts:/usr/local/psa/admin/plib/locales:/usr/local/psa/admin/auto_prepend:."
                </IfModule>

        </Directory>
</VirtualHost>
Viele Grüße und Danke

umbroboy
Posts: 258
Joined: 2005-05-11 11:49

Re: horde/vhost/login directory

Post by umbroboy » 2005-08-17 11:08

Hallo,

also ich hab mir jetzt eine eigene *.conf erstellt die ich über die httpd.include mit einbinde. Diese sieht wie folgt aus:

Code: Select all

<VirtualHost XXX.xxx.xxx.xxx:80>

DocumentRoot /home/httpd/vhosts/
Alias /horde/ /home/httpd/vhosts/horde/

ServerName webmailer
ServerAlias webmailer.*
UseCanonicalName Off
<Directory /home/httpd/vhosts/horde/horde>



<IfModule sapi_apache2.c>
php_admin_flag engine on
php_admin_flag magic_quotes_gpc off
php_admin_flag safe_mode off
php_admin_value open_basedir "/home/httpd/vhosts/horde:/tmp:/usr/share/php:/usr/local/psa/admin/plib:/usr/local/psa/admin/javascripts:/usr/local/psa/admin/plib/locales:/usr/local/psa/admin/auto_prepend:."
php_admin_value include_path "/home/httpd/vhosts/horde:/tmp:/usr/share/php:/usr/local/psa/admin/plib:/usr/local/psa/admin/javascripts:/usr/local/psa/admin/plib/locales:/usr/local/psa/admin/auto_prepend:."
</IfModule>
Options +Includes +ExecCGI FollowSymLinks

</Directory>
</VirtualHost>
Dies ging auch bis gestern noch.

Heute kommt allerdings wieder die Fehlermeldung 403.


Ebenso hab ich im Logfile diese Meldung drin:

[Wed Aug 17 10:56:45 2005] [error] [client 82.135.15.107] File does not exist: /home/httpd/vhosts/horde/horde/horde
[Wed Aug 17 11:00:34 2005] [error] [client 82.135.15.107] Directory index forbidden by rule: /home/httpd/vhosts/


das komische ist nu dass es gestern ging.

:-(

umbroboy
Posts: 258
Joined: 2005-05-11 11:49

Re: horde/vhost/login directory

Post by umbroboy » 2005-08-20 14:51

Halllo,

also hab jetzt folgenden Eintrag an die httpd.conf angehängt:

Code: Select all

<VirtualHost 
			XXX.XXX.XXX.XXX:80 
			>
	DocumentRoot /home/httpd/vhosts/horde/horde/

	Alias /horde/ /home/httpd/vhosts/horde/horde/
	Alias /imp/ /home/httpd/vhosts/horde/horde/imp/
	ServerName webmailer
	ServerAlias webmailer.*
	UseCanonicalName Off
	<Directory /home/httpd/vhosts/horde/horde/>
		<IfModule sapi_apache2.c>
			php_admin_flag engine on
			php_admin_flag magic_quotes_gpc off
			php_admin_flag safe_mode off
			php_admin_value open_basedir "/home/httpd/vhosts/horde/horde:/usr/share/php:/tmp:/var/log:/usr/share/doc:."
			php_admin_value include_path "/home/httpd/vhosts/horde/horde:/usr/share/php:."
		</IfModule>
allow from all 
Options +Indexes 
AddType application/x-httpd-php .php 
AddType application/x-httpd-php .php3 
AddType application/x-httpd-php .php4 
AddType application/x-httpd-php-source .phps 
DirectoryIndex index.php 
DirectoryIndex index.php3 
DirectoryIndex index.php4 
	</Directory>
</VirtualHost>
Gebe ich jetzt:

http://webmailer.XXX.de/test.php

ein, so sehe ich die Datei.

Gebe ich allerdings nur die Subdomain ein, versucht er die Seite aufzubauen und es steht dann da , Objekt nicht gefunden.

die URL im IE zeigt an:

webmailer.xxx.de/horde/login.php

Das komische was ich nicht vesteh ist, dass diese Konfiguration gestern noch ging. Danach habe ich den Server über PLESK neu gestartet und jetzt geht irgendwie nichts mehr :-(

Wer hat ne idee?

umbroboy
Posts: 258
Joined: 2005-05-11 11:49

Re: horde/vhost/login directory

Post by umbroboy » 2005-08-22 12:31

Hallo,

kann mir hier keiner helfen?

Viele Grüße und Danke