DRINGEND: Server fährt nicht mehr hoch nach xinitd absturz

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
merrow
Posts: 9
Joined: 2003-09-10 19:43

DRINGEND: Server fährt nicht mehr hoch nach xinitd absturz

Post by merrow » 2005-07-12 11:43

Hi,

der Server fährt nach Neustart nicht mehr hoch. Heute Nacht gab es ein paar Fehler in den Logs:

Code: Select all

Jul 12 00:15:12 p15137399 run-crons[6218]: logrotate returned 1
Jul 12 00:46:38 p15137399 xinetd[494]: pop3: fork failed: Cannot allocate memory (errno = 12)
Jul 12 00:46:38 p15137399 kernel: VM: killing process confixx_updates
Jul 12 00:46:38 p15137399 kernel: VM: killing process confixx_counter
Jul 12 00:46:38 p15137399 kernel: VM: killing process httpd
...
Jul 12 10:04:32 p15137399 xinetd[13274]: 13274 {general_handler} (13274) Unexpected signal: 11 (Segmentation fault)
Jul 12 10:04:32 p15137399 last message repeated 9 times
Jul 12 10:04:32 p15137399 xinetd[13274]: 13274 {bad_signal} Received 10 signals in 1 seconds. Exiting...
Jul 12 10:04:33 p15137399 xinetd[13275]: 13275 {general_handler} (13275) Unexpected signal: 11 (Segmentation fault)
Jul 12 10:04:33 p15137399 last message repeated 9 times
Jul 12 10:04:33 p15137399 xinetd[13275]: 13275 {bad_signal} Received 10 signals in 1 seconds. Exiting...
Jul 12 10:04:33 p15137399 xinetd[13276]: 13276 {general_handler} (13276) Unexpected signal: 11 (Segmentation fault)
Jul 12 10:04:33 p15137399 last message repeated 9 times
Jul 12 10:04:33 p15137399 xinetd[13276]: 13276 {bad_signal} Received 10 signals in 1 seconds. Exiting...
Jul 12 10:04:36 p15137399 xinetd[13277]: 13277 {general_handler} (13277) Unexpected signal: 11 (Segmentation fault)
Jul 12 10:04:36 p15137399 last message repeated 9 times
Jul 12 10:04:36 p15137399 xinetd[13277]: 13277 {bad_signal} Received 10 signals in 1 seconds. Exiting...
Jul 12 10:04:37 p15137399 xinetd[13278]: 13278 {general_handler} (13278) Unexpected signal: 11 (Segmentation fault)
Jul 12 10:04:37 p15137399 last message repeated 9 times
Jul 12 10:04:37 p15137399 xinetd[13278]: 13278 {bad_signal} Received 10 signals in 1 seconds. Exiting...
Die xinetd-fehler wurden erzeugt durch pop3 abrufe (die fehlgeschlagen sind), als ich dann versuchte den Server neu zu starten ist er nicht mehr hochgefahren. Im Rescue System fährt er hoch aber die "boot.msg" schreib er scheinbar nicht neu, weshalb ich davon ausgehe das der Server nicht einmal ins System kommt und keine Fehler der Netzwerkkarte vorliegt.

OS: Suse 8.1 Confixx 2.0

danke im voraus

alfmanuel
Posts: 59
Joined: 2004-04-04 13:12
Location: AT [salzburg]

Re: DRINGEND: Server fährt nicht mehr hoch nach xinitd absturz

Post by alfmanuel » 2005-07-12 12:31

Bei uns gab es einen ähnlichen Fehler, das System wurde da gehackt.
Und es wurden manche Systemdateien vom Hacker ausgetauscht und somit reagiert das System nciht mehr.

Ich würde xinetd komplett neu konfigurieren ?

bungeebug
Posts: 187
Joined: 2004-04-14 10:08

Re: DRINGEND: Server fährt nicht mehr hoch nach xinitd absturz

Post by bungeebug » 2005-07-12 13:40

im Rescue System rkhunter laufen lassen und im Fall des Falles das ganze System neu ausetzen. Kein rum gebastel. Das geht garantiert schief.

a-n
Posts: 145
Joined: 2004-05-10 10:15

Re: DRINGEND: Server fährt nicht mehr hoch nach xinitd abstu

Post by a-n » 2005-07-12 14:08

Merrow wrote: OS: Suse 8.1 Confixx 2.0

danke im voraus
SuSE8.1 bietet schonlange keine Security Patches mehr an.

Sollte auf jdenfall auf ne neuere Version upgraden !

alfmanuel
Posts: 59
Joined: 2004-04-04 13:12
Location: AT [salzburg]

Re: DRINGEND: Server fährt nicht mehr hoch nach xinitd absturz

Post by alfmanuel » 2005-07-12 14:56

stimmt hab ich auch gerade in der suse-dev-list gesehen !

weg mit dem 8.2er suse und wenn möglich neu aufsetzen!!!

nochwas: nie auf der fehlerhaften maschine rkhunter kompilieren, ausser es muss unbedingt so sein