exim4 installation -- setrlimit failed

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
woifi
Posts: 20
Joined: 2005-06-15 12:56

exim4 installation -- setrlimit failed

Post by woifi » 2005-07-09 14:32

hi!

ich wollte gerne nach debianhowto.devorbild einen exim4 mailserver aufsetzten.

leider scheitere ich gleich zu beginn bei exim4-config:

Code: Select all

vl01s06:~# apt-get --reinstall install exim4-config
Reading Package Lists... Done
Building Dependency Tree... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
Need to get 0B of archives.
After unpacking 0B of additional disk space will be used.
Do you want to continue? [Y/n]
Setting up exim4-config (4.50-8) ...
2005-07-09 14:28:00 setrlimit(RLIMIT_NPROC) failed: Operation not permitted
2005-07-09 14:28:00 setrlimit(RLIMIT_NPROC) failed: Operation not permitted
2005-07-09 14:28:00 setrlimit(RLIMIT_NPROC) failed: Operation not permitted
exim: could not open panic log - aborting: see message(s) above
Invalid new configfile /var/lib/exim4/config.autogenerated.tmp
not installing /var/lib/exim4/config.autogenerated.tmp to
/var/lib/exim4/config.autogenerated
dpkg: error processing exim4-config (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of exim4-base:
 exim4-base depends on exim4-config (>= 4.30) | exim4-config-2; however:
  Package exim4-config is not configured yet.
  Package exim4-config-2 is not installed.
  Package exim4-config which provides exim4-config-2 is not configured yet.
dpkg: error processing exim4-base (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of exim4-daemon-heavy:
 exim4-daemon-heavy depends on exim4-base (>= 4.50); however:
  Package exim4-base is not configured yet.
dpkg: error processing exim4-daemon-heavy (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 exim4-config
 exim4-base
 exim4-daemon-heavy
E: Sub-process /usr/bin/dpkg returned an error code (1)
google sowie die forensuche brachte mich nicht weiter, ich hoffe auf tipps eurerseits. :)

das system ist ein vserver, auf welchem debian sarge läuft.

bye

woifi

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: exim4 installation -- setrlimit failed

Post by dodolin » 2005-07-09 16:57

2005-07-09 14:28:00 setrlimit(RLIMIT_NPROC) failed: Operation not permitted
Das ist doch eigentlich eindeutig, oder? Wenn du irgendwelche Limits in /etc/security/limits.conf eingestellt hast, solltest du dich daran erinnern koennen.

woifi
Posts: 20
Joined: 2005-06-15 12:56

Re: exim4 installation -- setrlimit failed

Post by woifi » 2005-07-10 12:44

dodolin wrote:Das ist doch eigentlich eindeutig, oder? Wenn du irgendwelche Limits in /etc/security/limits.conf eingestellt hast, solltest du dich daran erinnern koennen.
Nein, es sind keine limits gesetzt. Es handelst sich eigentlich noch um eine default sarge Installation - ich hab bislang nur Apache, PHP und mysql eingerichtet.

User avatar
Joe User
Project Manager
Project Manager
Posts: 11578
Joined: 2003-02-27 01:00
Location: Hamburg

Re: exim4 installation -- setrlimit failed

Post by Joe User » 2005-07-10 15:02

man ulimit

Kernel mit grsec oder ähnlichem Patch?
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

woifi
Posts: 20
Joined: 2005-06-15 12:56

Re: exim4 installation -- setrlimit failed

Post by woifi » 2005-07-10 17:15

ulimit is obsolete...

über den kernel kann ich leider nicht viel sagen, da es sich wie gesagt um einen vserver handelt...

das einzige was ich jetzt noch gefunden habe ist:

Code: Select all

apt-cache show libbsd-resource-perl
Package: libbsd-resource-perl
Priority: extra
Section: perl
Installed-Size: 232
Maintainer: Piotr Roszatycki <dexter@debian.org>
Architecture: i386
Version: 1.24-2
Depends: perl, perlapi-5.8.4, libc6 (>= 2.3.2.ds1-4)
Filename: pool/main/libb/libbsd-resource-perl/libbsd-resource-perl_1.24-2_i386.deb
Size: 29356
MD5sum: 1b467fbc7462aa140009c5d8e886cb41
Description: perl BSD::Resource - BSD process resource limit and priority
 This Perl extension implements the BSD process resource limit functions
 getrusage() getrlimit() setrlimit() and the BSD process priority functions.
 .
 These are available also via core Perl but here we do more tricks so
 that the PRIO_* are available: getpriority() setpriority().
 .
 Also is provided times() which provides the same functionality as the one
 in core Perl, only with better time resolution.
dieses ist nicht installiert!

woifi
Posts: 20
Joined: 2005-06-15 12:56

Re: exim4 installation -- setrlimit failed

Post by woifi » 2005-07-10 18:16

k, installation des paktes bringt leider auch nichts :(

User avatar
Joe User
Project Manager
Project Manager
Posts: 11578
Joined: 2003-02-27 01:00
Location: Hamburg

Re: exim4 installation -- setrlimit failed

Post by Joe User » 2005-07-10 18:24

woifi wrote:da es sich wie gesagt um einen vserver handelt...
Oops, glatt überlesen - In dem Fall wirst Du wohl an Deinen Hoster wenden müssen, da es sich zu 99% um ein kernelbasiertes Limit handeln wird...
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

woifi
Posts: 20
Joined: 2005-06-15 12:56

Re: exim4 installation -- setrlimit failed

Post by woifi » 2005-07-10 18:43

Joe User wrote:
woifi wrote:da es sich wie gesagt um einen vserver handelt...
Oops, glatt überlesen - In dem Fall wirst Du wohl an Deinen Hoster wenden müssen, da es sich zu 99% um ein kernelbasiertes Limit handeln wird...
Hab ich schon gemacht, aber am Sonntag beantwortet da natürlich keiner E-Mails ;)

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: exim4 installation -- setrlimit failed

Post by dodolin » 2005-07-11 07:20

Es hat sich bereits gezeigt, dass ein exim4/vexim/mysql/spamassassin/clamav Setup einfach viel zu ueberdimensioniert fuer fast jede Art von vserver ist. Leg dir was groesseres zu und du wirst keine Probleme mehr haben.