Debian Woody auf Strato - nach dis-upgrade kein Server start

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
lindwyrm
Posts: 10
Joined: 2005-06-08 01:05

Debian Woody auf Strato - nach dis-upgrade kein Server start

Post by lindwyrm »

Huhu Zusammen,

ich habe das Image für Debian Woody auf meinen Root-Server installiert.

Ich habe mich gleich auf die Seriellen-Console angemeldet um später den Boot-Status verfolgen zu können.

Danach habe ich gleich die sources.list für den apt-packetmanager angepasst und ein apt-get update und ein apt-get dist-upgrade ausgeführt.

Das Upgrade an sich lief auch einwandfrei durch, und habe beim Installationsdialog die Defaults belassen. Ich habe also keine bestehende config überschrieben.

Nun wollte ich eine reboot durchführen, aber der Server startet nicht mehr.

In der Seriellen Console bleibt er an folgenden Punkt stehen und ist damit nicht mehr erreichbar:
h68231:/# shutdown -r now

Broadcast message from root (ttyS0) (Sat Jul 2 17:01:32 2005):

INIT: Sending processes the TERM signal
INIT: SendStopping periodic command scheduler: cron.
Stopping internet superserver: inetd.
Stopping rsync daemon: rsync.
Stopping OpenBSD Secure Shell server: sshd.
Saving the System Clock time to the Hardware Clock...
Hardware Clock updated to Sat Jul 2 17:01:39 CEST 2005.
Stopping kernel log daemon: klogd.
Stopping system log daemon: syslogd.
Sending all processes the TERM signal...done.
Sending all processes the KILL signal...done.
Saving random seed...done.
Unmounting remote and non-toplevel virtual filesystems...done.
Deconfiguring network interfaces: **** /sbin/dhcpcd-bin: not running
done.
Deactivating swap...done.
Unmounting local filesystems...done.
Rebooting... flushing ide devices: hda
Restarting system.

PXELINUX 1.76 2002-08-27 Copyright (C) 1994-2002 H. Peter Anvin
Booting from local disk...
Ich habe schon ein Hardreset und eine neuinstallation + dist-upgrade leider ohne Erfolg versucht ...


Für eure Hilfe wäre ich euch echt dankbar
superuser1
Posts: 291
Joined: 2003-11-26 18:43
Location: earth

Re: Debian Woody auf Strato - nach dis-upgrade kein Server start

Post by superuser1 »

lord_pinhead
Posts: 774
Joined: 2004-04-26 15:57

Re: Debian Woody auf Strato - nach dis-upgrade kein Server start

Post by lord_pinhead »

Ja da kann ich dir glaub ich helfen :D Dein MBR ist zerfeuert nach dem Update, du hättest Lilo nochmal ausführen müssen. Hatte ich auch, aber im Rescue Mode konnt ich das zum Glück wieder richten.

1) Mounten der /-Partition in /mnt/hda
2) Mounten der /boot-Partition in /mnt/hda/boot
3) lilo -d 10 -c /mnt/hda/ eintippen und hoffen das der MBR neu geschrieben wird nach deiner Config (die hoffentlich auch nach dem Upgrade geändert wurde, ist ein bischen was anders.)

Dann rebooten und daumen drücken das er hochläuft. Ansonsten mal in /mnt/hda/var/log/dmesg nachsehn was passiert.
lindwyrm
Posts: 10
Joined: 2005-06-08 01:05

Re: Debian Woody auf Strato - nach dis-upgrade kein Server start

Post by lindwyrm »

ahh vielen dank, genau das war es ... hmm aber eigentlich sollte er doch nach dem lilo update dieses von sich aus neu schreiben, oder?

Und der Link ist auch sehr interessant, hab den gleich mal gebookmarkt.

aber nun läuft es wieder und ich habe wieder was gelernt ^^ ... danke euch beiden
lord_pinhead
Posts: 774
Joined: 2004-04-26 15:57

Re: Debian Woody auf Strato - nach dis-upgrade kein Server start

Post by lord_pinhead »

Sag niemals "Es müsste gehen", den Fehler hatte ich oft nach einen Lilo Update. Daher immer drauf achten ob Lilo geupdatet wird und gleich mal danach lilo ausführen. Aber gut das er wieder läuft :)