Kernel bauen --> unknown block fehler

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
marco.kobek
Posts: 40
Joined: 2004-06-11 20:45

Kernel bauen --> unknown block fehler

Post by marco.kobek »

Ich habe auf Debian Sarge mehrere Kernel Versionen erstellt und das configxyz-file von /boot/ nach /usr/src/kernel-source-Vxy/ kopiert.

Dann make menuconfig und das conif geladen und dann gespeichert.
dann mit make-kpkg --revision=testkernel1 kernel_image ein .deb erstellt welches dann mit dpkg -i installiert wurde.

Beim Booten bekomm ich aber immer einen Fehler beim booten von sda1 bzw. "unknown block).

was mach ich da falsch???
captaincrunch
Userprojekt
Userprojekt
Posts: 7066
Joined: 2002-10-09 14:30
Location: Dorsten

Re: Kernel bauen --> unknown block fehler

Post by captaincrunch »

Genauere Logs helfen uns den Fehler zu finden. Alles andere ist Raterei.
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc
marco.kobek
Posts: 40
Joined: 2004-06-11 20:45

Re: Kernel bauen --> unknown block fehler

Post by marco.kobek »

Beim booten bekomme ich folgende Fehlermeldung. in /var/boot/ usw finde ich natürlich nix da er mit den Platten erst garnicht zurecht kommt.

VFS: Cannnot open root device "sda1" or unknown-block(0,0)
Kernel panic - not syncing: VFS: unable to mount root fs or unknown-block (0,0)

Könnt ihr damit was anfangen?
Sind wie gesagt SATA-Platten auf einem ASUS P4S8X-MX

Hier auch das .config aus /usr/src/linux-2.6.12
http://dynetix.net/downloads/.config
Und hier die zwei Files aus /boot/.
Die ältere Version ist die original von der Installation
http://dynetix.net/downloads/config-2.4.27-2-386
http://dynetix.net/downloads/config-2.6.12

ich hoffe diese Infos helfen möglichst weiter.

Nowas zum System. Ist ein P4 2,4GHz mit 1GB RAM und halt die zwei SATA Platten (SiS Controler onboard)
superuser1
Posts: 291
Joined: 2003-11-26 18:43
Location: earth

Re: Kernel bauen --> unknown block fehler

Post by superuser1 »

Hi...

1) wenn das ein Rootserver sein soll, dann deaktiviere bitte unnötigen Ballast.
2) wahrscheinlich wird das passende Kernelmodul für deinen SATA-Hostadapter nicht geladen... also forsche mal in die Richtung weiter.

btw:
Ist ein P4 2,4GHz...

Code: Select all

CONFIG_MPENTIUMM=y
# CONFIG_MPENTIUM4 is not set
:roll: