Horde, safe_mode, pear

Bash, Shell, PHP, Python, Perl, CGI
mschlem
Posts: 5
Joined: 2004-09-03 06:50

Horde, safe_mode, pear

Post by mschlem »

Hi also zuallerstmal hoffe ich das ich hier in dem Forum richtig bin :)
desweitern sorry schon wiedereinmal dieses Thema anzusprechen aber alle bisherigen Topcis zu dem Thema haben mir nicht geholfen und ich weiss wirklich nicht mehr weiter :(

Also mal zu den Fakten:

Server: SuSE-8.1 mit confixx-profi 2.x
Environment: Apache/1.3.26 (Linux/SuSE) mod_ssl/2.8.10
OpenSSL/0.9.6g PHP/4.3.10
Horde: Horde: 3.0.4

Probleme: 1) safe_mode disabled: No If safe_mode is enabled, Horde
cannot set enviroment variables, which means Horde will
be unable to translate the user interface into different
languages.

2) PEAR Search Path (PHP's include_path):
/home/www/web1/html/horde/lib:.:/usr/share/php
PEAR: No
Check your PHP include_path setting to make sure it has
the PEAR library directory.

3) Unter Horde: Administration: Konfiguration:
Keine Versionsnummer in Ihrer Konfiguration gefunden.
Erneuern Sie Ihre Konfiguration.

So nun zu den Einstellungen:
Zu Problem1:
/etc/php.ini
; Safe Mode
;
safe_mode = Off
/etc/httpd/confixx_vhost.conf
NameVirtualHost XXX.XXX.XXX.XXX:80
php_admin_flag safe_mode Off
php_admin_value safe_mode_exec_dir /home/www/empty


Zu Problem2:
find / -name PEAR.php:
/root/php-4.3.10/pear/PEAR.php
/usr/share/php/PEAR.php

Configuration:
==============
PEAR executables directory bin_dir /usr/bin
PEAR documentation directory doc_dir /usr/share/php/doc
PHP extension directory ext_dir /usr/share/extensions/no-debug-non-
zts-20020429
PEAR directory php_dir /usr/share/php
PEAR Installer cache directory cache_dir /tmp/pear/cache
PEAR data directory data_dir /usr/share/php/data
PHP CLI/CGI binary php_bin /usr/bin/php
PEAR test directory test_dir /usr/share/php/test
Cache TimeToLive cache_ttl 3600
Preferred Package State preferred_state stable
Unix file mask umask 22
Debug Log Level verbose 1
HTTP Proxy Server Address http_proxy <not set>
PEAR server master_server pear.php.net
PEAR password (for password <not set>
maintainers)
Signature Handling Program sig_bin /usr/bin/gpg
Signature Key Directory sig_keydir /usr/share/etc/pearkeys
Signature Key Id sig_keyid <not set>
Package Signature Type sig_type gpg
PEAR username (for username <not set>
maintainers)


Include Path in /etc/php.ini:
include_path = ".:/usr/share/php/PEAR:/tmp:usr/bin..."

Zu Problem3:
Keine Ahnung hab auch unter Google nichts gefunden, tippe halt das das an den PEAR problemen liegt ???

Also wäre dankbar über jede Hilfe :)

mfg
Micha
mydani
Posts: 152
Joined: 2003-08-18 19:34

Re: Horde, safe_mode, pear

Post by mydani »

Gibts bei dir ../PEAR und ../PEARx? (x sei eine Ganzzahl)...
Dieses Problem hatte ich bei mir mal mit unterschiedlichen Pearversionen. Geholfen hat ein Symlink von PEARx nach PEAR.
Gruß
r00ty
Posts: 747
Joined: 2003-03-17 15:32

Re: Horde, safe_mode, pear

Post by r00ty »

also ich habs auch ne Weile probiert zum laufen zu bringen habs dann aber sein lassen
jetzt verwende ich suPhp mit Safe-Mode disabled und es tut prima :)
mschlem
Posts: 5
Joined: 2004-09-03 06:50

Re: Horde, safe_mode, pear

Post by mschlem »

Ne habe nicht wirklich 2 PEAR Versionen drauf

find / -name PEAR*

/root/php-4.3.10/pear/PEAR
/root/php-4.3.10/pear/tests/PEAR_ErrorStack
/root/php-4.3.10/pear/PEAR.php
/usr/share/php/PEAR
/usr/share/php/PEAR.php
/usr/share/php/data/PEAR
/usr/share/lib/php/PEAR-1.4.0a12.tgz
/usr/share/lib/php/PEAR_Info-1.6.0.tgz
/usr/share/lib/php/PEAR_PackageFileManager-1.6.0a1.tgz
/usr/share/lib/php/PEAR_PackageFileManager_GUI_Gtk-1.0.1.tgz

Das mit suPHP würde ich gerne umgehen, da ich gerne wüsste was in meinem System vor sich geht :), aber vielen Dank für den Tipp falls gar nix geht
antondollmaier
Posts: 485
Joined: 2004-03-30 10:06

Re: Horde, safe_mode, pear

Post by antondollmaier »

Code: Select all

safe_mode_include_dir = /usr/share/php
damit läuft Horde hier trotz suPHP und safe_mode = on ...


HTH,
Anton
mschlem
Posts: 5
Joined: 2004-09-03 06:50

safe_mode_include_dir

Post by mschlem »

hi, alslo irgendwie bringt das auch nichts...

habe daas jetzt mal in der php.ini dringehabt und in der confixx.vhosts:

php_admin_value open_basedir /home/www/web1/:/tmp:/usr/share/php
php_admin_value upload_tmp_dir /home/www/web1/phptmp/
php_admin_flag safe_mode Off
php_admin_value safe_mode_include_dir /usr/share/php

hat aber alles nichts gebracht...
das kann doch nicht mehr sein ....

bin echt langsam am verzweifeln...
r00ty
Posts: 747
Joined: 2003-03-17 15:32

Re: Horde, safe_mode, pear

Post by r00ty »

was sagt denn die Status Seite ?
mschlem
Posts: 5
Joined: 2004-09-03 06:50

Statusseite ???

Post by mschlem »

Meinst du die horde testseite ??

siehe oben erstes posting


oder meinst du die phpinfo()

phpinfo sagt master value off local value on; zu pear steht da gar nix aber der include_path wird wie angegeben angezeigt


Auch bisher mal danke an alle die sich gemeldet haben, auch wenn ich noch nicht wirklich weiter bin ;)
r00ty
Posts: 747
Joined: 2003-03-17 15:32

Re: Horde, safe_mode, pear

Post by r00ty »

also schreib einfach mal direkt in die
/etc/apache2/confixx_vhost.conf
beim passenden vhost
php_admin_flag safe_mode Off
rein. Dann muss php_safe auch wirklich aus sein
rcapache2 restart
nicht vergessen
mschlem
Posts: 5
Joined: 2004-09-03 06:50

Re: Horde, safe_mode, pear

Post by mschlem »

danke für den Tipp, aber SIEHE OBEN:

habe apache 1.3XX,
in der confixx_vhost.conf (gibt nur eine unter /etc/httpd/confixx_vhost.conf
und in der steht wie schon oben beschrieben das admin_flag bereits drin.
den apache hab ich auch schon paar mal neu-gestartet.

also bringt leider nichts, gleiches ergebniss ;(