Zeit Problem auf SuSe 9.1

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
fbecker
Posts: 6
Joined: 2005-06-20 09:40

Zeit Problem auf SuSe 9.1

Post by fbecker »

Ich habe einen Root Server mit SuSe 9.1 von 1und1.
Allerdings habe ich dort ein Problem mit der Serverzeit.
Die Zeit des Servers stimmt mit der Aktuellen Uhrzeit überein.
über PHGP wird auch die Korrekte Uhrzeit ausgegeben, allerdings werden Dateien die auf dem Server gespeichert werden mit Zeitstempel -2 Stunden der eigentlichen Serverzeit geschrieben.
Wenn ich mit date über ssh die Zeit abfrage, wird die Aktuelle Uhrzeit angezeigt.
Bsp: Mit date zeigt er mir : Mo Jun 20 09:44:32 CEST 2005
Wenn ich jetzt eine Datei auf dem Server Speicher wird die Zeit der Datei dann so angezeigt: Mo Jun 20 07:44:32 CEST 2005

Ich habe bereits die Zeitzonen Datei für Berlin ausgetauscht und auch bereits mehrmals versucht mit Yast die Uhrzeit richtig zu bekommen, so das die Uhrzeit überall stimmt. Leider Ohne Erfolg.

Woran kann es liegen das ich beim Speichern von Dateien einen Zeitversatz von 2 Stunden habe? Vor allem wie kann ich es beheben.
Der Zeitversatz tritt bei jeder Art von Speicherung auf. Egal ob über FTP, PHP oder eine Datei von Apache selber geschrieben wird. Immer Speicherzeit = Reale Zeit -2 Stunden.

Der Support von 1und1 konnte da nicht weiterhelfen. Von dort habe ich nur den Tipp bekommen hier nachzusehen. Per E-Mail Support bekam ich nur die geistreiche Antwort den Server alle 15 Min ein Script ausführen zu lassen, welches die Aktuelle Zeit von einem Zeitserver holt.

Nette Idee, doch leider ist nicht die Reale Zeit das Problem und nen Abgleich mit einem Zeitserver habe ich bereits mehrmals gemacht.

Vielleicht weis ja einer eine Lösung........

User avatar
Joe User
Project Manager
Project Manager
Posts: 11164
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Zeit Problem auf SuSe 9.1

Post by Joe User »

Du verhexelst Server (international, UTC) und Clienten (national, localtime)...

PS: man ntpdate

Code: Select all

ntpdate -b -s -p 4 -t 0.1 ptbtime1.ptb.de
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

fbecker
Posts: 6
Joined: 2005-06-20 09:40

Re: Zeit Problem auf SuSe 9.1

Post by fbecker »

Kein erfolg:

Code: Select all

xxxx:/ # ntpdate -b -s -p 4 -t 0.1 ptbtime1.ptd.de
Error : Name or service not known

Roger Wilco
Posts: 5923
Joined: 2004-05-23 12:53

Re: Zeit Problem auf SuSe 9.1

Post by Roger Wilco »

FBecker wrote:Kein erfolg:
Tippfehler.

fbecker
Posts: 6
Joined: 2005-06-20 09:40

Re: Zeit Problem auf SuSe 9.1

Post by fbecker »

Befehl ausgeführt keine änderung
reboot ausgeführt keine änderung
nochmals befehl ausgeführt keine änderung....

Also hier nochmal die Daten:

Code: Select all

xxxx:/ # date
Mo Jun 20 17:18:18 CEST 2005
Die Dateien werden aber mit Uhrzeit -2 Stunden geschrieben.
Woran kann es liegen??
Wenn ich mittels PHP mir die Serverzeit anzeigen lasse stimmt die Zeit.
Wenn ich die über ssh Abfrage stimmt die Zeit ebenfals.

Nur beim Speichern auf dem Server wird die Speicherzeit -2 Stunden gezeigt.
Sprich, ich Speicher um 17:20Uhr eine Datei auf dem Server. Dann zeigt mir der Server an das ich die Datei um 15.20Uhr dort abgelegt habe. Was ja nicht stimmt, da es 17:20Uhr war.

Und ich denke nicht das ich Server Client da verwechsel. Den PHP ließt nicht die Client Zeit aus, sondern die Server Zeit und die besagt eben das sie Richtig eingestellt ist.

Und wie beschreiben Zeitupdate hat auch nichts daran geändert....

Roger Wilco
Posts: 5923
Joined: 2004-05-23 12:53

Re: Zeit Problem auf SuSe 9.1

Post by Roger Wilco »

Was sagt denn `ls --fulltime`? Auf welche Zeitzone ist /etc/localtime gesetzt? Was gibt `date -R` aus?

fbecker
Posts: 6
Joined: 2005-06-20 09:40

Re: Zeit Problem auf SuSe 9.1

Post by fbecker »

bei ls --fulltime ergibt nur Ungültige Option --fulltime
Localtime ist mittels Yast auf Europa/Germany gestellt
über Plesk habe ich die Zeitzone auf (GMT +2:00) Europa/Berlin gesetzt.
und date -R:

Code: Select all

xxxx:/etc # date -R
Mon, 20 Jun 2005 17:51:45 +0200
Wenn ich nicht genau wüsste das mein vorheriger Root Server die Zeit beim Speichern nicht Richtig gesetzt hätte, würde ich es darauf schieben das der Server halt die Daten in UTC Zeit Speichert. Danach sieht es ja aus.
Mir wäre es ja egal mit welcher Zeit er die Dateien speichert, wenn davon nicht auch der Mail Verkehr betroffen wäre....

Roger Wilco
Posts: 5923
Joined: 2004-05-23 12:53

Re: Zeit Problem auf SuSe 9.1

Post by Roger Wilco »

FBecker wrote:bei ls --fulltime ergibt nur Ungültige Option --fulltime
Sorry, sollte `ls --full-time` sein.

fbecker
Posts: 6
Joined: 2005-06-20 09:40

Re: Zeit Problem auf SuSe 9.1

Post by fbecker »

kann passieren....

hier das ergebnis der Datei die ich um 19:07 gespeichert habe.
2005-06-20 19:07:42.766387620 +0200

wenn ich mir das verzeichnis nur mit dir aufrufe, steht dann nur 2005-06-20 17:07:42

Recht eigenartig....

Roger Wilco
Posts: 5923
Joined: 2004-05-23 12:53

Re: Zeit Problem auf SuSe 9.1

Post by Roger Wilco »

Das zeigt zumindest, dass die Zugriffs- bzw. Erstellzeiten der Dateien korrekt geschrieben werden. Ist also nur ein Formatproblem.

User avatar
Joe User
Project Manager
Project Manager
Posts: 11164
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Zeit Problem auf SuSe 9.1

Post by Joe User »

Joe User wrote:Du verhexelst Server (international, UTC) und Clienten (national, localtime)...
FBecker wrote:Localtime ist mittels Yast auf Europa/Germany gestellt
Falsch: Hier muss UTC gewählt werden -> Serverzeit
FBecker wrote:über Plesk habe ich die Zeitzone auf (GMT +2:00) Europa/Berlin gesetzt.
Richtig: Hier sollte localtime gewählt werden -> Plesk = Client
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

fbecker
Posts: 6
Joined: 2005-06-20 09:40

Re: Zeit Problem auf SuSe 9.1

Post by fbecker »

Problem ist behoben.
Habe einfach noch mal die Zeitzonen Datei für Berlin gelöscht und noch mal neu geladen und abgelegt. Server Reboot gemacht,
dann mit Yast die Uhrzeit nach kontrolliert und ebenfalls die Zeitzone neu gesetzt. Anschließend in Plesk eingelogt und dort die Zeitzone ebenfalls neu gesetzt. Server Reboot und schon war alles wieder ok.
Dateidatum stimmt wieder und Uhrzeit stimmt auch wieder....

Ich weis zwar nicht woran es gelegen hat, aber das war bei mir die Lösung.

Ich danke für die Hilfe....