Ich w.n. gaga: SuSE, Putty und das Terminal => Sonderz.

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
Outlaw
Posts: 1500
Joined: 2002-12-04 10:22
Location: 4. Server von rechts, 2. Reihe von oben

Ich w.n. gaga: SuSE, Putty und das Terminal => Sonderz.

Post by Outlaw »

Hallo Leute,

ich habe das Problem, daß ich sowohl bei SuSE 9.1 (meinem Internetserver) als auch bei SuSE 9.3 (lokaler Server) beim Zugriff per Putty entweder im YAST oder im MC nur noch Steuerzeichen statt Linien zu sehen bekomme.

Kann da mal einer etwas aufklären ??

Wenn ich im Putty als Zeichensatz UTF-8 einstelle, dann ist MS ok, aber YAST spinnt, wenn ich auf ISO-8859-15:1999 (Latin-9, "euro") umstelle, isses umgekehrt und YAST is OK aber der MC spinnt.

Ich hatte es mal so, daß beide nicht passten aber die Kombi, daß beide stimmen bekomme ich einfach nicht mehr hin.

Gruß Outi

Outlaw
Posts: 1500
Joined: 2002-12-04 10:22
Location: 4. Server von rechts, 2. Reihe von oben

Re: Ich w.n. gaga: SuSE, Putty und das Terminal => Sonderz.

Post by Outlaw »

Das 2. hier ursprünglich genannte Problem hat sich erledigt, sorry, die Putty Geschichte besteht aber noch ....

Gruß Outi

User avatar
Joe User
Project Manager
Project Manager
Posts: 11164
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Ich w.n. gaga: SuSE, Putty und das Terminal => Sonderz.

Post by Joe User »

Code: Select all

insserv -d apache2
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

fritz
Posts: 891
Joined: 2002-04-23 20:12
Location: Lehrte / Hannover

Re: Ich w.n. gaga: SuSE, Putty und das Terminal => Sonderz.

Post by fritz »

ich habe auf den Servern mit SuSE 9.x einfach UTF-8 komplett abgeschaltet. (brauche ich nicht) Dann musste ich an keiner anderen Stelle etwas ändern oder 'experimentieren' (console fonts usw...)
Es ist dann auch völlig egal, ob Du ISO-8859-15, ISO-8859-1 oder etwas anderes nimmst.

http://s11server.de/11ers/utf-8.jpg

Yast - System - Sprache wählen - (mit TAB-Taste auf [Details]) - UTF8 ausschalten

(und rebooten ;-)

Gruss Fritz
Last edited by fritz on 2005-06-14 01:12, edited 1 time in total.

Outlaw
Posts: 1500
Joined: 2002-12-04 10:22
Location: 4. Server von rechts, 2. Reihe von oben

Re: Ich w.n. gaga: SuSE, Putty und das Terminal => Sonderz.

Post by Outlaw »

Joe User wrote:

Code: Select all

insserv -d apache2
??

Ach, Du meinst zu meinem damaligen 2. Problem ??

Gruß Outi

Outlaw
Posts: 1500
Joined: 2002-12-04 10:22
Location: 4. Server von rechts, 2. Reihe von oben

Re: Ich w.n. gaga: SuSE, Putty und das Terminal => Sonderz.

Post by Outlaw »

Fritz wrote:ich habe auf den Servern mit SuSE 9.x einfach UTF-8 komplett abgeschaltet. (brauche ich nicht) Dann musste ich an keiner anderen Stelle etwas ändern oder 'experimentieren' (console fonts usw...)
Es ist dann auch völlig egal, ob Du ISO-8859-15, ISO-8859-1 oder etwas anderes nimmst.

http://s11server.de/11ers/utf-8.jpg

Yast - System - Sprache wählen - (mit TAB-Taste auf [Details]) - UTF8 ausschalten

(und rebooten ;-)

Gruss Fritz

P.S. Joe, was haben die runlevel von apache2 mit den fonts über's Terminal zu tun? Bitte um ein paar Worte mehr zum Verständnis.
Hmmmm, hatte ich gemacht aber ohne Erfolg, wobei, ich hatte mich nicht neu eingloggt, mal probieren, obs daran lag ....

Komisch is halt, daß ich beide genannten Programme richtig hin bekomme, jedoch nicht gleichzeitig, eben immer nur abwechselnd ....

Was ich halt nicht verstehe, warum da Putty so reinhaut, denn an der lokalen Konsole funzt es prima, da gehen beide Proggis per UTF-8 aber über Putty nur der MC ....

So, gleich mal testen geh ....

Neeee, doch nicht, noch schlimmer, jetzt sind auch die Umlaute weg ....

naja, werde weiter testen.

Danke und Gruß Outi

fritz
Posts: 891
Joined: 2002-04-23 20:12
Location: Lehrte / Hannover

Re: Ich w.n. gaga: SuSE, Putty und das Terminal => Sonderz.

Post by fritz »

Outi, verstehe ich nicht. Du hast sicher schon so viel verstellt, dass nix mehr passt?! Ich habe in den letzten Wochen mehrere frisch installierte Server (SuSE 9.2 und 9.3) so, wie oben beschrieben, dazu gebracht, sowohl an der Konsole, als auch über Putty, alle Programme wie MC, W3M usw, die Linien zeichnen, richtig anzuzeigen. Auch mit Euro, Umlauten usw...
Sicher geht das auch gezielter, ohne UTF-8 abzuschalten, aber ich habe natürlich nicht weiter gesucht, weil ich so schon zufrieden war. Sonst hätte ich speziell noch die console_fonts, und die configs in /etc/sysconfig/language, /etc/sysconfig/console usw überprüft.

Gruss Fritz

User avatar
Joe User
Project Manager
Project Manager
Posts: 11164
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Ich w.n. gaga: SuSE, Putty und das Terminal => Sonderz.

Post by Joe User »

Outlaw wrote:Ach, Du meinst zu meinem damaligen 2. Problem ??
Jupp, ich war nur etwas zu spät ;)
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

Outlaw
Posts: 1500
Joined: 2002-12-04 10:22
Location: 4. Server von rechts, 2. Reihe von oben

Re: Ich w.n. gaga: SuSE, Putty und das Terminal => Sonderz.

Post by Outlaw »

Joe User wrote:
Outlaw wrote:Ach, Du meinst zu meinem damaligen 2. Problem ??
Jupp, ich war nur etwas zu spät ;)
Danke trotzdem, ich hab mir das gespeichert, bin kurz vorher über den Runleveleditor in Yast gestolpert ....

Gruß Outi

Outlaw
Posts: 1500
Joined: 2002-12-04 10:22
Location: 4. Server von rechts, 2. Reihe von oben

Re: Ich w.n. gaga: SuSE, Putty und das Terminal => Sonderz.

Post by Outlaw »

Fritz wrote:Outi, verstehe ich nicht. Du hast sicher schon so viel verstellt, dass nix mehr passt?! Ich habe in den letzten Wochen mehrere frisch installierte Server (SuSE 9.2 und 9.3) so, wie oben beschrieben, dazu gebracht, sowohl an der Konsole, als auch über Putty, alle Programme wie MC, W3M usw, die Linien zeichnen, richtig anzuzeigen. Auch mit Euro, Umlauten usw...
Sicher geht das auch gezielter, ohne UTF-8 abzuschalten, aber ich habe natürlich nicht weiter gesucht, weil ich so schon zufrieden war. Sonst hätte ich speziell noch die console_fonts, und die configs in /etc/sysconfig/language, /etc/sysconfig/console usw überprüft.

Gruss Fritz
Hallo Fritz,

danke für die Infos, habe diese Dateien auch schon durchgesehen aber nix verdächtiges gefunden.

Was ich eben nicht ganz verstehe ist eben die Tatsache, daß ich auf dem Lokalen Server an der Console alles trotz UTF-8 angezeigt bekomme, Yast und MC funzen prima, sobald ich aber per Putty zugreife, stimmt bei Yast der Zeichensatz nicht mehr, ich habe zwar Umlaute aber keine Linien mehr, stelle ich UTF-8 aus (in Yast & Putty), dann bekomme ich wieder Linien aber keine Umlaute und MC hat keine Linien mehr.

Daher suche ich den vermeintlichen Schalter in Putty oder Yast für Yast, da ja der MC tadellos funzt und beides eben an der direkten Console auch.

Gruß Outi