Selbst gelöst: Postfix fragt nicht nach SMTP-Auth

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
sllnd
Posts: 177
Joined: 2002-10-14 22:33

Selbst gelöst: Postfix fragt nicht nach SMTP-Auth

Post by sllnd » 2005-06-10 15:16

Hallo zusammen,

habe ein kleines Problem, was mich schon mehrere Stunden durch den Wind zieht

Suse 9.2, Postfix 2.15

Meine Konfig:
biff = no
mail_spool_directory = /var/mail
canonical_maps = hash:/etc/postfix/canonical
virtual_maps = hash:/etc/postfix/virtual
relocated_maps = hash:/etc/postfix/relocated
transport_maps = hash:/etc/postfix/transport
sender_canonical_maps = hash:/etc/postfix/sender_canonical
masquerade_exceptions = root
masquerade_classes = envelope_sender, header_sender, header_recipient
myhostname = linux.local
program_directory = /usr/lib/postfix
inet_interfaces = all
masquerade_domains =
mydestination = $myhostname, localhost.$mydomain
defer_transports =
disable_dns_lookups = no
relayhost =
mailbox_command =
mailbox_transport =
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_client_restrictions =
smtpd_helo_required = no
smtpd_helo_restrictions =
strict_rfc821_envelopes = no
smtpd_recipient_restrictions = permit_mynetworks,reject_unauth_destination
smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtpd_sasl_auth_enable = yes
smtpd_use_tls = no
smtp_use_tls = no
alias_maps = hash:/etc/aliases
mailbox_size_limit = 0
message_size_limit = 10240000
Bei jedem Server bekomme ich erstmal "Relay Access Denied", nur hier bekomme ich dieses noch nicht einmal. Einstellung beim Mail Client ohne jegliche authentifizierung und die Mail geht raus. Kommt für mich vor, als wenn Postfix die Paramater für SMTP-Auth gar nicht beachtet.

Danke im vorraus.
Last edited by sllnd on 2005-06-10 16:52, edited 1 time in total.

chaosad
Posts: 137
Joined: 2005-05-06 15:48

Re: Selbst gelöst: Postfix fragt nicht nach SMTP-Auth

Post by chaosad » 2005-06-10 15:35

kannst ja mal das folgende zum Testen verwenden:

telnet relay-test.mail-abuse.org

sllnd
Posts: 177
Joined: 2002-10-14 22:33

Re: Selbst gelöst: Postfix fragt nicht nach SMTP-Auth

Post by sllnd » 2005-06-10 15:46

Habs ja mit meinem Mailclient getestet und per Telnet vom Client auf den Server, kann im moment auch keine externen Tests durchführen, da der Server zur Zeit noch eine internet IP hat und gar nicht durchs Netz erreichbar ist (was auch zur Zeit besser so ist ;) )

Hab im Prinzip das selbe/gleiche *gg* Problem wie aus dem Post http://www.rootforum.org/forum/viewtopic.php?t=29826

Mein Postfix befindet sich in keiner chroot Umgebung.

Logs

/var/log/messages

Code: Select all

Jun 10 15:29:27 web01 saslauthd[13976]: server_exit     : master exited: 13976
Jun 10 15:29:27 web01 saslauthd[14316]: detach_tty      : master pid is: 14316
Jun 10 15:29:27 web01 saslauthd[14316]: ipc_init        : listening on socket: /var/run/sasl2//mux
/var/log/mail

Code: Select all

Jun 10 12:55:36 web01 postfix/smtpd[10637]: connect from unknown[192.168.3.53]
Jun 10 10:55:36 web01 postfix/smtpd[10637]: warning: unknown smtpd restriction: "perm??it_mynetworks"
Jun 10 10:55:36 web01 postfix/smtpd[10637]: NOQUEUE: reject: RCPT from unknown[192.168.3.53]: 451 Server configuration error; from=<uwe@web01.de> to=<uwe@test-domain.de> proto=SMTP helo=<nb-uwe>
Jun 10 12:55:36 web01 postfix/cleanup[10640]: BF5FC8C96: message-id=<20050610105536.BF5FC8C96@web01.local>
Jun 10 12:55:36 web01 postfix/qmgr[10626]: BF5FC8C96: from=<double-bounce@web01.local>, size=624, nrcpt=1 (queue active)
Jun 10 10:55:36 web01 postfix/smtpd[10637]: disconnect from unknown[192.168.3.53]
Jun 10 12:55:37 web01 postfix/local[10641]: BF5FC8C96: to=<root@web01.local>, orig_to=<postmaster>, relay=local, delay=1, status=sent (delivered to command: /usr/bin/procmail)
Jun 10 12:55:37 web01 postfix/qmgr[10626]: BF5FC8C96: removed

sllnd
Posts: 177
Joined: 2002-10-14 22:33

Re: Selbst gelöst: Postfix fragt nicht nach SMTP-Auth

Post by sllnd » 2005-06-10 16:50

Hat sich erledigt, ich depp, ich hatte sowohl den Mailserver als auch den Client im selben Netz, klar, dass der dann Mails ohne SMTP-Auth verschickt, wenn in den restrictens allow für das selbe netz drinnen steht.

Ist halt der erste Server, den ich direkt neben meinem PC installiere und nicht im Serverraum ;)

Schönes Wochenende...