Kein Spamassassin bei lokalen SMTP Connects.

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
hotzi
Posts: 197
Joined: 2004-04-14 09:04
Location: Bayern, Sulzemoos

Kein Spamassassin bei lokalen SMTP Connects.

Post by hotzi » 2005-05-27 12:07

Hallo allerseits.

Ich habe aktuell folgende Konfiguration:

Konfig: Debian/Exim4/Amavis/SAExim

Edit:

Ich habe also nun herausgefunden, dass

Code: Select all

2005-05-27 12:40:19 1DbcGJ-0000ht-8g SA: Action: Not running SA because SAEximRunCond expanded to false
nur auftritt, wenn die Email local per smtp ans Mailsystem übergeben wird, zum Beispiel von Fetchmail. Bei connects von externen IPs läuft der SA sauber.



Hat hier jemand eine Idee, wo ich bei der Fehlersuche ansetzen könnte?

Danke und Gruß

Andre
Last edited by hotzi on 2005-05-27 13:03, edited 1 time in total.

hotzi
Posts: 197
Joined: 2004-04-14 09:04
Location: Bayern, Sulzemoos

Re: Kein Spamassassin bei lokalen SMTP Connects.

Post by hotzi » 2005-05-27 12:15

Hm, wenn ich lokal Emails per telnet versende, habe ich den selben Effekt, fetchmal liefert ja auch per smtp an den lokalen Port 25 aus.

Schonmal ein kleiner Hinweis...

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: Kein Spamassassin bei lokalen SMTP Connects.

Post by dodolin » 2005-05-27 21:18

Hat hier jemand eine Idee, wo ich bei der Fehlersuche ansetzen könnte?
Du solltest deine Zeit nicht verschwenden, einen Fehler zu suchen, denn den gibt es nicht. Du musst lediglich deinen SAExim richtig konfigurieren. Das entsprechende Stichwort steht ja sogar in der Fehlermeldung: SAEximRunCond. Weiterhin wundert mich, wie man mit SAExim noch Amavis benoetigen kann und wie das noch sinnig zusammenspielt?

hotzi
Posts: 197
Joined: 2004-04-14 09:04
Location: Bayern, Sulzemoos

Re: Kein Spamassassin bei lokalen SMTP Connects.

Post by hotzi » 2005-05-27 21:24

Hallo,

ich habs schon gefunden, sorry, vergessen hier zu antworten.

Das Problem liegt hier:

Code: Select all

SAEximRunCond: ${if and {{def:sender_host_address} {!eq {$sender_host_address}{127.0.0.1}}  {!eq {${mask:${sender_host_address}/24}} {192.168.0.0/24}} {!eq {$h_X-SA-Do-Not-Run:}{Yes}} } {1}{0}}
Im Web gilt die Meinung, dass SAExim und Fetchmail keine gute Kombi wären. Jedenfalls habe ich vor, eine weitere Regel dahinter zu schreiben, die wenn Fetchmail einliefert, den Flag wieder auf 1 setzt.

Im web fand ich dies:

Code: Select all

if !eq{$sender_ident}{fetchmail}
Es wurde da in einer Exim ACL Config verwendet, ich muss mal testen ob ich das auch kurzerhand dort einbauen kann, meine Kurztests vorhin verliefen aber nicht erfolgreich.

Danke und Gruß

Andre

hotzi
Posts: 197
Joined: 2004-04-14 09:04
Location: Bayern, Sulzemoos

Re: Kein Spamassassin bei lokalen SMTP Connects.

Post by hotzi » 2005-05-27 21:31

dodolin wrote:
Hat hier jemand eine Idee, wo ich bei der Fehlersuche ansetzen könnte?
Weiterhin wundert mich, wie man mit SAExim noch Amavis benoetigen kann und wie das noch sinnig zusammenspielt?
Ich verwende Amavis als Virenscanner, SAExim hatte ich vorher schon drin, da dies bisher gut funzte, sah ich bisher keine Veranlassung, dies zu ändern. Ich kann den SA aber wohl auch per Amavis einbinden...

hotzi
Posts: 197
Joined: 2004-04-14 09:04
Location: Bayern, Sulzemoos

Re: Kein Spamassassin bei lokalen SMTP Connects.

Post by hotzi » 2005-05-27 22:24

Hm,

ich habe nunmal SA Exim ausgeschaltet und die SA Integration von Amavis benutzt, leider geht damit kein Body Rewriting, daher unbrauchbar für mich :(

Gruß

Andre