Downgrade Suse 9.2 --> 8.1

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
chulian
Posts: 4
Joined: 2005-03-21 13:54

Downgrade Suse 9.2 --> 8.1

Post by chulian » 2005-03-21 14:00

Hallo Zusammen,

folgendes Problem... Ich habe einen Root-Server bei Schlund angemietet. Standardmäßig ist ein Suse 9.2 vorinstalliert. Aufgrund von spez. Softwareanforderungen muss auf dem Server ein Suse 8.1 laufen.

Ich bin nach ersten Gesprächen mit Schlund davon ausgegangen, dass Sie mir ein rudimentäres 8.1 mit ssh zur aufspielen können. Heute hat sich herausgestellt, dass dies scheinbar nicht mehr möglich ist.

Welche Möglichkeiten habe ich hier jetzt noch per remote ein 8.1 aufzuspielen. Gibt es hier irgendwelche Tips bzw. Anleitungen?

Viele Grüße
chulian

yt
Posts: 103
Joined: 2003-10-13 23:04
Location: Duisburg

Re: Downgrade Suse 9.2 --> 8.1

Post by yt » 2005-03-21 14:05

Dir ist bewusst, dass SuSE seit Februar keine Sicherheits-Updates mehr für SuSE 8.1 bereitstellt?

chulian
Posts: 4
Joined: 2005-03-21 13:54

Re: Downgrade Suse 9.2 --> 8.1

Post by chulian » 2005-03-21 14:15

ja... ist mir eben auch aufgefallen. werde es wohl dann erstmal mit 8.2 versuchen. Höher geht leider nicht. Aber wie gesagt, kann mir einer einen Tip geben, wie ich ein 8.x aufspielen kann.

chulian

lufthansen
Posts: 390
Joined: 2002-09-24 17:31
Location: NRW

Re: Downgrade Suse 9.2 --> 8.1

Post by lufthansen » 2005-03-21 14:25

hmm ich würde ehrlich gesagt eher gucken mit welchen Programm versionen du probs hast und dann vllt lieber ne alte php version einspielen als ein 'komplettes' sys auf so einer unsicheren schiene laufen zulassen.

Weshalb genau brauchst du den suse 8 ?

mc5000
Posts: 308
Joined: 2004-06-17 11:56
Location: Köln

tauschen?

Post by mc5000 » 2005-03-21 14:31

wir können ja tauschen - ich hab noch eine Maschine mit 8.1 am laufen - wollte es jetzt über ostern upgraden ... :lol:

aber scherz beiseite - kann du keine 8.1 auf die maschine schieben und per recoverykonsole installieren?

brauchst du das gesamte 8.x oder nur spezielle komponenten?

gruß
MC

chulian
Posts: 4
Joined: 2005-03-21 13:54

Re: Downgrade Suse 9.2 --> 8.1

Post by chulian » 2005-03-21 14:33

bei mir dreht es sich um das Media-Asset-Managementsystem Cumulus 6 von Canto. Das Teil läuft nur auf 8.x u. da gibt´s leider nicht viel zu ändern ausser ein Update für 2000euro zu kaufen, das ich eigentlich nicht brauche.

daher muss halt ein 8.x her... nervt mich auch an.

gruß
chulian

lufthansen
Posts: 390
Joined: 2002-09-24 17:31
Location: NRW

Re: Downgrade Suse 9.2 --> 8.1

Post by lufthansen » 2005-03-21 14:36

sagt aber nichts darüber aus ob es jetzt ne alte php braucht oder irgendwas anderes altes ...

User avatar
Joe User
Project Manager
Project Manager
Posts: 11583
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Downgrade Suse 9.2 --> 8.1

Post by Joe User » 2005-03-21 14:42

Ein Downgrade ist Deinem Fall (Kosten->Nutzen) nicht möglich, da beide Distributionen auf unterschiedlichen glibc-Versionen, welche inkompatibel zueinander sind, aufbauen. Entweder Du passt die betroffene Software an die neue Umgebung an, oder Du packst sie in ein minimalistisches Jail/VM.

Welche Anforderungen hat die Software denn?
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

chulian
Posts: 4
Joined: 2005-03-21 13:54

Re: Downgrade Suse 9.2 --> 8.1

Post by chulian » 2005-03-21 14:45

hmm...

habe jetzt leider die Mail von canto nicht zur Hand. Aber wie ich mich erinnern kann liegt das an einer Multithreading Library (libpthread). Habe leider hier auch kein Detailwissen. Derzeit läuft das alles auf einem Debian und macht halt zicken.

Gruß

User avatar
Joe User
Project Manager
Project Manager
Posts: 11583
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Downgrade Suse 9.2 --> 8.1

Post by Joe User » 2005-03-21 15:00

OK, ich habe mir mal die Herstellerseite angesehen und vermute an Hand der Systemanforderungen für 6.5, dass 6.0 die glibc-2.2 benötigt. Da alle aktuellen Distributionen die glibc-2.3 verwenden, bleiben Dir letztendlich nur zwei Optionen: Debian 3.0 oder Cumulus 6.5
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

Anonymous

Re: Downgrade Suse 9.2 --> 8.1

Post by Anonymous » 2005-03-22 11:21

hallo zusammen,

nach weiteren recherchen ist ein downgrade des root-servers von suse 9.2 auf suse 8.2 leider unbedingt nötig.

es gibt 2 Möglichkeiten um sich auf dem server einzuloggen:
- rescue-system (linux im RAM)
- serielle konsole

wie kann man ein linux suse OS downgrade durchführen?

anleitungen die ich hierzu gefunden habe beziehen sich auf die installationen eines debian linux, als hilfstool dient hierbei debootstrap. das kann ich aber für ne suse-installatione nicht gebrauchen, oder!?

für tips immer dankbar,

jens & chulian

lufthansen
Posts: 390
Joined: 2002-09-24 17:31
Location: NRW

Re: Downgrade Suse 9.2 --> 8.1

Post by lufthansen » 2005-03-22 11:30

hmmm mal eine ganz blöde frage ..
du kannst doch bei yast die quellen angeben oder ?
da steht doch jetzt z.B. ftp.suse.de/pub/suse/9.1
was passiert denn wenn du ihm die quellen von nem 8'er suse gibst ?

User avatar
Joe User
Project Manager
Project Manager
Posts: 11583
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Downgrade Suse 9.2 --> 8.1

Post by Joe User » 2005-03-22 12:16

LuftHansen wrote:hmmm mal eine ganz blöde frage ..
du kannst doch bei yast die quellen angeben oder ?
da steht doch jetzt z.B. ftp.suse.de/pub/suse/9.1
was passiert denn wenn du ihm die quellen von nem 8'er suse gibst ?
http://www.rootforum.org/forum/viewtop ... 674#218674
http://www.rootforum.org/forum/viewtop ... 679#218679
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.