reverse lookup abschalten

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
raid
Posts: 119
Joined: 2003-08-01 09:32

reverse lookup abschalten

Post by raid » 2005-03-18 09:20

Hallo,

habe ein kleines Problem mit meinem Server.
Jede Nacht bekomme ich vom Monitoring Meldung das 2:23 Uhr bis 2:28 Uhr der POP3 Dienst nicht erreichbar ist. Nun bin ich dahiner gekommen das es mit dem reverse lookup zusammenhängt, da Nachts um die Zeit immer die Nameserver nicht gehen kann er alle die um die Zeit Mails abrufen nicht rückwärt auflösen und bockt somit rum.

Bei mir läuft SuSE 8.2 und als POP3 Server qpopper über xinetd und ich suche nun schon Tagen nach einer Lösung wie ich dieses reverse lookup abschalte beim POP3. Als MTA rennt die aktuelle Postfix-Version, aber ich denke das hat nicht viel damit zu tun, oder?

meine xinetd.conf:
#
# xinetd.conf
#
# Copyright (c) 1998-2001 SuSE GmbH Nuernberg, Germany.
# Copyright (c) 2002 SuSE Linux AG, Nuernberg, Germany.
#

defaults
{
log_type = FILE /var/log/xinetd.log
log_on_success = HOST EXIT DURATION
log_on_failure = HOST ATTEMPT
# only_from = localhost
instances = 30
cps = 50 10

#
# The specification of an interface is interesting, if we are on a firewall.
# For example, if you only want to provide services from an internal
# network interface, you may specify your internal interfaces IP-Address.
#
# interface = 127.0.0.1

}

includedir /etc/xinetd.d


meine /etc/xinetd.d/qpopper
#
# qpopper - pop3 mail daemon
#
service pop3
{
disable = no
socket_type = stream
protocol = tcp
wait = no
user = root
server = /usr/sbin/popper
server_args = -c -s -R -C
flags = IPv4
}

wobei das "server_args = -c -s -R -C" im Originalzustand "server_args = -s" war.


Ich habe schon einige Manuals durchblätter "man popper" sagt man soll es mit dem Argument -R starten aber das scheint nicht zu klappen.
Das schließe ich daraus das in /var/log/warn immernoch die tausend nervenden Einträge von wegen "host XXXXXX verification failed - host not found" zu finden sind. Der Host XXXXXX ist der Server von ServerGuard also dem Monitoring.

Wenn jemand einen Tip hat wie ich das endgültig abschalten kann wäre ich dankbar, ich bin da irgendwie in einer Sackgasse momentan ...

Was mir noch aufgefallen ist wenn ich xinetd neu starte, dann meldet er immer in/var/log/warn "(init_services) no services. Exiting ..."

kawfy
Posts: 307
Joined: 2002-08-08 23:45

Re: reverse lookup abschalten

Post by kawfy » 2005-03-19 15:21

Raid wrote:da Nachts um die Zeit immer die Nameserver nicht gehen
[...]
in /var/log/warn immernoch die tausend nervenden Einträge von wegen "host XXXXXX verification failed - host not found" zu finden sind. Der Host XXXXXX ist der Server von ServerGuard also dem Monitoring.
:!: dass beide Nameserver, die dein Server für's resolving benutzt, regelmäßig kaputt sind, ist kein guter Zustand. Kannst du daran etwas ändern -- oder liegt hier ein Missverständnis vor?

raid
Posts: 119
Joined: 2003-08-01 09:32

Re: reverse lookup abschalten

Post by raid » 2005-03-19 19:16

... leider kein mißverständniss auf mich reagieren die nicht, da hilft wo nur noch kündigen oder den anwalt mal einschalten.

wie kann man denn mal testen ob er rückwärts die adresse auflöst beim abrufen?