courierpop3login: LOGIN FAILED | vexim

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
hever
Posts: 74
Joined: 2003-09-14 15:23
Location: Münster

courierpop3login: LOGIN FAILED | vexim

Post by hever » 2005-03-16 10:00

Hallo zusammen,

Ich habe meinen Mailserver exim4 weitestgehend nach euerm HowTo eingerichtet:
http://www.debianhowto.de/howtos/de/exim4-vexim-sarge/

Mein Problem:
Ich kann mich nicht am Server mittels POP3 anmelden.

Im syslog und mail.err log steht diese Meldung:
Mar 16 09:40:33 xxx courierpop3login: LOGIN FAILED, ip=[::ffff:x.x.x.x]
Ich habe etwas recherchiert und gelesen, dass diese Meldung eigentlich nur bei einem falschen Passwort kommen sollte. Ich habe den Benutzer aber über vmail angelegt und er kann auch emails empfangen und sich bei vexim anmelden. courier ist konfiguert über die vexim Datenbank zu authentifizieren.

Hat vielleicht jemand von euch eine Idee woran es liegen könnte, das ich mich nicht einloggen kann?

Danke im Vorraus
Philipp

hever
Posts: 74
Joined: 2003-09-14 15:23
Location: Münster

Re: courierpop3login: LOGIN FAILED | vexim

Post by hever » 2005-03-16 11:26

Ohh mein Gott....
Es hat alles funktioniert, ich habe mich jedoch immer über telnet (und auch den Email Clients) falsch connected.

Man muss sich mit username@domain.tld anmelden und nicht einfach nur mit dem usernamen.

Jetzt klappt alles...
(Vorschnell gepostet, aber evtl doch hilfreich, denn beim googeln hab ich sehr oft von meiner Problemstellung gelesen, evtl könnt Ihr auch einen Hinweis ins Howto machen?!)

schlunzi
Posts: 8
Joined: 2005-03-28 01:50
Location: Warstein-Niederbergheim

Re: courierpop3login: LOGIN FAILED | vexim

Post by schlunzi » 2005-03-28 02:05

Hallo und guten morgen erst mal.

also ich habe noch das Problem, das die User keine Email abrufen oder verschicken können.

Ich hab es mit user@domain.org und nur mit dem user namen probiert, es klappt nicht.

die user sind via vexim angelegt eine verbindung via telnet funzt auch, nur mit nem mail client (evultion oder thunderbird) klappt es nicht.

ich erhalte immer die fehlermeldung das das Passwort nicht richtig sei, obwohl ich es mehrfach neu eingegeben habe und auch schon neu gesetzt habe.

alles was ich hier, oder in anderen foren gefunden habe, hab ich getestet, aber es will einfach nicht klappen.

MFG

Christian

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: courierpop3login: LOGIN FAILED | vexim

Post by dodolin » 2005-03-28 09:23

die user sind via vexim angelegt eine verbindung via telnet funzt auch
Was? SMTP oder POP3 oder beides?
Auch mit Login/Authentifikation?
Was sagen denn die Logfiles dazu?

schlunzi
Posts: 8
Joined: 2005-03-28 01:50
Location: Warstein-Niederbergheim

Re: courierpop3login: LOGIN FAILED | vexim

Post by schlunzi » 2005-03-28 10:13

sowohl pop3 als auch smtp verweigern mir den zugriff auf den server.

in den logs steht folgendes:
Mar 27 07:01:18 asgard sm-msp-queue[13410]: j2QA12ti011356: to=postmaster, delay=19:00:16, xdelay=00:00:00, mailer=relay, pri=5163181, relay=[127.0.0.1] [127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]
Mar 27 07:01:18 asgard sm-msp-queue[13410]: j2Q9f2mc011333: to=root, delay=19:20:16, xdelay=00:00:00, mailer=relay, pri=5251639, relay=[127.0.0.1] [127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]
Mar 27 07:01:18 asgard sm-msp-queue[13410]: j2Q5f8iJ010987: to=root, delay=23:20:09, xdelay=00:00:00, mailer=relay, pri=6331639, relay=[127.0.0.1] [127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]
Mar 27 07:01:18 asgard sm-msp-queue[13410]: j2Q5QZR9010955: to=root, ctladdr=root (0/0), delay=23:34:43, xdelay=00:00:00, mailer=relay, pri=6420370, relay=[127.0.0.1] [127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]
Mar 27 07:01:18 asgard sm-msp-queue[13410]: j2P9f8ED003986: to=root, delay=1+19:20:10, xdelay=00:00:00, mailer=relay, pri=11731639, relay=[127.0.0.1] [127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]
Mar 27 07:01:18 asgard sm-msp-queue[13410]: j2P5QIae003610: to=root, ctladdr=root (0/0), delay=1+23:35:00, xdelay=00:00:00, mailer=relay, pri=12900370, relay=[127.0.0.1] [127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]
Mar 27 07:01:18 asgard sm-msp-queue[13410]: j2OA132G000412: to=postmaster, delay=2+19:00:15, xdelay=00:00:00, mailer=relay, pri=18123181, relay=[127.0.0.1] [127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]
Mar 27 07:01:18 asgard sm-msp-queue[13410]: j2O9f4JH000391: to=root, delay=2+19:20:14, xdelay=00:00:00, mailer=relay, pri=18211639, relay=[127.0.0.1] [127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]
Mar 27 07:01:18 asgard sm-msp-queue[13410]: j2O5f5aX032512: to=root, delay=2+23:20:13, xdelay=00:00:00, mailer=relay, pri=19291639, relay=[127.0.0.1] [127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]
Mar 27 07:01:18 asgard sm-msp-queue[13410]: j2O5QCMM032482: to=root, ctladdr=root (0/0), delay=2+23:35:06, xdelay=00:00:00, mailer=relay, pri=19380370, relay=[127.0.0.1] [127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]
Mar 27 07:01:18 asgard sm-msp-queue[13410]: j2N9f1Ve030614: to=root, delay=3+19:20:17, xdelay=00:00:00, mailer=relay, pri=24691639, relay=[127.0.0.1] [127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]
Mar 27 07:01:18 asgard sm-msp-queue[13410]: j2N5Q9RU030238: to=root, ctladdr=root (0/0), delay=3+23:35:09, xdelay=00:00:00, mailer=relay, pri=25860370, relay=[127.0.0.1] [127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]
Mar 27 07:01:18 asgard sm-msp-queue[13410]: j2M9f2Qs028412: to=root, delay=4+19:20:16, xdelay=00:00:00, mailer=relay, pri=31171639, relay=[127.0.0.1] [127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]
Mar 27 07:01:18 asgard sm-msp-queue[13410]: j2M5QBDQ028036: to=root, ctladdr=root (0/0), delay=4+23:35:07, xdelay=00:00:00, mailer=relay, pri=32340370, relay=[127.0.0.1] [127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: courierpop3login: LOGIN FAILED | vexim

Post by dodolin » 2005-03-28 13:27

Also 1. sieht mir der Log sehr nach Postfix oder Sendmail aus, eher weniger nach Exim. 2. hast du ein Sandwitch-Setup, bei dem dein MTA versucht, die Mail an eine 2. Instanz, einen Virenscanner, Amavis o.ä. weiterzugeben. So ein Setup ist im Debianhowto meines Wissens nach nicht beschrieben.

Du solltest also mal schauen, an was dein MTA die Mails weitergeben will und warum das nicht funktioniert. Läuft dieser andere Prozess überhaupt, usw.?