Swap wird nicht genutzt

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
ghost48
Posts: 29
Joined: 2004-02-20 12:18

Swap wird nicht genutzt

Post by ghost48 » 2005-03-10 16:38

Hallo,

seitdem einer unserer Server einen Hardwarewechsel hinter sich hat, scheint er performancemäßig ein wenig hinterher zu sein. Wir haben natürlich auf bessere Hardware gewechselt.

Specs:
3 GHz XEON
1024 MB RAM
2 x SATA 80 GB Festplatten im RAID 1 Verbund

Ich habe schon seit längerem den Swap im Verdacht. Speichermäßig bewegt sich der Server im oberen Bereich. Aber der Swap scheint nie genutzt zu werden. Bei anderen Servern sehe ich zumindestens ein wenig "swapping".

Top Auszug:
16:31:50 up 11:59, 1 user, load average: 0.04, 0.08, 0.03
175 processes: 172 sleeping, 1 running, 2 zombie, 0 stopped
CPU states: 1.0% user, 0.6% system, 0.0% nice, 98.4% idle
Mem: 1032064K total, 949860K used, 82204K free, 94336K buffers
Swap: 2097136K total, 0K used, 2097136K free, 394036K cached

PID USER PRI NI SIZE RSS SHARE STAT %CPU %MEM TIME COMMAND
562 mail 9 0 36556 35M 11120 S 0.0 3.5 0:21 spamd
566 mail 9 0 35584 34M 11008 S 0.0 3.4 0:20 spamd
563 mail 9 0 34840 34M 11004 S 0.0 3.3 0:24 spamd
568 mail 9 0 34756 33M 11252 S 0.0 3.3 0:20 spamd
569 mail 9 0 34436 33M 10964 S 0.0 3.3 0:21 spamd
567 mail 9 0 34080 33M 11328 S 0.0 3.3 0:21 spamd
565 mail 9 0 34032 33M 11300 S 0.0 3.2 0:20 spamd
561 mail 9 0 33692 32M 11204 S 0.0 3.2 0:21 spamd
570 mail 9 0 33192 32M 11356 S 0.0 3.2 0:17 spamd
564 mail 9 0 33028 32M 11296 S 0.0 3.2 0:20 spamd
231 mail 9 0 24800 24M 11436 S 0.0 2.4 0:00 spamd
32427 www-data 9 0 10604 10M 7592 S 0.0 1.0 0:00 apache
735 www-data 9 0 10260 10M 7152 S 0.0 0.9 0:00 apache
....
Man sieht das der spamd Daemon ein Menge Speicher frisst. Wir arbeiten mit spamd/spamc. Aus Postfix werden die Mails per Procmail an spamc geleitet.
Daraufhin ist uns auch der Performanceeinbruch aufgefallen. Bei sehr hoher Maillast bearbeitet er die Mails nicht mehr korrekt und bounced die Emails. Das hat das System auf der alten Hardware mit langsamerer CPU und weniger Speicher selbst unter Last nie gemacht.

Wie kann man prüfen ob das System den Swap jemals benutzt?

Besten Dank im voraus.

Timo

moe``
Posts: 12
Joined: 2004-02-25 15:33
Location: Siegen

Re: Swap wird nicht genutzt

Post by moe`` » 2005-03-10 18:28

sei froh wenn er ihn nich nutzen muss :>