nach reinit werden keine mails mehr empfangen

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
unique
Posts: 40
Joined: 2003-03-24 20:05

nach reinit werden keine mails mehr empfangen

Post by unique » 2005-02-25 13:30

hallo zusammen,

habe gestern ein reinit meines servers durchführen müssen. jetzt läuft ein großteil wieder wie es soll, allerdings lassen sich keine mails mehr empfangen.
mails versenden geht problemlos, wenn ich allerdings von aussen eine mail an ein postfach des servers schicke kommt diese zurück.

folgendes steht im log:

Code: Select all

Feb 25 12:31:28 xxxxxxxx postfix/smtpd[8892]: NOQUEUE: reject: RCPT from mail.xxxxxxxxxxxx.de[217.9.41.xxx]: 554 <info@xxx.de>: Relay access denied; from=<xxx@xxx.de> to=<info@xxx.de> proto=ESMTP helo=<mail.xxxxxxxxxxxx.de>
das postfach für die zieladresse ist definitiv vorhanden.
auch von anderen account konnten keine mails an irgendein postfach auf diesem server verschickt werden. alle kamen wieder zurück.
auch innerhalb des servers kommen die mails zurück.

postconf -n sagt:

Code: Select all

alias_maps = hash:/etc/aliases
broken_sasl_auth_clients = yes
canonical_maps = hash:/etc/postfix/canonical
command_directory = /usr/sbin
config_directory = /etc/postfix
content_filter =
daemon_directory = /usr/lib/postfix
debug_peer_level = 2
default_privs = autoresponder
defer_transports =
disable_dns_lookups = no
inet_interfaces = all
mail_owner = postfix
mail_spool_directory = /var/mail
mailbox_command = /usr/bin/procmail
mailbox_size_limit = 0
mailbox_transport =
mailq_path = /usr/bin/mailq
manpage_directory = /usr/share/man
masquerade_classes = envelope_sender, header_sender, header_recipient
masquerade_domains =
masquerade_exceptions = root
message_size_limit = 20480000
mydestination = $myhostname, localhost.$mydomain
myhostname = xxxx.com
newaliases_path = /usr/bin/newaliases
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/packages/postfix/README_FILES
relayhost =
relocated_maps = hash:/etc/postfix/relocated
sample_directory = /usr/share/doc/packages/postfix/samples
sender_canonical_maps = hash:/etc/postfix/sender_canonical
sendmail_path = /usr/sbin/sendmail
setgid_group = maildrop
smtp_use_tls = no
smtpd_client_restrictions =
smtpd_helo_required = no
smtpd_helo_restrictions =
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_tls_CAfile = /etc/ssl/certs/p15xxxxx.pureserver.info-sample-ca.crt
smtpd_tls_cert_file = /etc/postfix/cert.pem
smtpd_tls_key_file = /etc/postfix/key.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
smtpd_use_tls = yes
strict_rfc821_envelopes = no
tls_random_source = dev:/dev/urandom
transport_maps = hash:/etc/postfix/transport
unknown_local_recipient_reject_code = 450

der eintrag für die virtual_maps ist auch drin:

Code: Select all

virtual_maps = hash:/etc/postfix/virtual, hash:/etc/postfix/confixx_virtualUsers, hash:/etc/postfix/confixx_localDomains
in diesen dateien sind auch die richtigen zuordnungen von adresse zu postfach.

ich hab schon vieles hier gelesen, die meisten hatten allerdings probleme beim mails versenden - und das geht bei mir prima...

ich hoffe, mir kann jemand helfen...

gruss

unique

unique
Posts: 40
Joined: 2003-03-24 20:05

Re: nach reinit werden keine mails mehr empfangen

Post by unique » 2005-02-25 13:45

ok - neuer status... die mails kommen jetzt an...

warum - weiss nur mein server allein, denn ich hab seit dem letzten test vor ner halben stunde nichts geänder - und jetzt gehts plötzlich - zumindest so halbwegs...
zuerst wurden alle mails ins erste postfach web0p1 geleitet... dann hab ich in confixx die catchall-adresse entfernt und seit dem gehts....
die catchall ist allerdings nicht ganz unwichtig, deshalb wäre es schön, wenn mir jemand des fehler erklären könnte und mir sagen, wie ich die catchall zum laufen bringe ohne dabei den rest wieder kaputtzumachen...

gruss

unique

unique
Posts: 40
Joined: 2003-03-24 20:05

Re: nach reinit werden keine mails mehr empfangen

Post by unique » 2005-02-25 14:14

so - dieser thread hat sich soeben in ein logikwölkchen aufgelöst...
der fehler mit der catchall-adresse ist hier beschrieben:
http://www.rootforum.org/forum/viewto ... n+catchall
das ursprüngliche problem hat sich ja irgendwie auch selbst aus der welt geschafft...
erinnert irgendwie an selbstgespräche dieser thread...

falls irgendjemand eine erklärung für den fehler hat, bin ich natürlich sehr interressiert dran - ausserdem kann er ja nicht einfach verschwinden, also wäre es schon interessant zu erfahren, was da eigentlich grad passiert ist...

wgot
RSAC
Posts: 1707
Joined: 2003-07-06 02:03

Re: nach reinit werden keine mails mehr empfangen

Post by wgot » 2005-02-25 16:16

Hallo,
unique wrote: mydestination = $myhostname, localhost.$mydomain
myhostname = xxxx.com
wenn "ihr" euch endlich mal dieses dämliche xxxx abgewöhnen könntet, da hat "man" schon gar keine Lust zu fragen ob das nun für eine Domain oder Subdomain steht.

Emailadressen @myhostname landen im falschen Postfach und ein Catchall@myhostname fängt alles ein, hat mit der internen Verarbeitung zu tun.

myhostname=mx.example.org (statt example.org eigene Domain einsetzen) und keine Emailadressen (vor allem keinen Catchall :oops: ) unter mx.example.org einrichten.

Gruß, Wolfgang

unique
Posts: 40
Joined: 2003-03-24 20:05

Re: nach reinit werden keine mails mehr empfangen

Post by unique » 2005-02-25 16:54

das stand ja auch im link des vorigen postings...

mich würde nur interessieren, warum erstmal überhaupt keine mails angenommen wurden...