server startet nicht mehr...

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
unique
Posts: 40
Joined: 2003-03-24 20:05

server startet nicht mehr...

Post by unique »

hallo zusammen,

ich hatte ja gehofft, so etwas nie poste zu müssen, aber ich hab da wohl etwas richtig verbockt... :?
ich hab gestern aus versehn rechte in den systemordnern /dev /boot und /etc geändert. anschließend konnte ich mich nicht mehr per ssh einloggen -> "connection refused". hab das system im rescue-modus gestartet und vom letzten backup (1 tag vorher) diese verzeichnise komplett kopiert, um die alten rechte wiederherzustellen. danach kam die kiste gar nicht mehr hoch - ich weiss nur leider nicht warum. das logfile boot.msg wurde angeblich im märz 2004 das letzte mal gändert, es ist also nicht anzunehmen, dass dort was interessantes drinsteht...

und das schönste kam erst noch - ich hab versucht mich über die serielle konsole einzuloggen, bei der allerdings nur folgende meldung kam:

Code: Select all

login as: u3xxxxxxx
u3xxxxxxx@sercon.pureserver.info's password:
Trying 172.19.42.85...
Escape character is '^]'.
danach passierte gar nichts mehr und im moment kann ich den server noch nichtmal im recuemode starten, da bei 1&1 im controlcenter folgende meldung kommt:

Code: Select all

Zur Zeit läuft gerade eine Aktion. Daher können Sie auf Ihrem Server im Moment keine Veränderungen vornehmen.
jetzt bin ich völlig am ende :cry:

bin wirklich für jedem konstruktiven vorschlag dankbar...

es wäre auch nett, wenn ihr euch sprüche wie - kauf die lieber einen gameboy zum spielen - verkneifen könntet... is mir schon peinlich genug die ganze sache....

schonmal dank im vorraus

gruss

unique

unique
Posts: 40
Joined: 2003-03-24 20:05

Re: server startet nicht mehr...

Post by unique »

so - hab mich jetzt für neuinitialisierung entschieden...

der kollege vom support meinte, dass es reicht, das /home und /var verzeichnis nach der initialisierung zurückzukopieren... die ganzen user und passwörter stehen doch aber in der passwd und shadow im verzeichnis /etc usw...
ich werd auf jeden fall das ganze verzeichnis sichern, aber ein paar tips, welche dateien man hinterher zurückspielen sollte bzw. welche auf gar keinen fall wären ganz hilfreich. kann man z.b. die passwd und shadow einfach reinkopieren und die user sind wieder am start oder zerschieß ich mir dann gleich wieder das neue system? welche sind noch wichtig, um den alten zustand wiederherzustellen - zb für die mail-accounts...

sicher gibts da kein patentrezept und kopieren und fertig wird auch nicht funktionieren, aber ein paar nützliche tips fänd ich ganz hilfreich, um den aufwand zu reduzieren..

gruss

unique

oldwebber
Posts: 43
Joined: 2004-02-24 14:29
Location: Kronach

Re: server startet nicht mehr...

Post by oldwebber »

das ging aber recht schnell kann ja wohl nichts wichtiges drauf gewesen sein :x .
hat bei mir vor ca. 1 woche auch ziemlich lang gedauert.
kurzer anruf bei 1&1 und nach 15 min war er wieder da wie aus dem nichts.
hab festgestellt das der reset wohl sit einiger zeit hängen bleibt oder sehr lange dauert.
gruß jesse

unique
Posts: 40
Joined: 2003-03-24 20:05

Re: server startet nicht mehr...

Post by unique »

da ist schon einiges wichtiges drauf - genau aus dem grund muss der server ja auch schnell wieder laufen... das ist wohl mit einem reinit schneller gemacht, als noch ne nacht erfolglos rumzubasteln...
der 1&1 support hat mir das ebenfalls empfohlen..

das problem mit der seriellen konsole war nur ein bug im 1&1 kundencenter - nach dem aus- und wieder einloggen konnte ich den server wieder reseten...

jetzt hab ich nur die mühsame arbeit vor mir, die daten alle wieder herzustellen... wird wohl ne lange nacht...

wie gesagt - ich bin für brauchbare tips sehr dankbar, was den reimport der daten angeht... besonders macht mir confixx sowie die mail-accounts sorgen..

wenn jemand erfahrung hat, wie man die ganzen benutzer und ihre mailaccounts wieder ins system kriegt und wie man confixx schnell wieder zum laufen bringt, wäre das eine sehr grosse hilfe, da der server möglichst heute nacht noch wieder funktionstüchtig sein muss...

gruss

unique

wicht
Posts: 4
Joined: 2005-02-13 18:51

Re: server startet nicht mehr...

Post by wicht »

hast du auch die mysql gesichert, ich hoffe doch

weil in der confixxmysql sind die user gespeichert u.v.m.


wenn diese wieder aufspielst könnte es keine probs geben.

mfg

unique
Posts: 40
Joined: 2003-03-24 20:05

Re: server startet nicht mehr...

Post by unique »

die mysql hab ich - allerdings nur als dateien, nicht als sql-dump... einen sql-dump konnte ich nicht mehr machen, nachdem das system im ar*** war... aber das sollte ja eingentlich trotzdem funktionieren...

liest confixx dann daten aus der db und legt die fehlenden benutzer im system an?

wgot
Posts: 1675
Joined: 2003-07-06 02:03

Re: server startet nicht mehr...

Post by wgot »

Hallo,

mache eine Komplettsicherung, brauchst (und solltest) nicht alles zurückspielen, aber es ist alles da. MysqlDump nicht vergessen (kann im Rescue gemacht werden). Confixx legt die User wieder an wenn Du ein paarmal das Counterscript laufen läßt.

Ich würde nicht so schnell aufgeben und die Kiste reparieren.

Gruß, Wolfgang

unique
Posts: 40
Joined: 2003-03-24 20:05

Re: server startet nicht mehr...

Post by unique »

für den dump wars leider schon zu spät... das reinit war schon am laufen...
hab jetzt aber alles wieder auf dem alten stand - es funktiniert auch, wenn man die dateien direkt nach /var/lib/mysql kopiert - is zwar nich die feine art, aber naja...

puh - grad nochmal gutgegangen.... so´n regelmäßiges backup hat schon was für sich...

ich hab mich so an diesen tips orientiert:

http://www.rootforum.org/forum/viewtopi ... alisierung

...und zum glück auch keine größeren probleme gehabt...

Outlaw
Posts: 1500
Joined: 2002-12-04 10:22
Location: 4. Server von rechts, 2. Reihe von oben

Re: server startet nicht mehr...

Post by Outlaw »

Nunja, vielleicht hätte es gereicht, einfach mal "die Aktion" abzuwartn oder zu fragen, was diese Aktion genau bedeutet.

Zu

"der 1&1 support hat mir das ebenfalls empfohlen.."

sag ich jetzt mal nix .... ;):D

Gruß Outi