HTML Mails kommen nicht korrekt an

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
moondancer2
Posts: 4
Joined: 2004-09-21 11:06

HTML Mails kommen nicht korrekt an

Post by moondancer2 » 2005-02-22 15:47

Hallo,

ich habe ein Shopsystem laufen (GS-Shop). Wenn nun hier eine Bestellbestätigung im HTML-Format abgeschickt wird, so kommt Sie auf meinem web.de - Account korrekt an. Rufe ich sie jedoch mit einer Emailadresse ab, welche auf dem selben Server wie der Shop eingerichtet ist, so wird die Mail nur im Textformat dargestellt inkl. HTML-Header.
Woran kann das liegen? Auf dem Server läuft Postfix.

Also es sieht so aus als ob die Mail vor der Auslieferung nochmal konvertiert wird - beim web.de-Account passiert das nicht...

Viele Grüße
Christian

rkaerner
Posts: 13
Joined: 2003-10-18 02:51

Re: HTML Mails kommen nicht korrekt an

Post by rkaerner » 2005-03-02 07:13

Headerzeilen vollständig? Einstellungen Deines Mailclients (falls Du die Dinger nicht im confixx oder sowas anguckst)?

moondancer2
Posts: 4
Joined: 2004-09-21 11:06

Re: HTML Mails kommen nicht korrekt an

Post by moondancer2 » 2005-03-03 10:05

also das Problem tritt bei Verwendung des PHP mail() Befehls auf.
So wie es ausschaut erfolgt eine nachträgliche Konvertierung der Headerzeilen durch den Mailserver.
Ab der Zeile "MIME-Version: 1.0" sind zusätzliche Leerzeilen eingefügt und somit verschiebt sich einiges...
Hatte das Problem schonmal jemand? Kann das an den Postfix-Einstellungen liegen?

Viele Grüße
Christian

willi
Posts: 24
Joined: 2004-10-26 10:28

Re: HTML Mails kommen nicht korrekt an

Post by willi » 2005-03-04 12:57

Vielleicht fügt dein Mailprogramm (lokal zuhause) diese Zeilen ein Schonmal versucht mit einem anderen Programm oder PC die Mail abzuholen?