exchange 2000 server an rootie-how to?

Lesenswerte Artikel, Anleitungen und Diskussionen
scuba303
Posts: 64
Joined: 2003-01-11 01:15

exchange 2000 server an rootie-how to?

Post by scuba303 » 2005-01-25 19:47

hallo. habe einen kunden, der seinen exchange 2000 server mit an unseren rootie hängen will. bisher hat er ein sammelpostfach, wo er alle mails abruft und die dann lokal per exchange weiterverteilt. nun soll auch der mail versand über die rootie smtp engine laufen. also postfix.

bisher hat er erfolglos versucht, sich mit dem von confixx erstellten user und passwort über den smarthost smtp.meinserver.de anzumelden. dabei hat er kein ETRN/TURN gesendet.
als fehler kommt dann
Fehler bei der SMTP-Kommunikation mit dem E-Mail-Server des Empfängers. Wenden Sie sich an Ihren Systemadministrator.
<hauptserver.SEINEDOMAIN.local #5.5.0 smtp;554 <beispiel@anderaddi.de>: Relay access denied>
muss ich bei meinem postfix in der main.cf irgendwelche special destitnations oder ähnliches einstellen?

chris76
Moderator
Moderator
Posts: 2015
Joined: 2003-06-27 14:37
Location: Germering

Re: exchange 2000 server an rootie-how to?

Post by chris76 » 2005-01-25 21:33

Relay access denied.

Dein "Kunde" muß sich an deinem Server authentifizieren.
Das kann er im Exchange einstellen.
Gruß Christian

BofH excuses: YOU HAVE AN I/O ERROR -> Incompetent Operator error

scuba303
Posts: 64
Joined: 2003-01-11 01:15

Re: exchange 2000 server an rootie-how to?

Post by scuba303 » 2005-01-26 11:15

müsste doch theoretisch nach dieser anleitung funktionieren, die authentifizierung:
http://www.sbspraxis.de/exchange/ex03009/ex03009.html

chris76
Moderator
Moderator
Posts: 2015
Joined: 2003-06-27 14:37
Location: Germering

Re: exchange 2000 server an rootie-how to?

Post by chris76 » 2005-01-26 11:22

Also bei uns funktioniert das auch in der Praxis so. Auch ohne diese Anleitung :wink:
Gruß Christian

BofH excuses: YOU HAVE AN I/O ERROR -> Incompetent Operator error

pf
Posts: 20
Joined: 2003-03-15 13:15

Re: exchange 2000 server an rootie-how to?

Post by pf » 2005-02-07 21:20

Ich habe leider auch genau dieses Problem:

Im Exchange Server sind Benutzernamen und Passwort eingetragen, aber die Authentifizierung geht nicht (Fehlermeldung wie bereits beschrieben, das ganze unter SBS 2003). Das Abholen von Mail über den pop3 Konnektor funktioniert ohne Probleme - Benutzernamen und Passwort sind also richtig

Mir ist jetzt aufgefallen, dass die Meldungen im mail.log von Postfix sehr unterschiedlich sind, je nachdem, ob ich versuche über den smtp Konnektor des Exchange Servers zu verschicken oder direkt mit Outlook.

über Exchange Server:
Feb 7 20:45:19 fd1 postfix/smtpd[6657]: connect from pxxx.dip.t-dialin.net[123.456.789.123]
Feb 7 20:45:19 fd1 postfix/smtpd[6657]: NOQUEUE: reject: RCPT from pxxx.dip.t-dialin.net[123.456.789.123]: 554 <test@vodafone.de>: Relay access denied; from=<absender@absenderdomain.de> to=<test@vodafone.de> proto=ESMTP helo=<absenderdomain.de>
Feb 7 20:45:20 fd1 postfix/smtpd[6657]: disconnect from pxxx.dip.t-dialin.net[123.456.789.123]
über Outlook:
Feb 7 20:56:55 fd1 postfix/smtpd[6790]: connect from pyyy.dip.t-dialin.net[123.123.123.123]
Feb 7 20:56:56 fd1 popper[6804]: Stats: web11p2 0 0 0 0 pyyy.dip.t-dialin.net 123.123.123.123 [pop_updt.c:296]
Feb 7 20:56:56 fd1 postfix/smtpd[6790]: 60661400142: client=pyyy.dip.t-dialin.net[123.123.123.123], sasl_method=LOGI
N, sasl_username=web11p2
Feb 7 20:56:56 fd1 postfix/cleanup[6794]: 60661400142: message-id=<20050207195656.60661400142@domain.de>
Feb 7 20:56:56 fd1 postfix/qmgr[19328]: 60661400142: from=<absender@domain.de>, size=704, nrcpt=1 (queue active)
Feb 7 20:56:57 fd1 popper[6805]: Stats: web0p1 0 0 0 0 pyyy.dip.t-dialin.net 123.123.123.123 [pop_updt.c:296]
Feb 7 20:56:57 fd1 postfix/smtp[6806]: 60661400142: to=<test@vodafone.de>, relay=smtp.email.vodafone.de[139.7.28.130]
, delay=1, status=sent (250 2.5.0 Message accepted for delivery!)
Feb 7 20:56:57 fd1 postfix/qmgr[19328]: 60661400142: removed
Die Authentifizierung scheint irgendwie anders abzulaufen...

Hoffentlich hat noch jemand einen Tip für mich,

Patrick

pf
Posts: 20
Joined: 2003-03-15 13:15

Re: exchange 2000 server an rootie-how to?

Post by pf » 2005-02-08 01:43

Ich habe jetzt noch eine Ewigkeit rumprobiert und werde nicht wirklich schlauer:

- versenden über Exchange Server geht nicht (Relay access denied)
- versenden per telnet geht auch nicht: (Relay access denied) - stimmt soweit, da ich nicht weiß, wie ich hier Benutzer und Passwort eingeben kann :-)
- versenden direkt per Outlook: geht

Das Ganze immer aus demselben Netzwerk und mit demselben Account...

Zuerst dachte ich es könnte an T-Online liegen, habe dann aber auch über MSN Call by Call probiert und es geht auch nicht...

Meiner Meinug nach ist das ein Problem des Exchange Servers und ich werde mal in der Richtung weiter suchen - wenn aber doch jemand einen Tip hat, wäre ich dankbar.

Patrick

pf
Posts: 20
Joined: 2003-03-15 13:15

Re: exchange 2000 server an rootie-how to?

Post by pf » 2005-02-09 00:56

So, jetzt bin ich insofern einen Schritt weiter gekommen, dass ich eine funktionisfähige Lösung gefunden hab:

Anhand der Logfiles des Exchange Servers war zu sehen, dass dieser kein smtp-auth sendet, obwohl es im smpt Konnektor eingestellt ist.
Das Ganze hängt irgendwie mit der Domain zusmannen, die als Mailrelay angegeben ist. Ursprünglich war es wie folgt (und hat nicht funktioniert): Domain test.de ist auf meinem Rootserver gehostet als web1 und der Exchange Server sammelt über den POP3 Konnektor alles aus web1p1 ein und der smpt Konnektor sollte über web1p1 verschicken - was er eben nicht tat.
Jetzt lasse ich über eine andere Domain auf demselben Rootserver verschicken, web0p1, und es funktioniert: Der Exchange Server sendet das smtp-auth, kann sich authentifizieren und alles klappt.

Erklären kann ich mir das nur dadurch, dass der Exchange Server sich für die Domain test.de selbst zuständig fühlt und deswegen das smtp-auth nicht sendet - Feature oder Fehler?

Patrick

scuba303
Posts: 64
Joined: 2003-01-11 01:15

Re: exchange 2000 server an rootie-how to?

Post by scuba303 » 2005-02-15 19:34

cool... warum auch immer. so funktioniert es... danke..

blaǃzilla
Posts: 9
Joined: 2005-02-22 15:56
Location: Leverkusen

Re: exchange 2000 server an rootie-how to?

Post by blaǃzilla » 2005-02-23 10:29

Das ist das Problem wenn man intern, auf dem Exchange, und extern die gleiche Maildomain verwendet. In der Regel versucht der Exchange dann nämlich die Post lokal zuzustellen, da er ja für die Domain zuständig ist. Aber das ist alles nur eine Sache der Konfiguration. :)

cya
bla!zilla