postfix: server1 spricht nicht mit server2

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
waynorth
Posts: 22
Joined: 2004-04-07 11:51

postfix: server1 spricht nicht mit server2

Post by waynorth » 2005-01-02 17:10

Server a)
1und1 Root Suse 8.1, postfix wie mitgeliefert

Server b)
1und1 Root Suse 9.2, postfix wie mitgeliefert.

Habe gerade bemerkt, dass von a) an b) keine E-Mails ausgeliefert werden! Es passiert einfach nichts. in keinem log von b) passiert etwas, wenn ich von a) nach b) eine E-Mail sende. Umgekehrt funktioniert es (von b) nach a)). Auch von diversen äußeren und anderen Servern funktioniert der E-Mail versand an sowohl a) und b) sowie von a) und b) an alle bisher getesteten.

/var/log/mail von a) sagt beim Versand:
2 16:57:14 p12345678 postfix/local[27898]: C9DAB70004: to=<web99p1@p2345678.pureserver.info>, relay=local, delay=1, status=sent (mailbox)

Dennoch kommt bei b) nichts an, in den Logs passiert nichts.
Auf einer Blacklist sind weder a) noch b). Bin eher durch Zufall darauf gekommen.

Freue mich über jede Hilfe :) Danke Waynorth

squize
Userprojekt
Userprojekt
Posts: 741
Joined: 2003-05-19 16:46
Location: Karlsruhe

Re: postfix: server1 spricht nicht mit server2

Post by squize » 2005-01-02 20:43

relay=local, delay=1, status=sent (mailbox)
Soweit ich es jetzt im Kopf habe sagt das aus, dass Server a) sich selbst für die Domain zuständig hält. Du solltest also schauen, ob die Domain von Server b) eventuell nicht bei Server a) in mydestination oder der virtualdomainmap drin ist.

Gruss

Marc

waynorth
Posts: 22
Joined: 2004-04-07 11:51

Re: postfix: server1 spricht nicht mit server2

Post by waynorth » 2005-01-02 21:47

Super Tipp! Ich hatte ein Brett vorm Kopf:
Die Domain, an die es ging, war früher auf Server a). Nach dem Umzug auf Server b) wurde es zwecks "erst mal sehen ob's klappt" nicht gelöscht! Nun ist sie gelöscht und jetzt gehen natürlich auch die E-Mails raus.
Vielen Dank!