[RPM] Failed dependencies?

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
michse02
Posts: 9
Joined: 2004-09-29 19:47

[RPM] Failed dependencies?

Post by michse02 »

Guten Tag,

ich habe nun mehrfach versucht auf meinem SUSE 9.0 Server meinen Apache upzudaten. Dabei tritt allerdings immer folgender Fehler auf:

rpm -ihU *.rpm
warning: apache-1.3.31-1.i586.rpm: V3 DSA signature: NOKEY, key ID efb694ea
error: Failed dependencies:
apache_mmn_19990320_15 is needed by (installed) mod_perl-1.28-102
apache_mmn_19990320_15 is needed by (installed) authldap-1.6.0-709
apache_mmn_19990320_15 is needed by (installed) mod_php4-4.3.3-177
apache = 1.3.28 is needed by (installed) apache-devel-1.3.28-60

was kann man dagegen machen? Um den Apache doch noch upzudaten habe ich dann erst alle diese deinstaliert und dann upgedatet. Danach habe ich diese Packete wieder installiert. Jetzt kommt in Yast lediglich jedesmal ein Packetabhängigkeitsfehler da die PHP, perl und co Pakete den Apache 1.3.28 benötigen würden.

Weiterhin tritt der Fehler auch bei einem Update von PHP auf.

Kann es sein, das das Betriebssystem nicht sauber arbeitet?

Ã?ber einen Lösungsvorschlag würde ich mich sehr freuen.
duergner
Posts: 923
Joined: 2003-08-20 11:30
Location: Pittsburgh, PA, USA

Re: [RPM] Failed dependencies?

Post by duergner »

Nein das liegt an den Abhängleiten der Packete und hat mit dem OS nichst zu tun.
michse02
Posts: 9
Joined: 2004-09-29 19:47

Re: [RPM] Failed dependencies?

Post by michse02 »

ja, ok, aber warum brauchen die dann alle unbedingt den 1.3.28 ? und akzeptieren den 1.3.31 nicht? auch neuinstallationen von PHP akzeptieren den APache 1.3.31 nicht..
User avatar
Joe User
Project Manager
Project Manager
Posts: 11165
Joined: 2003-02-27 01:00
Location: Hamburg

Re: [RPM] Failed dependencies?

Post by Joe User »

Was ist an "apache = 1.3.28 is needed by (installed) apache-devel-1.3.28-60" unverständlich?
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
michse02
Posts: 9
Joined: 2004-09-29 19:47

Re: [RPM] Failed dependencies?

Post by michse02 »

ja, das hab ich ja jetzt auf 1.3.31 beides... seit dem kommt in yast jedesmla das php, perl den apache 1.3.28 benötigen. Obwohl alles läuft...

Und wenn ich versuche PHP upzudaten kommt:

Code: Select all

warning: mod_php4-4.3.9-1.i586.rpm: V3 DSA signature: NOKEY, key ID efb694ea
error: Failed dependencies:
        apache_mmn_19990320_15 is needed by mod_php4-4.3.9-1
was ist daran bitte verständlich ?
User avatar
Joe User
Project Manager
Project Manager
Posts: 11165
Joined: 2003-02-27 01:00
Location: Hamburg

Re: [RPM] Failed dependencies?

Post by Joe User »

Und für welchen Apache-Build wurde Dein PHP kompiliert? Changelog gelesen?

PS: Subject angepasst-
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
michse02
Posts: 9
Joined: 2004-09-29 19:47

Re: [RPM] Failed dependencies?

Post by michse02 »

installiert wurde es unter 1.3.28. aber ich will ja ne komplett neue rpm instalieren....