Verzweifle noch an Exim4 + Smtp Auth HILFE

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
light
Posts: 10
Joined: 2004-02-14 22:54

Verzweifle noch an Exim4 + Smtp Auth HILFE

Post by light » 2004-11-14 20:30

Ich hoffe es kann mir hier jemand helfen,
Habe folgendes Problem denke ich steh kurz davor das der Mailserver funktioniert

Hab duzende Howtos gelesen zu Mailserver unter Linux

Auf meinen Root läuft Debian Sarge.

Habe mich für die Exim4 V4.34 entschieden bekomme leider nun immer folgende Fehlermeldung:


2004-11-14 21:37:36 login authenticator failed for pd9e13f5e.dip.t-dialin.net (workstation) [217.225.63.94]: 535 Incorrect authentication data (set_id=admin)
2004-11-14 21:45:48 login authenticator failed for pd9e13f5e.dip.t-dialin.net (workstation) [217.225.63.94]: 535 Incorrect authentication data (set_id=admin)
2004-11-14 21:45:54 login authenticator failed for pd9e13f5e.dip.t-dialin.net (workstation) [217.225.63.94]: 535 Incorrect authentication data (set_id=admin)
2004-11-14 21:46:24 login authenticator failed for pd9e13f5e.dip.t-dialin.net (workstation) [217.225.63.94]: 535 Incorrect authentication data (set_id=admin)
2004-11-14 21:46:30 login authenticator failed for pd9e13f5e.dip.t-dialin.net (workstation) [217.225.63.94]: 535 Incorrect authentication data (set_id=admin)
2004-11-14 21:47:48 IPv6 socket creation failed: Address family not supported by protocol
2004-11-14 21:47:48 Failed to create IPv6 socket for wildcard listening (Address family not supported by protocol): will use IPv4
2004-11-14 21:47:48 exim 4.34 daemon started: pid=6174, -q30m, listening for SMTP on port 25 (IPv4)
2004-11-14 21:47:48 Start queue run: pid=6176
2004-11-14 21:47:48 End queue run: pid=6176
2004-11-14 21:54:01 Start queue run: pid=6185
2004-11-14 21:54:01 End queue run: pid=6185


Folgendes habe ich schon probiert.

Hab versuch das pw verschlüsselt zu übertragen

Unverschlüsselt hab ich es auch schon versucht

Nun läuft meine Auth Methode über Mysql.

Aber der fehler bleibt der gleiche.

Denke das irgentwas verpeilt habe in meiner Conf.

Nutze Split-Modus bei dem Exim.


Achso ich rufe meine Mail über Outlook 2003 ab.

Wenn ich local über den Rootserver gehe kann Mails versenden nur über Outlook nicht.
Outlook ist richtig eingestellt das nur noch zur Info.

Hoffe ihr könnt mir helfen.

Sagt mir einfach welche conf ihr braucht um euch ein Bild zu machen.


Mfg Light

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: Verzweifle noch an Exim4 + Smtp Auth HILFE

Post by Roger Wilco » 2004-11-14 20:43

light wrote:Sagt mir einfach welche conf ihr braucht um euch ein Bild zu machen.
Den Authenticators-Abschnitt der exim.conf und evtl. das SQL-Schema von der verwendeten Datenbank, in denen die Benutzer gespeichert werden.

light
Posts: 10
Joined: 2004-02-14 22:54

Re: Verzweifle noch an Exim4 + Smtp Auth HILFE

Post by light » 2004-11-14 21:04

### auth/30_exim4-config_examples
#################################

# The examples below are for server side authentication; they allow two
# styles of plain-text authentication against an CONFDIR/passwd file
# which should have user IDs in the first column and crypted passwords
# in the second. The columns need to be separated by ':'. For CRAM-MD5
# exim needs access to the UNECRYPTED passwd - the example below assumes
# it is avalable in the third column of CONFDIR/passwd

# plain_server:
# driver = plaintext
# public_name = PLAIN
# server_condition = "${if crypteq{$3}{${extract{1}{:}{${lookup{$2}lsearch{/etc/exim4/passwd.client}{$value}{*:*}}}}}{1}{0}}"
# server_set_id = $2
# server_prompts = :
#
# login_server:
# driver = plaintext
# public_name = LOGIN
# server_prompts = "Username:: : Password::"
# server_condition = "${if eq{$2}{${extract{1}{:}{${lookup{$1}lsearch{CONFDIR/passwd.client}{$value}{*:*}}}}}{1}{0}}"
# server_set_id = $

#
# cram_md5_server:
# driver = cram_md5
# public_name = CRAM-MD5
# server_secret = ${extract{2}{:}{${lookup{$1}lsearch{CONFDIR/passwd}{$value}fail}}}
# server_set_id = $1

# Here is an example of CRAM-MD5 authentication against PostgreSQL:
#
# psqldb_auth:
# driver = cram_md5
# public_name = CRAM-MD5
# server_secret = ${lookup pgsql{SELECT pw FROM users WHERE username = '${quote_pgsql:$1}'}{$value}fail}
# server_set_id = $1

# Authenticate against local passwords using sasl2-bin
#
# plain_saslauthd:
# driver = plaintext
# public_name = PLAIN
# # don't send system passwords over unencrypted connections
# server_advertise_condition = ${if eq{$tls_cipher}{}{0}{1}}
# server_condition = ${if saslauthd{{$2}{$3}}{1}{0}}
# server_set_id = $2
# server_prompts = :

##############
# See /usr/share/doc/exim4-base/README.SMTP-AUTH
##############

# These examples below are the equivalent for client side authentication.
# They get the passwords from CONFDIR/passwd.client. This file should have
# three columns separated by colons, the first contains the name of the
# mailserver to authenticate against, the second the username and the third
# contains the password.

### # example for CONFDIR/passwd.client
### mail.server:blah:secret
### # default entry:
### *:bar:foo

#cram_md5:
# driver = cram_md5
# public_name = CRAM-MD5
# client_name = ${extract{1}{:}{${lookup{$host}lsearch*{CONFDIR/passwd.client}{$value}fail}}}
# client_secret = ${extract{2}{:}{${lookup{$host}lsearch*{CONFDIR/passwd.client}{$value}fail}}}

# Because AUTH PLAIN sends the password in clear, per default we only allow it
# over encrypted connections. If you want to change this disable the existing
# "client send" entry and enable the one below without the "if !eq{$tls_cipher}{}"
# by removing the hash-mark (#) at the beginning of the line.
#plain:
# driver = plaintext
# public_name = PLAIN
# client_send = "${if !eq{$tls_cipher}{}{
# ^${extract{1}{::}
# {${lookup{$host}lsearch*{/etc/exim4/passwd.client}{$value}fail}}}
# ^${extract{2}{::}
# {${lookup{$host}lsearch*{/etc/exim4/passwd.client}{$value}fail}}}
# }fail}"
# client_send = "^${extract{1}{::}{${lookup{$host}lsearch*{CONFDIR/passwd.client}{$value}fail}}}^${extract{2}{::}{${lookup{$host}lsearch*{CONFDIR/passwd.client}{$value}fail}}}"

# Because AUTH LOGIN sends the password in clear, per default we only allow it
# over encrypted connections. If you want to change this disable the existing
# "client send" entry and enable the one below without the "if !eq{$tls_cipher}{}"
# by removing the hash-mark (#) at the beginning of the line.
#login:
# driver = plaintext
# public_name = LOGIN
# client_send = "${if !eq{$tls_cipher}{}{}fail}
# : ${extract{1}{::}
# {${lookup{$host}lsearch*{CONFDIR/passwd.client}{$value}fail}}}
# : ${extract{2}{::}
# {${lookup{$host}lsearch*{CONFDIR/passwd.client}{$value}fail}}}"
# client_send = ": ${extract{1}{::}{${lookup{$host}lsearch*{CONFDIR/passwd.client}{$value}fail}}} : ${extract{2}{::}{${lookup{$host}lsearch*{CONFDIR/passwd.client}{$value}fail}}}"

## Windows Client
#
#login:
# driver = plaintext
# public_name = LOGIN
# server_prompts = Username:: : Password::
# server_condition = ${if eq {${readsocket{/usr/local/var/authdaemon/socket}
# {AUTH ${strlen:eximnloginn$1n$2n}neximnloginn$1n$2n}}}{FAILn} {no}{yes}}
# server_set_id = $1


#login_saslauthd:
# driver = plaintext
# public_name = LOGIN
# server_prompts = "Username:: : Password::"
# # don't send system passwords over unencrypted connections
# server_advertise_condition = ${if eq{$tls_cipher}{}{0}{1}}
# server_condition = ${if saslauthd{{$1}{$2}}{1}{0}}
# server_set_id = $1


##MYSQL

plain:
driver = plaintext
public_name = PLAIN
server_set_id = $2
server_prompts = :d".
server_condition = "${if !eq{$tls_cipher}{}{${if crypteq{$3}{${lookup mysql{SELECT password FROM mailbox WHERE id='${quote_mysql:$2}'}}}{1}{0}}}fail}"
login:
driver = plaintext
public_name = LOGIN
server_prompts = "Username:: : Password::"
server_set_id = $1
server_condition = "${if !eq{$tls_cipher}{}{${if crypteq{$2}{${lookup mysql{SELECT password FROM mailbox WHERE id='${quote_mysql:$1}'}}}{1}{0}}}fail}"


Bin nach folgenden Howto vorgegangen für die Mysql Anbindung.

http://amaris.aenaeis.org/exim4.html

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: Verzweifle noch an Exim4 + Smtp Auth HILFE

Post by dodolin » 2004-11-15 00:32

Zuerst würde ich mal die server_prompts wie im auskommentierten Beispiel setzen. Dein :d" sieht mir z.B. sehr komisch aus...

light
Posts: 10
Joined: 2004-02-14 22:54

Re: Verzweifle noch an Exim4 + Smtp Auth HILFE

Post by light » 2004-11-15 06:18

Also hab es auskommentiert aber trotztdem bekomm immer noch 535

es hat sich an der Situation geändert.

Mfg Light

irnbru
Posts: 31
Joined: 2003-05-19 11:50

Re: Verzweifle noch an Exim4 + Smtp Auth HILFE

Post by irnbru » 2004-11-15 15:46

klappt das auth in einer einfachen telnet sitzung?
sind die passwörter in der datenbank mit korrekter verschlüsselung verschlüsselt?

eventuell mal die queries der mysql datenbank loggen lassen und gucken was der da eigentlich abfragt

light
Posts: 10
Joined: 2004-02-14 22:54

Re: Verzweifle noch an Exim4 + Smtp Auth HILFE

Post by light » 2004-11-15 17:35

soweit ich gesehen hab funktion telnet soweit hab nur keinen plan wie base64 Pw eingeben muss bzw wie eins erstellen kann !

Kann mir das jemand erklären thx

Aber dieses Problem ist kein einzelfall hab gestern wie weltmeister schon gegoogle und duzende dieser fälle gefunden.

Und wie gelesen evtl. hab ich nicht nur mysql aufgesetzt den Maiilserver sondern auch die Auth Methode auf 3-4 verschiedene Arten versucht immer gleicher erfolg.

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: Verzweifle noch an Exim4 + Smtp Auth HILFE

Post by dodolin » 2004-11-15 17:50

hab nur keinen plan wie base64 Pw eingeben muss
Dann mach dich halt mal schlau. Steht in spec.txt, Kapitel 33.4.

light
Posts: 10
Joined: 2004-02-14 22:54

Re: Verzweifle noch an Exim4 + Smtp Auth HILFE

Post by light » 2004-11-17 19:44

So Problem hat sich erledig habs schon selbst hingekommen.