Mysql von 4.0.15 auf 4.0.22 update schlägt fehl

MySQL, PostgreSQL, SQLite
jürgen2372
Posts: 17
Joined: 2004-08-31 23:00

Mysql von 4.0.15 auf 4.0.22 update schlägt fehl

Post by jürgen2372 » 2004-11-11 13:18

Hab von mysql.com mir das rpm gezogen MySQL-server-4.0.22-0.i386.rpm und wollt den auf mein Suse 9.0 draufmachen.

rpm -ivh MySQL-server-4.0.22-0.i386.rpm

Fehler:

Code: Select all

file /usr/bin/perror from install of MySQL-server-4.0.22-0 conflicts with file from package mysql-client-4.0.15-13
file /usr/bin/replace from install of MySQL-server-4.0.22-0 conflicts with file from package mysql-client-4.0.15-13
file /usr/share/man/man1/perror.1.gz from install of MySQL-server-4.0.22-0 conflicts with file from package mysql-client-4.0.15-13
file /usr/share/man/man1/replace.1.gz from install of MySQL-server-4.0.22-0 conflicts with file from package mysql-client-4.0.15-13
file /etc/init.d/mysql from install of MySQL-server-4.0.22-0 conflicts with file from package mysql-4.0.15-67
file /etc/logrotate.d/mysql from install of MySQL-server-4.0.22-0 conflicts with file from package mysql-4.0.15-67
file /etc/my.cnf from install of MySQL-server-4.0.22-0 conflicts with file from package mysql-4.0.15-67
file /usr/bin/isamchk from install of MySQL-server-4.0.22-0 conflicts with file from package mysql-4.0.15-67
file /usr/bin/isamlog from install of MySQL-server-4.0.22-0 conflicts with file from package mysql-4.0.15-67
file /usr/bin/my_print_defaults from install of MySQL-server-4.0.22-0 conflicts with file from package mysql-4.0.15-67
file /usr/bin/myisamchk from install of MySQL-server-4.0.22-0 conflicts with file from package mysql-4.0.15-67
file /usr/bin/myisamlog from install of MySQL-server-4.0.22-0 conflicts with file from package mysql-4.0.15-67
file /usr/bin/myisampack from install of MySQL-server-4.0.22-0 conflicts with file from package mysql-4.0.15-67
file /usr/bin/mysql_fix_privilege_tables from install of MySQL-server-4.0.22-0 conflicts with file from package mysql-4.0.15-67
file /usr/bin/mysql_install_db from install of MySQL-server-4.0.22-0 conflicts with file from package mysql-4.0.15-67
file /usr/bin/mysql_secure_installation from install of MySQL-server-4.0.22-0 conflicts with file from package mysql-4.0.15-67
file /usr/bin/mysqlbug from install of MySQL-server-4.0.22-0 conflicts with file from package mysql-4.0.15-67
file /usr/bin/mysqld_multi from install of MySQL-server-4.0.22-0 conflicts with file from package mysql-4.0.15-67
file /usr/bin/mysqld_safe from install of MySQL-server-4.0.22-0 conflicts with file from package mysql-4.0.15-67
file /usr/bin/mysqlhotcopy from install of MySQL-server-4.0.22-0 conflicts with file from package mysql-4.0.15-67
file /usr/bin/mysqltest from install of MySQL-server-4.0.22-0 conflicts with file from package mysql-4.0.15-67
file /usr/bin/pack_isam from install of MySQL-server-4.0.22-0 conflicts with file from package mysql-4.0.15-67
file /usr/bin/resolve_stack_dump from install of MySQL-server-4.0.22-0 conflicts with file from package mysql-4.0.15-67
file /usr/bin/resolveip from install of MySQL-server-4.0.22-0 conflicts with file from package mysql-4.0.15-67
file /usr/lib/mysql/mysqld.sym from install of MySQL-server-4.0.22-0 conflicts with file from package mysql-4.0.15-67
file /usr/sbin/mysqld from install of MySQL-server-4.0.22-0 conflicts with file from package mysql-4.0.15-67
file /usr/share/info/mysql.info.gz from install of MySQL-server-4.0.22-0 conflicts with file from package mysql-4.0.15-67
file /usr/share/man/man1/isamchk.1.gz from install of MySQL-server-4.0.22-0 conflicts with file from package mysql-4.0.15-67
Muss ich zuvor die alte 4.0.15 (mit rpm -e) deinstallieren? Will das nicht einfach so machen, ohne vorher Eure Meinung zu hören, ist ja nen laufender Server.

Weiss jemand von Problemen, wenn ich gleich von 4.0.15 auf 4.1.7 update?

Danke

pfalzpower
Posts: 90
Joined: 2003-10-28 22:37
Location: Karlsruhe

Re: Mysql von 4.0.15 auf 4.0.22 update schlägt fehl

Post by pfalzpower » 2004-11-15 12:43

wieso willste die RPM's neu installieren und nicht nur updaten?
Welche anderen Pakete er noch upgedatet haben will, sagt er ja, z.b. mysql-client, mysql-server, mysql

jürgen2372
Posts: 17
Joined: 2004-08-31 23:00

Re: Mysql von 4.0.15 auf 4.0.22 update schlägt fehl

Post by jürgen2372 » 2004-11-17 17:52

Update gleiches Ergebnis. Hat jemand ne sinnvolle Idee/Vorschlag?

User avatar
Joe User
Project Manager
Project Manager
Posts: 11137
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Mysql von 4.0.15 auf 4.0.22 update schlägt fehl

Post by Joe User » 2004-11-17 18:26

Code: Select all

rpm -e $oldmysql
rpm -ivh $newmysql
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.